Ubuntu

Add/Remove in Ubuntu 8.04 not working

Asked by Garret on 2009-03-05

I am running Ubuntu 8.04 and at current the server kernel. For a bit now when I open Add/Remove programs and refresh nothing is listed to be browsed, chosen, or installed.

Further, if I change the options in "Show" there is now change, including if I filter on "Installed Applications Only." Now, Synaptic and Apt-Get are working fine.

Back to the issue, Search does not work - nothing is found; but help does.

Thank you,

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-app-install Edit question
Assignee:
No assignee Edit question
Solved by:
Dave
Solved:
2009-03-17
Last query:
2009-03-17
Last reply:
2009-03-16
Garret (atticstorm-gmail) said : #1

PS: Is there a way here to upload a file - I can post a screen shot.

Bhavani Shankar (bhavi) said : #2

Please paste the output of

sudo apt-get update

sudo apt-get upgrade

Garret (atticstorm-gmail) said : #3

xxxxxxxx@xxxxxxx-lapt:~$ sudo apt-get update
Hit http://download.virtualbox.org hardy Release.gpg
Ign http://download.virtualbox.org hardy/non-free Translation-en_US
Ign http://ppa.launchpad.net hardy Release.gpg
Ign http://ppa.launchpad.net hardy/main Translation-en_US
Hit http://archive.canonical.com hardy Release.gpg
Ign http://archive.canonical.com hardy/partner Translation-en_US
Hit http://packages.medibuntu.org hardy Release.gpg
Ign http://packages.medibuntu.org hardy/free Translation-en_US
Ign http://packages.medibuntu.org hardy/non-free Translation-en_US
Hit http://us.archive.ubuntu.com hardy Release.gpg
Ign http://us.archive.ubuntu.com hardy/main Translation-en_US
Hit http://security.ubuntu.com hardy-security Release.gpg
Ign http://security.ubuntu.com hardy-security/main Translation-en_US
Ign http://security.ubuntu.com hardy-security/restricted Translation-en_US
Hit http://download.virtualbox.org hardy Release
Get:1 http://ppa.launchpad.net hardy Release [27.6kB]
Hit http://archive.canonical.com hardy Release
Hit http://packages.medibuntu.org hardy Release
Ign http://us.archive.ubuntu.com hardy/restricted Translation-en_US
Ign http://us.archive.ubuntu.com hardy/universe Translation-en_US
Ign http://us.archive.ubuntu.com hardy/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com hardy-updates Release.gpg
Ign http://us.archive.ubuntu.com hardy-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com hardy-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com hardy-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com hardy-updates/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com hardy-backports Release.gpg
Ign http://us.archive.ubuntu.com hardy-backports/main Translation-en_US
Ign http://security.ubuntu.com hardy-security/universe Translation-en_US
Ign http://security.ubuntu.com hardy-security/multiverse Translation-en_US
Hit http://security.ubuntu.com hardy-security Release
Ign http://ppa.launchpad.net hardy/main Packages
Hit http://download.virtualbox.org hardy/non-free Packages
Hit http://archive.canonical.com hardy/partner Packages
Hit http://packages.medibuntu.org hardy/free Packages
Ign http://us.archive.ubuntu.com hardy-backports/restricted Translation-en_US
Ign http://us.archive.ubuntu.com hardy-backports/universe Translation-en_US
Ign http://us.archive.ubuntu.com hardy-backports/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com hardy Release
Ign http://ppa.launchpad.net hardy/main Sources
Hit http://us.archive.ubuntu.com hardy-updates Release
Hit http://security.ubuntu.com hardy-security/main Packages
Hit http://archive.canonical.com hardy/partner Sources
Hit http://packages.medibuntu.org hardy/non-free Packages
Hit http://us.archive.ubuntu.com hardy-backports Release
Hit http://ppa.launchpad.net hardy/main Packages
Hit http://us.archive.ubuntu.com hardy/main Packages
Hit http://us.archive.ubuntu.com hardy/restricted Packages
Hit http://us.archive.ubuntu.com hardy/main Sources
Hit http://us.archive.ubuntu.com hardy/restricted Sources
Hit http://us.archive.ubuntu.com hardy/universe Packages
Hit http://security.ubuntu.com hardy-security/restricted Packages
Hit http://security.ubuntu.com hardy-security/main Sources
Hit http://security.ubuntu.com hardy-security/restricted Sources
Hit http://security.ubuntu.com hardy-security/universe Packages
Hit http://us.archive.ubuntu.com hardy/universe Sources
Hit http://us.archive.ubuntu.com hardy/multiverse Packages
Hit http://ppa.launchpad.net hardy/main Sources
Hit http://us.archive.ubuntu.com hardy/multiverse Sources
Hit http://us.archive.ubuntu.com hardy-updates/main Packages
Hit http://us.archive.ubuntu.com hardy-updates/restricted Packages
Hit http://us.archive.ubuntu.com hardy-updates/main Sources
Hit http://us.archive.ubuntu.com hardy-updates/restricted Sources
Hit http://us.archive.ubuntu.com hardy-updates/universe Packages
Hit http://us.archive.ubuntu.com hardy-updates/universe Sources
Hit http://security.ubuntu.com hardy-security/universe Sources
Hit http://security.ubuntu.com hardy-security/multiverse Packages
Hit http://security.ubuntu.com hardy-security/multiverse Sources
Hit http://us.archive.ubuntu.com hardy-updates/multiverse Packages
Hit http://us.archive.ubuntu.com hardy-updates/multiverse Sources
Hit http://us.archive.ubuntu.com hardy-backports/main Packages
Hit http://us.archive.ubuntu.com hardy-backports/restricted Packages
Hit http://us.archive.ubuntu.com hardy-backports/universe Packages
Hit http://us.archive.ubuntu.com hardy-backports/multiverse Packages
Fetched 1B in 1s (1B/s)
Reading package lists... Done
xxxxxxxx@xxxxxxx-laptop:~$

Garret (atticstorm-gmail) said : #4

xxxxxxxx@xxxxxxx-laptop:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
xxxxxxxx@xxxxxxx-laptop:~$

Garret (atticstorm-gmail) said : #5

Also, I have tried:

      sudo apt-get autoclean
      sudo apt-get autoremove

With no change/help Add/Remove is still broken

Bhavani Shankar (bhavi) said : #6

Hmm the thing is fine

Open a terminal and type:

cat /etc/apt/sources.list

Copy/Paste the output here.

Garret (atticstorm-gmail) said : #7

----------------------------------
# deb cdrom:[Ubuntu 8.04.1 _Hardy Heron_ - Release i386 (20080702.1)]/ hardy main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://us.archive.ubuntu.com/ubuntu/ hardy main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ hardy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ hardy-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ hardy-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://us.archive.ubuntu.com/ubuntu/ hardy universe
deb-src http://us.archive.ubuntu.com/ubuntu/ hardy universe
deb http://us.archive.ubuntu.com/ubuntu/ hardy-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ hardy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ hardy multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ hardy multiverse
deb http://us.archive.ubuntu.com/ubuntu/ hardy-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ hardy-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ hardy-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu hardy partner
deb-src http://archive.canonical.com/ubuntu hardy partner

deb http://security.ubuntu.com/ubuntu hardy-security main restricted
deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted
deb http://security.ubuntu.com/ubuntu hardy-security universe
deb-src http://security.ubuntu.com/ubuntu hardy-security universe
deb http://security.ubuntu.com/ubuntu hardy-security multiverse
deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse

## VirtualBox Install and Update
deb http://download.virtualbox.org/virtualbox/debian hardy non-free
deb http://ppa.launchpad.net/do-core/ubuntu hardy main
deb-src http://ppa.launchpad.net/do-core/ubuntu hardy main
---------------------------------------------

Thank you, this has been most helpful. I asked several questions on the Ubuntu IRC channel and no one would respond.

Andy Ruddock (andy-ruddock) said : #8

Do you get any useful information if you run /usr/bin/gnome-app-install from a terminal window?

Garret (atticstorm-gmail) said : #9

No change. When I run the Add/Remove opens and no selections are available. I get the same "There are no matching applications available." message and it shows "All" in the upper left; Show has "All available applications" and Search is blank.

I did it again with "sudo /usr/bin/gnome-app-install" with the same above results.

Dave (davedname) said : #10

I'm also having this problem, synaptic works fine thought.

Best Dave (davedname) said : #11

OK, so I've fixed this by running synaptic and doing a complete removal of gnome-app-install and the re-installing it.

Garret (atticstorm-gmail) said : #12

Thanks Dave, that solved my question.