APT not working behind an autheticated proxy

Asked by peloas on 2006-02-20

I was trying to install some packages, I am behind a firewall with authentication, but the application "add applications" is unable to pass trough - doesn't pop-up any windows foe proxy authentication.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gnome-app-install Edit question
Assignee:
No assignee Edit question
Last query:
2006-02-20
Last reply:
2006-07-04
Bajtalan Hunor (cerebellum) said : #1

Hello,

In my opinion the problem is with the firewall. If you are just a home user and when you are using linux you don't need a firewall. The problem is that firewalls control not jsut your internet access but your programs access to internet too, they open some ports (gates to the net) and probably the port which is used by apt is closed by your firewall. My suggestion is that if you are a home user than just simply delete your firewall settings in terminal by writing sudo iptables --flush.

If you would like to remain secure from hackers because you have important information on your computer than configure your firewall and enable apt in order to reach the net. You should use firestarter.

Info on installing firestarter: http://ubuntuguide.org/

Info on configuring and using firestarter: http://techrepublic.com.com/5100-1009_11-5708627.html

Flávio Etrusco (etrusco) said : #2

Indeed, it would be very nice to have visual feedback on proxy authentication errors.
If you are not experienced with setting up proxies on "Linux systems" (1) you may be missing some detail in the string. It's quite tricky...
Also, what kind of firewall are you using? It isn't a
 MS ISA, is it?

(1) As a matter of fact, "GNU system" would be more correct here ;-)

peloas (peloas2001) said : #3

Thank you for your answer,
 ...but is quite far from what's happening, - my fault because I was quite quick in sending the this request.
 Error is 407 (authentication proxy required) - the problem is that specifying the proxy characteristiques in the configuration file (apt.conf - if I remember well - I already uninstalled it - sorry) - doesn't work at all.
 The format was the standard one: http://username:pass@proxyadress:port. (in fact as described in the examples provided with the system)

 Setting the http_proxy system variable in a shell, the launching from that shell any update tool (apt or synaptic, ...) it works. So my real problem is with the fact that's not working with the configuration file of apt or whatever.
 Another problem is when you have really complicated passwords with special characters...

 Maybe the request should be addressed to the apt developers & not to you, but you (ubuntu) choosed to work with apt, I tried to update my ubuntu installations so that's why I addressed to you.

 You were a little bit nasty in your comment (about the firewall) but I forgive you :) because I really loved your "human" theme.
 Fyi, the proxy is a squid installation on a solaris (10) system (SFV490)

 The real problem is the fact that the application (apt) seems totally ignoring the configuration file, so here we are..

 Thank you,
 Br
 FP

etrusco <email address hidden> wrote: Support request #390 on Ubuntu changed:
https://launchpad.net/distros/ubuntu/+ticket/390

Comment:
Indeed, it would be very nice to have visual feedback on proxy authentication errors.
If you are not experienced with setting up proxies on "Linux systems" (1) you may be missing some detail in the string. It's quite tricky...
Also, what kind of firewall are you using? It isn't a
 MS ISA, is it?

(1) As a matter of fact, "GNU system" would be more correct here ;-)

---------------------------------
Brings words and photos together (easily) with
 PhotoMail - it's free and works with Yahoo! Mail.

Gustavo Azambuja (gazambuja) said : #4

I have same error with ISA Server, i configure all and synaptic not update.

sorry, my english is not good.

Can you help with this problem?

Provide an answer of your own, or ask peloas for more information if necessary.

To post a message you must log in.