display problem

Asked by Griffinspc on 2006-01-30

I just loaded Ubuntu and things went fine however I'm stuck at 640 x 480 60Hz. I downloaded NVIDIA-Linux-x86-1.0-8178-pkg1.run
from Nvidia but can't figure; 1. is it the right file and 2. how the heck do i install or upgrade Linux drivers?
Thanks

ttp://www.nvidia.com/object/linux_display_ia32_1.0-8178.html

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-app-install Edit question
Assignee:
No assignee Edit question
Solved by:
Nicolas Kassis
Solved:
2006-02-09
Last query:
2006-02-12
Last reply:
2006-02-09
Griffinspc (griffinspc) said : #1

I guess I should have included the board model. It's a Nvidia GeForce2 MX/MX 400. Also this is my first experience away from Windows.

You should be able to modify the resolution from the system-> preferences -> screen resolution menu item. If this only allows you to used 640x480 than you need to post the following thing here so I can help better. post the file found at /etc/X11/xorg.conf it's a simple test file so you can open it with any text editor. If you can just post the section called "screen" the resolution and stuff should be available there.

To install the nvidia drivers just follow the instructions found here you don't need to read the official nvidia page since the ubuntu wiki shows you a simpler and better way of installing them :

https://wiki.ubuntu.com/BinaryDriverHowto/Nvidia?highlight=%28nvidia%29%7C%28drivers%29

hope it helps.

Nic

Griffinspc (griffinspc) said : #3

I'll get the file for you tonight if I ever get off work. Yes, the only resolution and refresh I'm offered is 640 x 480 & 60Hz in the screen resolution preferences. Thanks for the wiki solution which I'll try tonight too. The Nvidia page(s) are long and convoluted to say the least.

Griffinspc (griffinspc) said : #4

OK I finally got some time, the package install went fine I think. I'm recieving the Nvidia splash screen at boot but still no options for changing the resolution/refresh rate.

I also found an article in the January 2006 issue of MaximumPC that details an installation of Ubuntu and it has screenshots of the install. Every screenshot there was exactly what I encountered except one, it has a configuring Xserver screen for choosing a resolution that I was never prompted for during my installation.

At any rate, what would be my next step.

Well the probable reason is the only screen resolution in you /etc/X11/xorg.conf is set to 640x 480. Try changing the resolution by hand in the sceen section. You are probably using 24-bit colors. so here is what your screen section in that file probably looks like right now :

Section "Screen"
 Identifier "Default Screen"
 Device "Something to about nvidida"
 Monitor "Generic Monitor"
 DefaultDepth 24
 SubSection "Display"
  Depth 1
  Modes "640x480"
 EndSubSection

and some more sections for other color depth
make a copy of the file using this
sudo cp /etc/X11/xorg.conf{,-bak}

If something goes wrong you can log in on a text console and do the oposite
sudo cp /etc/X11/xorg.conf{-bak,}

Now add before "640x480" to the Modes line the resolution you want. Such as "1024x768"
after that log out and use ctrl+alt+backspace to restart x and it should now work.

Hope it's clear

Griffinspc (griffinspc) said : #6

I tried your approach above but couldn't get it to stick. I found the answer here: https://wiki.ubuntu.com/FixVideoResolutionHowto

The top "Run the Autodetect Script Again" worked perfectly. I now have 4 chosen and available resolutions and 3 choices for refresh rates in the System/Preferences/Screen Resolution option window.

Thanks for your help though. It eventually led me in the right direction.