Package installer

Asked by De Silva on 2008-03-22

I am trying to install limewire, music sharing software. It downloaded all necessary files but now stuck on Java sun6 bin.
I tried it once on another computer (running Ubuntu) and as it was taking a long time, I terminated the program.
Now when I try to install any thing, it has a message- run (dpkg --configure a
But when I run this command on terminal it says that I have to be a superuser!
Help please.

Bhavani Shankar (bhavi) said : #1

Hello Desilva:

Sudo command is used for super user access in ubuntu

Type the following command in a terminal:

sudo dpkg --configure -a

and press enter key

(you wont get any output if there are no errors, if there are errors you ll get output)


Bhavani Shankar.

Vojtěch Trefný suggests this article as an answer to your question:
FAQ #52: “Can't install new software and updates”.

Best Thomas Lang (thht) said : #3

Another way to install Java:

1) In the Menu - Bar in the upper left corner, klick "Applications" > "Add / Remove Software"
2) type "Java" in the "Search" field and select "show: 'all available applications' " in the upper right corner
3) Check the box for "Sun Java 6 Web Start" Software
4) Click "Install Software" (lower right corner)

Best Regards,

Thomas Lang

De Silva (l-desilva) said : #4

Thanks. I ran that on terminal. There were various messages flickering through for few minutes and then it stopped with the following.

Setting up odbcinst1debian1 (2.2.11-16) ...

Setting up unixodbc (2.2.11-16) ...

Setting up gcc-3.3-base (1:3.3.6-15ubuntu2) ...
Setting up libstdc++5 (1:3.3.6-15ubuntu2) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place

De Silva (l-desilva) said : #5

Thanks everyone
This may sound bit stupid but I will ask it anyway.
I followed your advice and package installer was successful in installing bot Java and Limewire. Now I can not find the package, I do not know where I installed it into

De Silva (l-desilva) said : #6

I finally found it and it is working. We are having fun with Ubuntu. Thanks everyone again.

De Silva (l-desilva) said : #7

Thanks Thomas Lang, that solved my question.