statoverride file problem

Asked by darren bridge on 2010-05-09

I cant install any updates or packages because there is a fatal fault with the stat override file.
The error report is 'unknown group 'gnokii' in statoverride file'
The line 'root gnokii 4750 /usr/sbin/mgnokiidev' is in the stateoverride file
gnokii is a package I had installed then it was removed.
this line is not in the _old file. How do I remove it from the statoverride file or restore back to the _old version

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gnome-app-install Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2010-05-11
Last query:
2010-05-11
Last reply:
2010-05-11

should`ve made myself clearer.
I cant modify the file statoverride because it says I am not the owner even though I log on as an Administrator, I guess I need to log on as root (superuser) but I dont know how.

Best Sam_ (and-sam) said : #3

Are you saying you're not able to open it with:
gksudo gedit /var/lib/dpkg/statoverride

No login as root needed, sudo is the rational way.
btw. any repairs can also be done from LiveCD or Recovery Mode.

Thanks Sam, that solved my question.

a ha. thats done it. thanks...
I was going at it all wrong. when I opened gedit from the gui i couldnt do any thing with the file..
New to Linux.. have only just woken up from windows lol

Sam_ (and-sam) said : #6

> New to Linux...

is an essential info, thanks.
In case you're interested in some basics.
https://help.ubuntu.com/community/Signpost
https://help.ubuntu.com/community/CommonQuestions
https://answers.launchpad.net/ubuntu/+faqs