the web page lookup for Intrepid shows gnash and related at 0.8.2 but apt seems unable to get newer than 0.8.1 from repository

Asked by GaryW

: #root@1i14z512(~) ;apt-get update
Hit intrepid-security Release.gpg
Ign intrepid-security/restricted Translation-en_GB
Hit intrepid-updates Release.gpg
Ign intrepid-updates/main Translation-en_GB
Ign intrepid-updates/restricted Translation-en_GB
Ign intrepid-security/main Translation-en_GB
Ign intrepid-security/multiverse Translation-en_GB
Ign intrepid-security/universe Translation-en_GB
Hit intrepid-security Release
Ign intrepid-updates/universe Translation-en_GB
Ign intrepid-updates/multiverse Translation-en_GB
Hit intrepid-updates Release
Hit intrepid-security/restricted Packages
Hit intrepid-security/main Packages
Hit intrepid-security/multiverse Packages
Hit intrepid-security/universe Packages
Hit intrepid-updates/main Packages
Get: 1 intrepid Release.gpg [189B]
Hit intrepid-updates/restricted Packages
Hit intrepid-updates/universe Packages
Hit intrepid-updates/multiverse Packages
Get: 2 intrepid/main Translation-en_GB [30.2kB]
Get: 3 intrepid-updates Release.gpg [191B]
Ign intrepid-updates/main Translation-en_GB
Get: 4 intrepid Release [65.9kB]
Get: 5 intrepid-updates Release [37.0kB]
Get: 6 intrepid/main Packages [1228kB]
Get: 7 intrepid-updates/main Packages [14B]
Get: 8 intrepid-updates/main Sources [14B]
Get: 9 intrepid-updates/restricted Sources [14B]
Fetched 1361kB in 11s (116kB/s)
Reading package lists... Done
: #root@1i14z512(~) ;apt-get --no-act install gnash gnash-common mozilla-plugin-gnash
Reading package lists... Done
Building dependency tree
Reading state information... Done
gnash is already the newest version.
gnash-common is already the newest version.
mozilla-plugin-gnash is already the newest version.
The following packages were automatically installed and are no longer required:
  linux-image-generic linux-restricted-modules-2.6.20-15-generic
  linux-image-2.6.22-14-386 linux-image-2.6.20-15-generic
  linux-ubuntu-modules-2.6.22-14-386 libkdeedu4
  linux-restricted-modules-2.6.22-14-generic linux-image-2.6.22-14-generic
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
: #root@1i14z512(~) ;

#So apt cannot help me get newer than 0.8.1 so I download them manually from webpage links choosing mirror of as example shows here:

and then when I have all 3 debs I want proceed to install them as follows:
dpkg --install *gnash*
(Reading database ... 177290 files and directories currently installed.)
Preparing to replace gnash 0.8.1-0ubuntu3 (using gnash_0.8.2-0ubuntu3_i386.deb) ...
Unpacking replacement gnash ...
Preparing to replace gnash-common 0.8.1-0ubuntu3 (using gnash-common_0.8.2-0ubuntu3_i386.deb) ...
Unpacking replacement gnash-common ...
Preparing to replace mozilla-plugin-gnash 0.8.1-0ubuntu3 (using mozilla-plugin-gnash_0.8.2-0ubuntu3_i386.deb) ...
Unpacking replacement mozilla-plugin-gnash ...
Setting up gnash-common (0.8.2-0ubuntu3) ...

Processing triggers for man-db ...
Setting up gnash (0.8.2-0ubuntu3) ...
Setting up mozilla-plugin-gnash (0.8.2-0ubuntu3) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place

#I did wonder whether the reason apt seemed unable to fetch 0.8.2 itself was because of some dependency missing but
#dpkg did not complain when I manually installed so still puzzled.

: #root@1i14z512(~) ;cat /etc/lsb-release ;uname -a
DISTRIB_DESCRIPTION="Ubuntu intrepid (development branch)"
Linux i14z512 2.6.27-2-generic #1 SMP Thu Aug 28 17:20:02 UTC 2008 i686 GNU/Linux

Question information

English Edit question
Ubuntu gnash Edit question
No assignee Edit question
Solved by:
Alan Pope 🍺🐧🐱 πŸ¦„
Last query:
Last reply:
Revision history for this message
Best Alan Pope 🍺🐧🐱 πŸ¦„ (popey) said :

Can you post your sources.list?

I suspect you're missing an entry for the "universe" section of Intrepid.

Revision history for this message
GaryW (gnubyexample) said :

Have now added a suitable universe entry which you correctly suggested I was missing.

: #useri@1i14z512(~) ;cat /etc/apt/sources.list.d/intrepid-universe-mirrorservice.list
deb intrepid universe
#deb intrepid-updates universe
#updates are handled in the main sources.list file

Thought my upgrade had finished but now I have added universe correctly another 97 packages are being moved up from Gutsy to Intrepid. Looks like most of them are okay with just the occassional 404:
: #root@1i14z512(sources.list.d) ;apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  chromium clamav clamav-daemon clamav-freshclam djview gcc-3.4-base gnuplot-nox gnuplot-x11
  gstreamer0.10-ffmpeg gurlchecker libalut0 libgda2-3 libsyslog-ruby libthunar-vfs-1-2 mcpp neverball pspp
  r-base-core serpentine swi-prolog syslog-ng thunar thunar-data trophy xfce4-panel xfce4-terminal
The following packages will be upgraded:
  amor antiword apparmor-profiles arj armagetron armagetronad armagetronad-common bluemon bluetooth-alsa
  brutalchess childsplay chromium-data circuslinux circuslinux-data clamav-base console-tools dhcdbd
  djvulibre-bin djvulibre-plugin dvi2tty esound fdutils fillets-ng fillets-ng-data fping freedroid
  freedroid-data fwlogwatch galeon galeon-common gltron gnome-btdownload gnome-volume-manager grip gs-esp-x
  gstreamer0.10-plugins-ugly htdig k3dsurf kbd-compat kdirstat liba52-0.7.4 libconsole libdb4.3 libdb4.4
  libdvdread3 libedataserver1.2-9 libelfg0 libexo-0.3-0 libgda2-common libgksu1.2-1 libgnet2.0-0
  libgnome-desktop-2 libgucharmap6 libmpeg2-4 libnss3-0d libopenal0a libpam-foreground libpoppler2 libsbc0
  libsdl-console libsdl-gfx1.2-4 libsdl-net1.2 libsdl-sound1.2 libsidplay1 libsoup2.2-8 libstdc++5
  libxfce4mcs-client3 libxfce4mcs-manager3 libxfce4util4 libxfcegui4-4 mason menu menu-xdg molly-guard
  music-applet pachi pachi-data pdfcrack pinball pinball-data python-pygame python-xml r-base-html r-doc-html
  r-doc-pdf rssh sound-juicer supertux supertux-data swi-prolog-doc syslog-summary trophy-data unace uruk xdm
  xfmedia xpmutils
97 upgraded, 0 newly installed, 0 to remove and 26 not upgraded.
Need to get 198MB of archives.
After this operation, 33.8MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get: 1 intrepid/universe xdm 1:1.1.8-4 [194kB]
Err intrepid/universe amor 4:4.1.0-0ubuntu2
  404 Not Found [IP: 80]
Get: 2 intrepid/universe antiword 0.37-3 [152kB]
Get: 3 intrepid/universe arj 3.10.22-6 [224kB]
Get: 4 intrepid/universe armagetronad-common [281kB]
Get: 5 intrepid/universe armagetronad [1261kB]
Get: 6 intrepid/universe armagetron [7408B]
Get: 7 intrepid/universe bluemon 1.4-3 [24.9kB]
Get: 8 intrepid/universe brutalchess 0.5.2+dfsg-3 [806kB]
Get: 9 intrepid/universe python-pygame 1.8.1release-0ubuntu1 [1109kB]
Get: 10 intrepid/universe childsplay 0.85.1-1.1 [1819kB]
Get: 11 intrepid/universe chromium-data [1214kB]
Get: 12 intrepid/universe circuslinux-data 1.0.3-23 [1187kB]
Get: 13 intrepid/universe circuslinux 1.0.3-23 [37.7kB]
Err intrepid/universe clamav-base 0.93.3.dfsg-1
  404 Not Found [IP: 80]
Get: 14 intrepid/universe kbd-compat 1:0.2.3dbs-65.1ubuntu1 [46.6kB]
Get: 15 intrepid/universe console-tools 1:0.2.3dbs-65.1ubuntu1 [302kB]
Get: 16 intrepid/universe libconsole 1:0.2.3dbs-65.1ubuntu1 [83.1kB]
Get: 17 intrepid/universe dhcdbd 3.0-4ubuntu3 [50.6kB]
Err intrepid/universe djvulibre-bin 3.5.20-7ubuntu1
  404 Not Found [IP: 80]
Err intrepid/universe djvulibre-plugin 3.5.20-7ubuntu1
  404 Not Found [IP: 80]
Get: 18 intrepid/universe dvi2tty 5.3.1-4 [26.4kB]
Get: 19 intrepid/universe esound 0.2.38-0ubuntu9 [27.7kB]
Get: 20 intrepid/universe fdutils 5.5-20060227-2 [362kB]
Get: 21 intrepid/universe fillets-ng-data 0.8.0-1 [66.3MB]
Get: 22 intrepid/universe fillets-ng 0.8.0-2 [289kB]
Get: 23 intrepid/universe fping 2.4b2-to-ipv6-15 [30.0kB]
Get: 24 intrepid/universe freedroid 1.0.2+cvs040112-1.1ubuntu1 [141kB]
Get: 25 intrepid/universe freedroid-data 1.0.2+cvs040112-1.1ubuntu1 [5245kB]
Get: 26 intrepid/universe fwlogwatch 1.1-3 [131kB]
Get: 27 intrepid/universe galeon-common 2.0.6-2 [2878kB]
Get: 28 intrepid/universe galeon 2.0.6-2 [538kB]
Get: 29 intrepid/universe libsdl-net1.2 1.2.7-2 [11.5kB]
Get: 30 intrepid/universe libsdl-sound1.2 1.0.3-1 [100kB]
Get: 31 intrepid/universe gltron 0.70final-8ubuntu2 [1965kB]
Get: 32 intrepid/universe gnome-btdownload 0.0.30-2 [45.3kB]
Get: 33 intrepid/universe gnome-volume-manager 2.22.1-1ubuntu7 [164kB]
Get: 34 intrepid/universe grip 3.3.1-15 [463kB]
Get: 35 intrepid/universe gs-esp-x 8.63.dfsg.1-0ubuntu4 [28.9kB]
Get: 36 intrepid/universe liba52-0.7.4 0.7.4-11ubuntu1 [27.2kB]
Get: 37 intrepid/universe libdvdread3 0.9.7-11ubuntu1 [62.7kB]
Get: 38 intrepid/universe libmpeg2-4 0.4.1-3 [55.9kB]
Get: 39 intrepid/universe libsidplay1 1.36.59-5 [73.5kB]
Err intrepid/universe gstreamer0.10-plugins-ugly 0.10.8-1
  404 Not Found [IP: 80]
Get: 40 intrepid/universe htdig 1:3.2.0b6-6 [1852kB]
Get: 41 intrepid/universe k3dsurf 0.6.2-3 [1448kB]
Get: 42 intrepid/universe kdirstat 2.4.4-4 [275kB]
Get: 43 intrepid/universe libdb4.3 4.3.29-11ubuntu1 [421kB]
Get: 44 intrepid/universe libdb4.4 4.4.20-11 [474kB]
Get: 45 intrepid/universe libedataserver1.2-9 2.22.2-1ubuntu1 [109kB]
Get: 46 intrepid/universe libelfg0 0.8.10-2 [52.8kB]
Get: 47 intrepid/universe libxfce4util4 4.4.2-3ubuntu1 [59.2kB]
Get: 48 intrepid/universe libexo-0.3-0 0.3.4-7ubuntu3 [680kB]
Get: 49 intrepid/universe libgda2-common 1.2.4-1.1 [287kB]
Get: 50 intrepid/universe libgksu1.2-1 1.3.8-1ubuntu4 [23.3kB]
Err intrepid/main libgnet2.0-0 2.0.8-1
  404 Not Found [IP: 80]
Get: 51 intrepid/universe libgnome-desktop-2 1:2.23.2-0ubuntu1 [93.9kB]
Err intrepid/universe libgucharmap6 1:2.22.1-1ubuntu1
  404 Not Found [IP: 80]
Get: 52 intrepid/universe libnss3-0d [17.7kB]
Err intrepid/universe libopenal0a 1:0.0.8-8
  404 Not Found [IP: 80]
Get: 53 intrepid/universe libpam-foreground 0.5 [8116B]
Err intrepid/universe libpoppler2 0.6.4-1ubuntu1
  404 Not Found [IP: 80]
Get: 54 intrepid/universe libsdl-console 1.3-5 [13.8kB]
Get: 55 intrepid/universe libsdl-gfx1.2-4 2.0.13-4 [43.5kB]
Get: 56 intrepid/universe libsoup2.2-8 2.2.105-4 [88.8kB]
Get: 57 intrepid/universe libstdc++5 1:3.3.6-17ubuntu1 [296kB]
Get: 58 intrepid/universe libxfce4mcs-client3 4.4.2-3 [20.8kB]
Get: 59 intrepid/universe libxfce4mcs-manager3 4.4.2-3 [23.8kB]
Get: 60 intrepid/universe libxfcegui4-4 4.4.2-4ubuntu1 [230kB]
Get: 61 intrepid/universe menu 2.1.40ubuntu1 [434kB]
Get: 62 intrepid/universe menu-xdg 0.3 [4750B]
Get: 63 intrepid/universe music-applet 2.3.1-1 [103kB]
Get: 64 intrepid/universe pachi 1:1.0-5 [30.6kB]
Get: 65 intrepid/universe pachi-data 1:1.0-5 [3031kB]
Get: 66 intrepid/universe pdfcrack 0.9-1 [22.5kB]
Get: 67 intrepid/universe pinball-data 0.3.1-7ubuntu2 [5544kB]
Get: 68 intrepid/universe pinball 0.3.1-7ubuntu2 [164kB]
Get: 69 intrepid/universe python-xml 0.8.4-10.1ubuntu1 [454kB]
Get: 70 intrepid/universe r-doc-html 2.7.1-2 [602kB]
Get: 71 intrepid/universe r-doc-pdf 2.7.1-2 [6678kB]
Get: 72 intrepid/universe rssh 2.3.2-7 [49.0kB]
Err intrepid/universe sound-juicer 2.23.2-0ubuntu1
  404 Not Found [IP: 80]
Get: 73 intrepid/universe supertux-data 0.3.1d-0ubuntu1 [44.3MB]
Get: 74 intrepid/universe supertux 0.3.1d-0ubuntu1 [721kB]
Get: 75 intrepid/universe swi-prolog-doc 5.6.50-1 [3927kB]
Get: 76 intrepid/universe syslog-summary 1.13-1 [9144B]
Get: 77 intrepid/universe trophy-data 1.1.5-1 [14.2MB]
Get: 78 intrepid/universe unace 1.2b-7 [16.6kB]
Get: 79 intrepid/universe uruk 20080330-1 [66.2kB]
Get: 80 intrepid/universe xfmedia 0.9.2-5 [661kB]
Get: 81 intrepid/universe xpmutils 1:3.5.7-1 [29.1kB]
Err intrepid/universe apparmor-profiles 2.3+1289-0ubuntu2
  404 Not Found [IP: 80]
Get: 82 intrepid/universe libsbc0 0.0cvs20070728-1 [15.1kB]
Get: 83 intrepid/universe bluetooth-alsa 0.5cvs20080115-1 [306kB]
Get: 84 intrepid/universe mason 1.0.0-11 [469kB]
Get: 85 intrepid/universe molly-guard 0.4.4-2 [11.5kB]
Get: 86 intrepid/universe r-base-html 2.7.1-2 [1245kB]
Fetched 177MB in 13min58s (212kB/s)
Failed to fetch 404 Not Found [IP: 80]
Failed to fetch 404 Not Found [IP: 80]
Failed to fetch 404 Not Found [IP: 80]
Failed to fetch 404 Not Found [IP: 80]
Failed to fetch 404 Not Found [IP: 80]
Failed to fetch 404 Not Found [IP: 80]
Failed to fetch 404 Not Found [IP: 80]
Failed to fetch 404 Not Found [IP: 80]
Failed to fetch 404 Not Found [IP: 80]
Failed to fetch 404 Not Found [IP: 80]
Failed to fetch 404 Not Found [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

#Most of those 404 are probably minor name changes or moves into 'main' from 'universe'
#One thing i will sort out is now that libgnome-desktop-2-7 is in 'main' I probably do not need libgnome-desktop-2 from 'universe'

Revision history for this message
GaryW (gnubyexample) said :

Thanks Alan Pope, that solved my question.