I got this error when I tried to install libgmp3: libgmp3-dev : Depends: libgmp-dev (= 2:5.1.3+dfsg-1ubuntu1) but 2:6.0.0+dfsg-6ubuntu1 is to be installed

Asked by Erinfolami Rukayat Ayomide on 2017-02-16

I am trying to run a program with depends on libgmp3. I found out that I already have libgmp 10 installed but that does not work for the program. Trying to install libgmp3 gave me this error: libgmp3-dev : Depends: libgmp-dev (= 2:5.1.3+dfsg-1ubuntu1) but 2:6.0.0+dfsg-6ubuntu1 is to be installed.

Please, how can this problem be resolved? Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gmp Edit question
Assignee:
No assignee Edit question
Last query:
2017-02-16
Last reply:
2017-02-17

What is the output of:

lsb_release -a; uname -a; apt-cache policy libgmp3 libgmp3-dev

Thanks

That's one command, it may wrap in your email or the forum web page but copy it as one command and run it. Copy the output and paste as an update on:
https://answers.launchpad.net/ubuntu/+source/gmp/+question/463668

Thanks

LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch
Distributor ID: Ubuntu
Here is the output of lsb_release -a; uname -a; apt-cache policy libgmp3 libgmp3-dev:

Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty
Linux dorchester 4.4.0-59-generic #80~14.04.1-Ubuntu SMP Fri Jan 6 18:02:02 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
libgmp3:
  Installed: (none)
  Candidate: (none)
  Version table:
libgmp3-dev:
  Installed: (none)
  Candidate: 2:5.1.3+dfsg-1ubuntu1
  Version table:
     2:5.1.3+dfsg-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Thanks.

Here is the output of lsb_release -a; uname -a; apt-cache policy libgmp3 libgmp3-dev:

LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:core-4.1-amd64:core-4.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 14.04.5 LTS
Release: 14.04
Codename: trusty
Linux dorchester 4.4.0-59-generic #80~14.04.1-Ubuntu SMP Fri Jan 6 18:02:02 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
libgmp3:
  Installed: (none)
  Candidate: (none)
  Version table:
libgmp3-dev:
  Installed: (none)
  Candidate: 2:5.1.3+dfsg-1ubuntu1
  Version table:
     2:5.1.3+dfsg-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Manfred Hampl (m-hampl) said : #5

What is the output of

apt-cache policy libgmp-dev

I got this :

libgmp-dev:
  Installed: 2:6.0.0+dfsg-6ubuntu1
  Candidate: 2:6.0.0+dfsg-6ubuntu1
  Version table:
 *** 2:6.0.0+dfsg-6ubuntu1 0
        100 /var/lib/dpkg/status
     2:5.1.3+dfsg-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

Manfred Hampl (m-hampl) said : #7

How did you install version 2:6.0.0+dfsg-6ubuntu1 of libgmp-dev ?
That is the version for vivid, and not the one for trusty!

What is the output of the command

dpkg -l | grep 6.0.0+dfsg-6ubuntu1

I got this for dpkg -l | grep 6.0.0+dfsg-6ubuntu1:

ii libgmp-dev:amd64 2:6.0.0+dfsg-6ubuntu1 amd64 Multiprecision arithmetic library developers tools
ii libgmp10:amd64 2:6.0.0+dfsg-6ubuntu1 amd64 Multiprecision arithmetic library
ii libgmpxx4ldbl:amd64 2:6.0.0+dfsg-6ubuntu1 amd64 Multiprecision arithmetic library (C++ bindings)

Manfred Hampl (m-hampl) said : #9

From what I see I conclude that you have already installed three gmp packages from a different Ubuntu release. If you now need an additional gmp package, you can either deinstall these three packages and install the standard version, or you have to try installing libgmp3-dev in the same wrong version as the others.

Do you have an idea where these gmp version 2:6.0.0+dfsg-6ubuntu1 packages are coming from?

No, I don't know how they got installed.

On Thu, Feb 16, 2017 at 3:08 PM, Manfred Hampl <
<email address hidden>> wrote:

> Your question #463668 on gmp in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gmp/+question/463668
>
> Status: Needs information => Answered
>
> Manfred Hampl proposed the following answer:
> >From what I see I conclude that you have already installed three gmp
> packages from a different Ubuntu release. If you now need an additional
> gmp package, you can either deinstall these three packages and install
> the standard version, or you have to try installing libgmp3-dev in the
> same wrong version as the others.
>
> Do you have an idea where these gmp version 2:6.0.0+dfsg-6ubuntu1
> packages are coming from?
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> https://answers.launchpad.net/ubuntu/+source/gmp/+question/
> 463668/+confirm?answer_id=8
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/gmp/+question/463668
>
> You received this question notification because you asked the question.
>

Do you suggest that I uninstall the versions of gmp that I currently have?

On Thu, Feb 16, 2017 at 3:22 PM, Erinfolami Rukayat Ayomide <
<email address hidden>> wrote:

> Your question #463668 on gmp in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gmp/+question/463668
>
> Status: Answered => Open
>
> You are still having a problem:
> No, I don't know how they got installed.
>
> On Thu, Feb 16, 2017 at 3:08 PM, Manfred Hampl <
> <email address hidden>> wrote:
>
> > Your question #463668 on gmp in Ubuntu changed:
> > https://answers.launchpad.net/ubuntu/+source/gmp/+question/463668
> >
> > Status: Needs information => Answered
> >
> > Manfred Hampl proposed the following answer:
> > >From what I see I conclude that you have already installed three gmp
> > packages from a different Ubuntu release. If you now need an additional
> > gmp package, you can either deinstall these three packages and install
> > the standard version, or you have to try installing libgmp3-dev in the
> > same wrong version as the others.
> >
> > Do you have an idea where these gmp version 2:6.0.0+dfsg-6ubuntu1
> > packages are coming from?
> >
> > --
> > If this answers your question, please go to the following page to let us
> > know that it is solved:
> > https://answers.launchpad.net/ubuntu/+source/gmp/+question/
> > 463668/+confirm?answer_id=8
> >
> > If you still need help, you can reply to this email or go to the
> > following page to enter your feedback:
> > https://answers.launchpad.net/ubuntu/+source/gmp/+question/463668
> >
> > You received this question notification because you asked the question.
> >
>
> --
> You received this question notification because you asked the question.
>

Manfred Hampl (m-hampl) said : #12

Due to the fact that I do not know the background why these versions are installed, I can neither recommend uninstalling nor keeping them.

To check the potential consequences of removing them, what is the output of
apt-get --simulate remove libgmp-dev libgmp10 libgmpxx4ldbl

Here is the output I got:

NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 alex : Depends: libgmp10 but it is not going to be installed
 cabal-install : Depends: libgmp10 but it is not going to be installed
 cpp-4.8 : Depends: libgmp10 but it is not going to be installed
 g++-4.8 : Depends: libgmp10 but it is not going to be installed
 gcc-4.8 : Depends: libgmp10 but it is not going to be installed
 ghc : Depends: libgmp-dev but it is not going to be installed
       Depends: libgmp10 but it is not going to be installed
 ghc-haddock : Depends: libgmp10 but it is not going to be installed
 guile-2.0-libs : Depends: libgmp10 but it is not going to be installed
 happy : Depends: libgmp10 but it is not going to be installed
 libcloog-isl4 : Depends: libgmp10 but it is not going to be installed
 libisl10 : Depends: libgmp10 but it is not going to be installed
 libmpc3 : Depends: libgmp10 but it is not going to be installed
 libmpfr4 : Depends: libgmp10 but it is not going to be installed
 librasqal3 : Depends: libgmp10 but it is not going to be installed
 linux-generic-lts-vivid : Depends: linux-image-generic-lts-vivid (= 3.19.0.80.62) but 3.19.0.79.61 is to be installed
                           Depends: linux-headers-generic-lts-vivid (= 3.19.0.80.62) but 3.19.0.79.61 is to be installed
 llvm-3.4-dev : Depends: libgmp10 but it is not going to be installed
 python-crypto : Depends: libgmp10 but it is not going to be installed
 python3-crypto : Depends: libgmp10 but it is not going to be installed
 stack : Depends: libgmp-dev but it is not going to be installed
 swi-prolog-nox : Depends: libgmp10 but it is not going to be installed
                  Depends: libgmp-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Manfred Hampl (m-hampl) said : #14

The output shows that several programs are dependent on libgmp10 and/or libgmp-dev.
I therefore recommend to better keep the existing versions of the already installed packages, and to add the libgmp3-dev package in the same (wrong) version.

Try downloading https://launchpad.net/ubuntu/+archive/primary/+files/libgmp3-dev_6.0.0+dfsg-6ubuntu1_amd64.deb and manually installing it (e.g. with "sudo dpkg --install /path/to/your/file")

I downloaded and installed the file, but I still get the same error when running the program: error while loading shared libraries: libgmp.so.3: cannot open shared object file: No such file or directory

I ran this command again "dpkg -l | grep 6.0.0+dfsg-6ubuntu1" and this is what I got:
ii libgmp-dev:amd64 2:6.0.0+dfsg-6ubuntu1 amd64 Multiprecision arithmetic library developers tools
ii libgmp10:amd64 2:6.0.0+dfsg-6ubuntu1 amd64 Multiprecision arithmetic library
ii libgmp3-dev 2:6.0.0+dfsg-6ubuntu1 amd64 Multiprecision arithmetic library developers tools
ii libgmpxx4ldbl:amd64 2:6.0.0+dfsg-6ubuntu1 amd64 Multiprecision arithmetic library (C++ bindings)

I can now find libgmp3-dev in the list, but the error still persists.

Manfred Hampl (m-hampl) said : #16

"error while loading shared libraries: libgmp.so.3: cannot open shared object file: No such file or directory" is something that you cannot solve by installing libgmp3-dev of trusty or vivid.

You would need a package that provides libgmp.so.3, but this does no more exist on current Ubuntu versions.
The only one I find is libgmp3c2 in precise, but I do not know whether this can be installed on trusty without problems.

You probably better search for an updated application that works with libgmp10 instead of libgmp3.

Okay. Thank you so much for your support.

Can you help with this problem?

Provide an answer of your own, or ask Erinfolami Rukayat Ayomide for more information if necessary.

To post a message you must log in.