Ubuntu

Can't configure gmailfs for normal user.

Asked by Shirish Agarwal on 2007-08-16

Hi all,
      I tried the latest 0.8.2 of gmailfs in gutsy (7.10 - tribe 4) & haven't been able to configure it right, I want that the user shirish should be able to upload stuff to gmail, other than root. I did change the appropriate mount point (/home/shirish/gmailfs) and the appropriate username, password & fsname as required.

  I tried the following stuff :-

As per the manpage at mount.gmailfs one could either do :-

 mount -t gmailfs none /path/of/mount/point -o username=gmailuser,password=gmailpass,fsname=zOlRRa

 mount.gmailfs none /mnt -o username=gmailuser,password=gmailpass,fsname=zOlRRa

now the mount command needs a superuser or sudo status, if I try to mount with my own I get :-

mount -t gmailfs none /path/of/mount/point -o username=gmailuser,password=gmailpass,fsname=zOlRRa

mount: only root can do that

If I mount the same with sudo then the ownership of the directory is only with root & shirish cannot access or do anything to it.

Doing a sudo mount -t gmailfs none /path/of/mount/point -o username=gmailuser,password=gmailpass,fsname=zOlRRa,uid=1000 gives me :-

[sudo] password for shirish:
Usage: mount -V : print version
       mount -h : print this help
       mount : list mounted filesystems
       mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
       mount -a [-t|-O] ... : mount all stuff from /etc/fstab
       mount device : mount device at the known place
       mount directory : mount known device here
       mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
       mount --bind olddir newdir
or move a subtree:
       mount --move olddir newdir
One can change the type of mount containing the directory dir:
       mount --make-shared dir
       mount --make-slave dir
       mount --make-private dir
       mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
       mount --make-rshared dir
       mount --make-rslave dir
       mount --make-rprivate dir
       mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .

I also tried putting it in /etc/fstab with

none /mountpoint gmailfs username=gmailuser,password=gmailpass,fsname=zOlRRa 0 0

changing to

sudo mount -t gmailfs none /path/of/mount/point -o username=gmailuser,password=gmailpass,fsname=zOlRRa,user gives the above mount options & stays there.

but the problem remains that the mountpoint is accessible only by root.

There is also an /etc/gmailfs.conf which I don't know what is to given there.

 There is also a package called gnome-mount which perhaps might have a solution to my problem.

So to say, I am stuck, also is fsname really necessary? Because I don't remember giving any fsname in windows?

Any solution here would be nice.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu gmailfs Edit question
Assignee:
No assignee Edit question
Last query:
2007-08-16
Last reply:
2007-09-01
Shirish Agarwal (shirishag75) said : #1

xtknight gave me the following stuff to add to list to commands :-

sudo chown $USER:$USER /mnt/gmail
sudo chmod u+w /mnt/gmail
mount /mnt/gmail

let's see if they make my problem disappear.

Shirish Agarwal (shirishag75) said : #2

nah, its still the root who can make a call.

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Open' state without activity for the last 15 days.