libc 2.7 bug

Asked by Sébastien Escudier on 2009-01-29

Hi

There may be a bug in ubuntu hardy libc version (libc2.7)
eventfd function appears to be implemented, but not defined.
I am building a software (vlc) which uses Autotools and :
AC_CHECK_FUNCS(eventfd) is successfull but AC_CHECK_HEADERS(sys/eventfd.h) is not
This means this libc implements eventfd() but does not declare it anywhere.
Should I fill a bug report about that or contact the maintainer ?

thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu glibc Edit question
Assignee:
No assignee Edit question
Solved by:
Tom
Solved:
2009-01-29
Last query:
2009-01-29
Last reply:
2009-01-29
Best Tom (tom6) said : #1

I've been cheeky and sent this off to the bug-squad straight away. You're the second person (or maybe he was) that reported a problem with this since the updates this morning. This is way out of my league and at this time-of-day i thought i'd do my best to flag it up to developers and such as i'm not sure any are around in the Answers section right now.

It would help if you could report the bug directly from inside some program where the bug manifests itself (usually some useful info gets sent automatically that way) and clearly you know how to describe the problem better than me. When you have reported the bug please change the status of mine to make it a duplicate of yours.

Thanks for reporting this
Regards from
Tom

Thank you for the fast answer.

Should I fill the bug report here ? :
https://bugs.launchpad.net/ubuntu/+source/glibc/+filebug

This does not happens since this morning updates. It was there before.

Regards,
Seb

Sorry I did'nt see your bug report. It is the first time I am using lanchpad.
I can't tell more that what I said before, so your bug report is ok for me.

Thank you

Thanks Tom, that solved my question.

Tom (tom6) said : #5

There are now 2 bug reports and two questions about this. I think they are all the same problem. Yes your link was right for reporting bugs but it's usually best to go up to the "Help" menu in an app that's misbehaving and then click on "Report a bug". Instead of using your link this time tho it'd probably be better to add to whichever of these 2 bug-reports is more relevant ...
https://bugs.launchpad.net/ubuntu/+source/glibc/+bug/322666
https://bugs.launchpad.net/ubuntu/+bug/322676
and the other question that i think is similar is ...
https://answers.launchpad.net/ubuntu/+question/59086

Sorry i stupidly tried to download something and install updates at the same time even tho i knew i was extremely low on disc space. I couldn't reboot and the mailman arrived with my new power-supply which was all quite exciting and then i had to go out... I used Wolvix to sort my partitions out and deleted the swap from this drive because i'm not going to move it into my old machine just yet awhile. Then Ubuntu allowed me to reboot but still having troubles with Xp. Phew :) all worked out well but a few minutes of panic! :)

Anyway, good luck and regards from
Tom :)

Hi

I fail to see how the other bug report is related to mine ?
There is no kernel panic in my bug report (so the title is wrong).

I can't do a bug report from an application beacause this bug happens when I try to compile a software.

Seb

Tom (tom6) said : #7

Ok. Thanks for correcting my mistakes in the bug title and sorting that out :)

I don't know how to remove the link to the other bug but i'm sure it'll be clear what's happened to the right people that read the bug reports now. Hopefully one of them will be able to remove the link easily.

Thanks for helping us with this
Regards from
Tom :)