E: Internal Error, No file name for libc6

Asked by VidiMan on 2012-12-30

Running Ubuntu 12.04 and this one file has ruined my server.

libc6 is the package which refers to /lib/libc.so.6 as far as I can discover. The package file is 2.15-0ubuntu10.

Cannot run updates or configure the package. There are more than 300 other programs that depend on it so a purge and reinstall are not possible. Anyone have a clue how to fix.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu glibc Edit question
Assignee:
No assignee Edit question
Solved by:
VidiMan
Solved:
2012-12-31
Last query:
2012-12-31
Last reply:
2012-12-30
N1ck 7h0m4d4k15 (nicktux) said : #1

This is a bug my friend. You are unlucky and you fell to this bug.

But a workaround is available until the bug is fixed..

Visit the bug page and see the #7th comment

https://bugs.launchpad.net/ubuntu/+source/dpkg/+bug/983543

Do not forget to hit the "Affects me too" button so the heat go up and bug fixed soon.

Thanks

VidiMan (vidibuzz) said : #2

The "workaround" did nothing to fix my issue with lib6c.

I get "Processing was halted because there were too many errors." when running the --configure command. Nothing fixes the problem. No workaround in site. Anyone have an ideas? I tried all the normal fixes for packages.

What is the output of:

lsb_release -a; uname -a; apt-cache policy lkbc6

Thanks

VidiMan (vidibuzz) said : #4

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux 47981 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
N: Unable to locate package lkbc6

VidiMan (vidibuzz) said : #5

When I ran :
dpkg --configure -a

it said there were too many errors and could not complete.

libc6_2.15-0ubuntu10.3_amd64.deb

Manually downloading and installing the new version was the only thing that worked. Note this is the 10.3 version, not 10.2 as described in the other workaround.

When I ran -i the first time it complained about /etc/ld.so.nohwcap being a folder, so I deleted it.

dpkg -i /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_amd64.deb

dpkg -i /var/cache/apt/archives/*.deb
dpkg --configure -a