New Upgrading GLEW to version 1.5.2 for Karmic & Lucid

Asked by Josh Engwer on 2010-01-08

Will you please upgrade GLEW from version 1.5.1 to 1.5.2 for Ubuntu 9.10 & Lucid?

Version 1.5.2 adds support for OpenGL 3.1, OpenGL 3.2, and newer OpenGL extensions.

Also, version 1.5.2 fixes many bugs found in version 1.5.1 including:

* glTransformFeedbackVaryings arguments.
* Resource leak in glewinfo and visualinfo tools.
* Fixed version detection for GLEW_VERSION_2_1 and GLEW_VERSION_3_0.
* MesaGLUT glut.h GLAPIENTRY dependency.
* glFramebufferTextureLayer correction.
* Use $(STRIP) consistently.

See the following link for the release notes: http://glew.sourceforge.net/log.html

I manually installed version 1.5.2 in Ubuntu 9.04 (Jaunty), and tested it with a couple of programs that use the new features of GLEW 1.5.2 (OpenGL 3.2), and all the GLEW functions executed without issue.

Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu glew Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Daniel T Chen (crimsun) said :
#1

I've uploaded 1.5.2 to Lucid/10.04. It is not possible to add 1.5.2 to Karmic/9.10. However, you may request a backport of 1.5.2 to 9.10 once it is built and available in 10.04.

Can you help with this problem?

Provide an answer of your own, or ask Josh Engwer for more information if necessary.

To post a message you must log in.