Ubuntu

gksu doesn't allow escalating priviledges, dialog box freezes

Asked by NoahY on 2009-09-06

Hi, I'm having several problems with Karmic Alpha 64 bit, one of which is that I can't run any application that requires escalated priviledges. When I try to run synaptic, for instance, I get a dialog that says:

Failed to run /usr/sbin/synaptic as user root.
Failed to exec new process. Exec format error.

Running sudo <anything> from shell does nothing, just gives me another command prompt.

Other problems are that I the gcc compiler doesn't work and I can't switch users, but I only mention those here in case they are somehow related. What should I do to figure out what is the problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gksu Edit question
Assignee:
No assignee Edit question
Solved by:
NoahY
Solved:
2009-09-12
Last query:
2009-09-12
Last reply:
2009-09-07
Sam_ (and-sam) said : #1

> Karmic Alpha 64 bit

Actually only for testing, but I guess you know that.
Did you try daily build
http://cdimage.ubuntu.com/daily-live/current/

Proper cmd is:
gksudo synaptic

Failure can happen when a 'normal' user app, eg. firefox, was started with (gk)sudo.
http://www.psychocats.net/ubuntu/graphicalsudo

Check sudoers itself and also permissions (0440).
https://help.ubuntu.com/community/Sudoers
http://www.psychocats.net/ubuntu/fixsudo

.Xauthority should belong to user (600)
dito .ICEauthority

https://help.ubuntu.com/community/RootSudo

##for the record
https://bugs.launchpad.net/ubuntu/+source/gksu/+bug/425438

NoahY (noahy) said : #2

Thanks a lot... yes, I know it is for testing, I'm a little embarrassed that I've dragged myself through this again... Jaunty broke down, and the only thing I could think to do to fix it was upgrade... silly me.

I've already read most of what you posted, but I don't have either an .Xauthority file, nor an .ICEauthority file in my ~ directory... why would that be?

NoahY (noahy) said : #3

Sorry, and I am using todays updates... it's probably not a bug, just my incompetence messing things up.

NoahY (noahy) said : #4

To be more specific, here is my /etc/sudoers file:

# /etc/sudoers
#
# This file MUST be edited with the 'visudo' command as root.
#
# See the man page for details on how to write a sudoers file.
#

Defaults env_reset

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification
root ALL=(ALL) ALL

# Uncomment to allow members of group sudo to not need a password
# (Note that later entries override this, so you might need to move
# it further down)
# %sudo ALL=NOPASSWD: ALL

# Members of the admin group may gain root privileges
%admin ALL=(ALL) ALL

its permissions are 0440.

NoahY (noahy) said : #5

I wonder if this is related:

in ~/.xsession-errors

[DEBUG]: Unable to locate 'gnomesu' in your PATH
[DEBUG]: Using '/usr/bin/gksu' as GUI 'su' tool

NoahY (noahy) said : #6

I still need an answer...

NoahY (noahy) said : #7

Okay, I solved the problem, in a manner of speaking... downloaded Alpha 5 again, did a clean install. Poof. Problem solved :) still curious as to what was the real problem, but anyway.

Sam_ (and-sam) said : #8

> Alpha 5 again, did a clean install ... solved

I guess you should add the experience to your bug report #425438

As the 'debug' stated assumes messed up root privileges.

> : Using '/usr/bin/gksu' as GUI 'su' tool

As mentioned in the earlier post, a GUI app should be opened with gksudo or as above with gksu.
It can break for example .ICEauthority

Locations in Karmic?
https://bugs.launchpad.net/uck/+bug/414383

> : Unable to locate 'gnomesu' in your PATH

Your PATH is in /etc/environment and it_does_not include 'gnomesu'.
CLI:
printenv

e.g. in Hardy the output shows .Xauthority in /home/user

https://help.ubuntu.com/community/EnvironmentVariables#File-location%20related%20variables

Karmic related
https://bugs.launchpad.net/ubuntu/+source/libgksu/+bug/398849