what happened to nautilius gksudo feature

Asked by Roy Reese

Previous versions of Ubuntu allowed a nautilus extension that using gksu/gksudo you could edit a config file directly without having to enter a terminal. For v8.04 this seems to be broken. I have installed the package nautilus-gksu and it failed to work. gksu/gksudo apparently works from the terminal. I have removed the package and reinstalled and removed the package and installed via apt-get but still no joy. It is much easier to click on a file, right mouse click, choose Open as Administrator, enter your password , edit the file and save than opening a terminal CD to a directory the type in sudo gedit etc. Any time you have to type instead of point and click there is a greater chance for error, especially with my failing eyesight.



Question information

English Edit question
Ubuntu gksu Edit question
No assignee Edit question
Solved by:
Roy Reese
Last query:
Last reply:

This question was reopened

Revision history for this message
marcobra (Marco Braida) (marcobra) said :

Open a terminal and type

cd /usr/lib/nautilus
sudo cp extensions-1.0/* extensions-2.0/.

Hope this helps

Revision history for this message
Roy Reese (rj-reese) said :

Thanks marcobra, that solved my question.

Revision history for this message
Roy Reese (rj-reese) said :

Sorry but it didn't.


Revision history for this message
Roy Reese (rj-reese) said :

Thanks to all. The solution by marcobra did the trick BUT required a reboot.

Thanks again