gksu or gksudo in Ubuntu 13.04 -- Not working

Asked by Warren Hill on 2013-04-23

Yesterday I installed 13.04 on a test system to check if it was still possible to get the "Gnome Classic" desktop -- it is.

However, when I tried to run the file manager as root by pressing ALT+F2 to open the run dialogue then entering

----------------------------------------
gksu nautilus
---------------------------------------

It does not work . I also tried

----------------------------------------
gksudo nautilus
---------------------------------------

With the same result. Note on 12.04 and 12.10 (and probably earlier versions) gksudo is a symbolic link to gksu

In this case I could get away with

----------------------------------------------
sudo nautilus
---------------------------------------------

but this is not recommended for graphical applications for the reasons given here
https://help.ubuntu.com/community/RootSudo

I did some digging and found out that

1. gksu and gksudo are depreciated in favour of pkexec
2. gksu (and gksudo) have not been ported to Gnome 3
see here: http://changelogs.ubuntu.com/changelogs/pool/main/g/gksu/gksu_2.0.2-6ubuntu2/changelog

What is the easiest way to run graphical applications with root privileges in 13.04?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gksu Edit question
Assignee:
No assignee Edit question
Solved by:
Warren Hill
Solved:
2013-04-23
Last query:
2013-04-23
Last reply:
2013-04-23

I suggest you report a bug. Raring is not ready and not stable

Warren Hill (warren-hill) said : #2

If the bug is that gksu is not part of the standard install any more what package is it?

What defines the list of packages that are in a standard install?

Raring is due out on April 25 so I would hope its reasonably stable by now: I have not seen any suggestion it's going to be delayed. I have it installed on a separate test PC: nowhere near the one I use day to day.

Warren Hill (warren-hill) said : #3

Just had a long conversation on IRC #ubuntu-devel.

gksu can be installed in Raring but it's not the preferred way any more.

I have posted a full answer here: http://askubuntu.com/a/284717/107450