I just did a mini install of ubuntu 10.10 and I can not open synaptic package

Asked by oocevin

When opening synaptic package it ask for password but tells me wrong password.

Password works in terminal.

So how do I get that to work so I can do my repository adding
to get up dates...

Question information

English Edit question
Ubuntu gksu Edit question
No assignee Edit question
Solved by:
Eliah Kagan
Last query:
Last reply:
Revision history for this message
Eliah Kagan (degeneracypressure) said :

When you say that the password works in the Terminal, do you mean that it works for running commands with sudo? Or do you mean something else?

Have you verified that Caps Lock is not unintentionally on?

In the Terminal, please run this command (paste it into the Terminal and press enter--this avoids typos), then select all the text in the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it here.

lsb_release -a; echo; groups; echo; gconftool-2 -R /apps/gksu

Revision history for this message
oocevin (ccct007) said :

intim99@ubuntu:~$ lsb_release -a; echo; groups; echo; gconftool-2 -R /apps/gksuNo LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick

cintim99 adm dialout fax cdrom floppy tape dip video plugdev fuse lpadmin sambashare admin

 sudo-mode = false
 prompt = false
 force-grab = false
 save-to-keyring = false
 display-no-pass-info = false
 disable-grab = false
 save-keyring = session
This is what came back.

Yes it works running commands with sudo. Can't open
ubuntu software center neither.

I can install Lubuntu 10.04 mini install. Everything works.

But can't get the mini install of Ubuntu 10.10 to work

Thank You

Revision history for this message
oocevin (ccct007) said :

It seems it only works with the terminal

Revision history for this message
Best Eliah Kagan (degeneracypressure) said :

This is bug 685349. Many graphical administrative tools in Ubuntu are set up to use gksu as their graphical front-end to sudo. (Using sudo directly with graphical applications can be a bad thing; see https://help.ubuntu.com/community/RootSudo for details.) But depending on how gksu is installed, and at least on some Maverick and Natty installations (I haven't tested Oneiric yet) starting with minimal command-line systems, gksu is sometimes configured to act as a front-end for su instead of sudo. Since su only works if the root account is enabled (which is not the default on Ubuntu, nor is it is supported or recommended practice), the result is that gksu authentications always fail, reporting that an incorrect password was entered.

To repair the problem fully, just run this command, which makes gksu use sudo rather than su by default (as it should, in any Ubuntu system):

gconftool-2 --type bool --set /apps/gksu/sudo-mode true

As before, I recommend copying and pasting this command into the Terminal to reduce the risk of typos. (It's even more important in this case, because this command actually modifies settings.) Assuming the command succeeds, the problem should be solved, and you should be able to run graphical programs as root with gksu. In particular, launchers for administrative utilities like Synaptic that use gksu to run the utilities as root should start working.

(When manually invoking graphical programs as root on a system with a GTK+ based desktop environment--including GNOME, Xfce, and LXDE--you have the choice of using either gksu or gksudo. The former is more standard and should work--and running the above command makes it work, and you should only ever have to run it once, unless you switch to a different machine or wipe the disk and start over....or perhaps you'd have to run it again if you created another administrative user account--but the latter uses sudo no matter what.)

Revision history for this message
oocevin (ccct007) said :

sudo gconftool-2 --type bool --set /apps/gksu/sudo-mode true

did the job

thank you Eliah

Revision history for this message
Eliah Kagan (degeneracypressure) said :

I'm glad it worked!

If you are willing to do so, it would be helpful for you to go to https://bugs.launchpad.net/ubuntu/+source/gksu/+bug/685349, indicate that it affects you using the green "This bug affects..." link near the top-left corner of the bug page (I am assuming you have not done this because I think the person affected, besides me, is Bratmaxe--please let me know if I am mistaken), and post a short comment at the bottom of the bug (use the "Add comment" box at the bottom of the bug page) indicating that it affected you on Maverick with lubuntu-desktop installed (assuming installing lubuntu-desktop was the way you created your Lubuntu 10.10 system), specifying your lubuntu-desktop and gksu package versions (you can get these using "apt-cache policy lubuntu-desktop gksu"), and including a link to this question.