How to circumvent libgit2-glib 0.24 dependency

Asked by Greemin

I am trying to compile gitg from "apt-get source" for Ubuntu 16.04 xenial.
After installing all dependencies ./configure throws:

"Requested 'libgit2-glib-1.0 < 0.24.0' but version of libgit2-glib is 0.24.0"

Only a v0.24.X package is available in the ubuntu repositories. I tried to install some older version of the binary package but that led to more version conflicts with other packages.

How do I circumvent this problem?

Question information

English Edit question
Ubuntu gitg Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

What is the problem with the available binary packages that you try building yourself?

Which version of gitg are you trying to build?
I think the version problem that you see is in version 3.17.1 only, but has already been corrected in 3.20.3

Revision history for this message
Greemin (greemin) said :

I am trying to build gitg 3.17.1 to hunt down a bug that i reported earlier:
Apparently it's fixed with the last apt-upgrade but the original cause is still unclear.
I use gitg at work so I cannot simply upgrade to 17.04.

Revision history for this message
Manfred Hampl (m-hampl) said :

It seems that currently there is a FTBFS (failed to build from source) situation for gitg in xenial.
As far as I can see the gitg package was built on Dec 11, 2015 (at that time a libgit2-glib 0.23.* package was available), but on April 18, 2016 a 0.24* package of libgit2-glib was introduced in xenial, and since that moment the gitg package can no more be built because of dependency problems.

I am not sure what kind of advice to give in such case.

You might create a bug report to signal this to the developers, but I am not sure whether it is worth spending capacity on such issue.

What you could try is replacing the line
(or something like that) in the file
This might allow the compilation, but I cannot guarantee that the program still works as expected.

Revision history for this message
Greemin (greemin) said :

Changing the libgit-glib-max-version in results in a compiler error:

/home/jesse/devel/gitg/libgitg/gitg-remote.vala: In function '____lambda57_':
/home/jesse/devel/gitg/libgitg/gitg-remote.vala:250:2: error: too few arguments to function 'ggit_remote_connect'
In file included from /usr/include/libgit2-glib-1.0/libgit2-glib/ggit.h:67:0,
                 from libgitg/gitg-remote.c:27:
/usr/include/libgit2-glib-1.0/libgit2-glib/ggit-remote.h:74:20: note: declared here
 void ggit_remote_connect (GgitRemote *remote,
Makefile:2772: recipe for target 'libgitg/libgitg_libgitg_1_0_la-gitg-remote.lo' failed

So it seems like there is a reason that a libgit2-glib version under 0.24.0 is required.
I'll file a bug report to inform the developers about it, so that at least the package gets flagged or whatever the procedure is.
Thanks for the quick answer!

Can you help with this problem?

Provide an answer of your own, or ask Greemin for more information if necessary.

To post a message you must log in.