Avoid modal popups from terminal

Asked by Mario T. Lanza on 2012-03-17

I have used "git" from Windows and from Ubuntu. When I do a push/pull operation I'm prompted for my github password. In Windows the prompt is inline in the PowerShell. In Ubuntu the prompt appears as a modal popup outside the shell. I prefer, when in the shell to remain in the shell. It feels a little jarring to pop out into the desktop environment. Is there a way to disable this popup so that prompts remain inline?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu git Edit question
Assignee:
No assignee Edit question
Last query:
2012-03-17
Last reply:
2012-03-17

Could report a bug

Anders Kaseorg (andersk) said : #2

If you run ‘unset SSH_AUTH_SOCK’, you’ll be prompted in your terminal. Note though that you’ll be re-prompted on every push/pull instead of just the first one.

Can you help with this problem?

Provide an answer of your own, or ask Mario T. Lanza for more information if necessary.

To post a message you must log in.