Why not use Gimp 2.10?

Asked by Malix on 2018-04-18

Gimp 2.10 RC2 is just released, it's not yet the final version, but the official 2.10 will be ready in just few weeks. Why stel struggle on old 2.8 release and not migrate to last version?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gimp Edit question
Assignee:
No assignee Edit question
Last query:
2018-04-18
Last reply:
2018-04-18

Because it came out last month. The feature freeze was on 1st March so it just missed out.

Ubuntu is not a rolling release distribution so packages are rarely updated unless there is a significant reason to upgrade (critical bug and security fixes).

If you run:

ubuntu-bug gimp

The process will start and you can alert the developers to significant bugs that have been addressed in the newer version or even let them know if the current version is no longer supported by the gimp team.

Can you help with this problem?

Provide an answer of your own, or ask Malix for more information if necessary.

To post a message you must log in.