Gimp crashes (segfault) in glib2.0 while parsing iso codes XML

Asked by JPT on 2018-03-02

Thread 1 "gimp" received signal SIGSEGV, Segmentation fault.
0x00007ffff40abffa in g_markup_parse_context_parse () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
(gdb) backtrace
#0 0x00007ffff40abffa in g_markup_parse_context_parse () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1 0x00005555558f7227 in gimp_xml_parser_parse_io_channel (parser=parser@entry=0x555556b97c80, io=io@entry=0x5555569215f0, error=error@entry=0x0) at ././app/config/gimpxmlparser.c:213
#2 0x00005555558f734f in gimp_xml_parser_parse_file (parser=parser@entry=0x555556b97c80, filename=filename@entry=0x555556ba8a90 "/usr/share/xml/iso-codes/iso_639.xml", error=error@entry=0x0)
    at ././app/config/gimpxmlparser.c:96
#3 0x000055555578aec1 in gimp_language_store_parse_iso_codes (store=0x555556ae1a10, error=0x0) at ././app/widgets/gimplanguagestore-parser.c:127
#4 0x00007ffff458860d in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#5 0x00007ffff4589d85 in g_object_new_with_properties () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#6 0x00007ffff458a801 in g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#7 0x000055555578a8f9 in gimp_language_store_new () at ././app/widgets/gimplanguagestore.c:141
#8 0x000055555578a2db in gimp_language_entry_new () at ././app/widgets/gimplanguageentry.c:211
#9 0x000055555574a5da in gimp_prop_language_entry_new (config=config@entry=0x7fffe9598100, property_name=property_name@entry=0x5555559f9bef "language") at ././app/widgets/gimppropwidgets.c:1223
#10 0x00005555556a5a5f in gimp_text_options_gui (tool_options=<optimized out>) at ././app/tools/gimptextoptions.c:614
#11 0x000055555564eaea in gimp_tools_restore (gimp=gimp@entry=0x7ffff7fee020) at ././app/tools/gimp-tools.c:343
#12 0x000055555560a700 in gui_restore_callback (gimp=0x7ffff7fee020, status_callback=0x55555560d860 <splash_update>) at ././app/gui/gui.c:465
#13 0x00007ffff4582f9d in g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#14 0x00007ffff4595cde in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#15 0x00007ffff459e4b5 in g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#16 0x00007ffff459eecf in g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#17 0x0000555555607c90 in app_run (full_prog_name=<optimized out>, filenames=0x0, alternate_system_gimprc=<optimized out>, alternate_gimprc=<optimized out>, session_name=<optimized out>, batch_interpreter=0x0,

Package: libglib2.0-0 Version: 2.54.1-1ubuntu1
Package: iso-codes Version: 3.75-1
Package: gimp Version: 2.8.20-1
Linux JPT 4.13.0-36-generic #40-Ubuntu SMP Fri Feb 16 20:07:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
Kubuntu Artful

what can I do to solve this problem?
Which package is causing the problem? The XML seems to be valid, tried XML validator. No Idea what else I could check.

thanks

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu gimp Edit question
Assignee:
No assignee Edit question
Last query:
2018-03-05
Last reply:
2018-03-21

What is the output of:

lsb_release -a; uname -a; apt-cache policy gimp

Thanks

JPT (j-p-t) said : #2

lsb_release -a; uname -a; apt-cache policy gimp
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 17.10
Release: 17.10
Codename: artful
Linux JPT 4.13.0-36-generic #40-Ubuntu SMP Fri Feb 16 20:07:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
gimp:
  Installed: 2.8.20-1
  Candidate: 2.8.20-1
  Version table:
 *** 2.8.20-1 500
        500 http://de.archive.ubuntu.com/ubuntu artful/universe amd64 Packages
        100 /var/lib/dpkg/status

Have you tried renaming the GIMP configuration folder then relaunching it so that you get default settings

JPT (j-p-t) said : #4

~/.gimp-2.8/ ?

yes, already tried. Did not help.

Launchpad Janitor (janitor) said : #5

This question was expired because it remained in the 'Open' state without activity for the last 15 days.