gimp 2.8

Asked by arnupharb on 2012-05-09

how to install gimp 2.8
i try this way but it isn't work

    sudo add-apt-repository ppa:otto-kesselgulasch/gimp
    sudo apt-get update && sudo apt-get install gimp

it show something about between 32 bit or 64bit
or gimp isn't avalible for 64 bit

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gimp Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-05-10
Last query:
2012-05-10
Last reply:
2012-05-10
Jeet (gour-jitendrasingh) said : #1

give me output of

lsb_release -a; uname -a

arnupharb (arnupharb-master) said : #2

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux maszter-System-Product-Name 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Can you give the output of:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install

arnupharb (arnupharb-master) said : #4

กำลังอ่านรายชื่อแพกเกจ... เสร็จแล้ว
กำลังสร้างโครงสร้างลำดับความสัมพันธ์
กำลังอ่านข้อมูลสถานะ... เสร็จแล้ว
The following packages were automatically installed and are no longer required:
  libkwwidgets1.0.1009 libtorque2 libunity6 libgdcm2.0 libgl2ps0 iwidgets4
  lib32gcc1 libbabl-0.0-0 libgegl-0.0-0 libteem1 tcllib libvtk5.8
  libopenmpi1.3 python-vtk libinsighttoolkit3.20 libhdf5-serial-1.8.4
  libopenigtlink1.9 itcl3 libnuma1 libibverbs1 tcl8.5-kwwidgets libcharls1
  itk3 tcl-vtk libnetcdf6
ใช้ 'apt-get autoremove' เพื่อลบแพกเกจดังกล่าวได้
จะปรับรุ่นแพกเกจต่อไปนี้ขึ้น:
  gimp
ปรับรุ่นขึ้น 1, ติดตั้งใหม่ 0, ถอดถอน 0 และไม่ปรับรุ่น 27
ต้องดาวน์โหลดแพกเกจ 0 B/6,086 kB
หลังจากการกระทำนี้ ต้องใช้เนื้อที่บนดิสก์อีก 2,121 kB
(กำลังอ่านฐานข้อมูล ... 313437 แฟ้มและไดเรกทอรีติดตั้งอยู่)
กำลังเตรียมแทนที่ gimp 2.6.12-1ubuntu1 (ด้วย .../gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb) ...
กำลังแตกแพกเกจแทนที่ gimp ...
dpkg: เกิดข้อผิดพลาดขณะประมวลผล /var/cache/apt/archives/gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb (--unpack):
 กำลังพยายามเขียนทับ '/usr/lib/gimp/2.0/plug-ins/file-xmc' ซึ่งอยู่ในแพกเกจ gimp-plugin-registry 3.5.4-1 เช่นกัน
dpkg-deb: error: subprocess แปะ was killed by signal (Broken pipe)
กำลังประมวลผลการสะกิดสำหรับ menu ...
เกิดข้อผิดพลาดขณะประมวลผล:
 /var/cache/apt/archives/gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
maszter@maszter-System-Product-Name:~$ sudo add-apt-repository ppa:otto-kesselgulasch/gimp
You are about to add the following PPA to your system:
 CAUTION!

This PPA could break your installed OS. There are dependency issues for Oneiric Ocelot (11.10). Only use it if you know what you do!

There should be no problems in Precise Pangolin (12.04).

Regards
 More info: https://launchpad.net/~otto-kesselgulasch/+archive/gimp
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.j2gMIyFZri --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv FB97E9C3A97F85C095AEA7903BDAAC08614C4B38
gpg: requesting key 614C4B38 from hkp server keyserver.ubuntu.com
gpg: key 614C4B38: "Launchpad otto06217" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
maszter@maszter-System-Product-Name:~$ sudo apt-get update
ข้าม http://th.archive.ubuntu.com precise InRelease
ข้าม http://th.archive.ubuntu.com precise-updates InRelease
ข้าม http://th.archive.ubuntu.com natty-backports InRelease
ข้าม http://archive.canonical.com precise InRelease
ข้าม http://archive.canonical.com natty InRelease
ข้าม http://extras.ubuntu.com precise InRelease
ข้าม http://ppa.launchpad.net precise InRelease
ข้าม http://ppa.launchpad.net precise InRelease
ข้าม http://security.ubuntu.com precise-security InRelease
เจอ http://th.archive.ubuntu.com precise Release.gpg
เจอ http://th.archive.ubuntu.com precise-updates Release.gpg
เจอ http://archive.canonical.com precise Release.gpg
เจอ http://extras.ubuntu.com precise Release.gpg
ข้าม http://ppa.launchpad.net precise Release.gpg
เจอ http://security.ubuntu.com precise-security Release.gpg
เจอ http://th.archive.ubuntu.com natty-backports Release.gpg
เจอ http://archive.canonical.com natty Release.gpg
เจอ http://th.archive.ubuntu.com precise Release
เจอ http://extras.ubuntu.com precise Release
เจอ http://ppa.launchpad.net precise Release.gpg
เจอ http://security.ubuntu.com precise-security Release
เจอ http://th.archive.ubuntu.com precise-updates Release
เจอ http://archive.canonical.com precise Release
ข้าม http://ppa.launchpad.net precise Release
เจอ http://th.archive.ubuntu.com natty-backports Release
เจอ http://extras.ubuntu.com precise/main Sources
เจอ http://th.archive.ubuntu.com precise/main Sources
เจอ http://th.archive.ubuntu.com precise/restricted Sources
เจอ http://th.archive.ubuntu.com precise/universe Sources
เจอ http://security.ubuntu.com precise-security/main Sources
เจอ http://th.archive.ubuntu.com precise/multiverse Sources
เจอ http://th.archive.ubuntu.com precise/main amd64 Packages
เจอ http://th.archive.ubuntu.com precise/restricted amd64 Packages
เจอ http://th.archive.ubuntu.com precise/universe amd64 Packages
เจอ http://ppa.launchpad.net precise Release
เจอ http://th.archive.ubuntu.com precise/multiverse amd64 Packages
เจอ http://th.archive.ubuntu.com precise/main i386 Packages
เจอ http://archive.canonical.com natty Release
เจอ http://th.archive.ubuntu.com precise/restricted i386 Packages
เจอ http://th.archive.ubuntu.com precise/universe i386 Packages
เจอ http://th.archive.ubuntu.com precise/multiverse i386 Packages
เจอ http://th.archive.ubuntu.com precise/main TranslationIndex
เจอ http://th.archive.ubuntu.com precise/multiverse TranslationIndex
เจอ http://extras.ubuntu.com precise/main amd64 Packages
เจอ http://extras.ubuntu.com precise/main i386 Packages
เจอ http://th.archive.ubuntu.com precise/restricted TranslationIndex
เจอ http://security.ubuntu.com precise-security/restricted Sources
เจอ http://security.ubuntu.com precise-security/universe Sources
เจอ http://security.ubuntu.com precise-security/multiverse Sources
เจอ http://security.ubuntu.com precise-security/main amd64 Packages
เจอ http://security.ubuntu.com precise-security/restricted amd64 Packages
เจอ http://security.ubuntu.com precise-security/universe amd64 Packages
เจอ http://security.ubuntu.com precise-security/multiverse amd64 Packages
เจอ http://security.ubuntu.com precise-security/main i386 Packages
เจอ http://security.ubuntu.com precise-security/restricted i386 Packages
เจอ http://security.ubuntu.com precise-security/universe i386 Packages
ข้าม http://ppa.launchpad.net precise/main TranslationIndex
เจอ http://th.archive.ubuntu.com precise/universe TranslationIndex
เจอ http://th.archive.ubuntu.com precise-updates/main Sources
เจอ http://th.archive.ubuntu.com precise-updates/restricted Sources
เจอ http://th.archive.ubuntu.com precise-updates/universe Sources
เจอ http://th.archive.ubuntu.com precise-updates/multiverse Sources
เจอ http://archive.canonical.com precise/partner amd64 Packages
เจอ http://archive.canonical.com precise/partner i386 Packages
ข้าม http://archive.canonical.com precise/partner TranslationIndex
เจอ http://th.archive.ubuntu.com precise-updates/main amd64 Packages
เจอ http://th.archive.ubuntu.com precise-updates/restricted amd64 Packages
เจอ http://th.archive.ubuntu.com precise-updates/universe amd64 Packages
เจอ http://th.archive.ubuntu.com precise-updates/multiverse amd64 Packages
ข้าม http://extras.ubuntu.com precise/main TranslationIndex
เจอ http://security.ubuntu.com precise-security/multiverse i386 Packages
เจอ http://security.ubuntu.com precise-security/main TranslationIndex
เจอ http://security.ubuntu.com precise-security/multiverse TranslationIndex
เจอ http://security.ubuntu.com precise-security/restricted TranslationIndex
เจอ http://security.ubuntu.com precise-security/universe TranslationIndex
เจอ http://ppa.launchpad.net precise/main Sources
เจอ http://ppa.launchpad.net precise/main amd64 Packages
เจอ http://ppa.launchpad.net precise/main i386 Packages
ข้าม http://ppa.launchpad.net precise/main TranslationIndex
เจอ http://th.archive.ubuntu.com precise-updates/main i386 Packages
เจอ http://th.archive.ubuntu.com precise-updates/restricted i386 Packages
เจอ http://th.archive.ubuntu.com precise-updates/universe i386 Packages
เจอ http://th.archive.ubuntu.com precise-updates/multiverse i386 Packages
เจอ http://th.archive.ubuntu.com precise-updates/main TranslationIndex
เจอ http://th.archive.ubuntu.com precise-updates/multiverse TranslationIndex
เจอ http://archive.canonical.com natty/partner Sources
เจอ http://th.archive.ubuntu.com precise-updates/restricted TranslationIndex
เจอ http://th.archive.ubuntu.com precise-updates/universe TranslationIndex
เจอ http://th.archive.ubuntu.com natty-backports/main Sources
เจอ http://th.archive.ubuntu.com natty-backports/restricted Sources
เจอ http://th.archive.ubuntu.com natty-backports/universe Sources
เจอ http://security.ubuntu.com precise-security/main Translation-en
เจอ http://th.archive.ubuntu.com natty-backports/multiverse Sources
เจอ http://th.archive.ubuntu.com precise/main Translation-th
เจอ http://th.archive.ubuntu.com precise/main Translation-en
เจอ http://th.archive.ubuntu.com precise/multiverse Translation-en
เจอ http://th.archive.ubuntu.com precise/restricted Translation-en
เจอ http://th.archive.ubuntu.com precise/universe Translation-th
เจอ http://th.archive.ubuntu.com precise/universe Translation-en
เจอ http://th.archive.ubuntu.com precise-updates/main Translation-en
เจอ http://th.archive.ubuntu.com precise-updates/multiverse Translation-en
เจอ http://th.archive.ubuntu.com precise-updates/restricted Translation-en
เจอ http://security.ubuntu.com precise-security/multiverse Translation-en
เจอ http://security.ubuntu.com precise-security/restricted Translation-en
เจอ http://th.archive.ubuntu.com precise-updates/universe Translation-en
เจอ http://security.ubuntu.com precise-security/universe Translation-en
ปัญหา http://ppa.launchpad.net precise/main Sources
  404 Not Found
ปัญหา http://ppa.launchpad.net precise/main amd64 Packages
  404 Not Found
ปัญหา http://ppa.launchpad.net precise/main i386 Packages
  404 Not Found
ข้าม http://ppa.launchpad.net precise/main Translation-th_TH
ข้าม http://ppa.launchpad.net precise/main Translation-th
ข้าม http://ppa.launchpad.net precise/main Translation-en
ข้าม http://ppa.launchpad.net precise/main Translation-th_TH
ข้าม http://extras.ubuntu.com precise/main Translation-th_TH
ข้าม http://ppa.launchpad.net precise/main Translation-th
ข้าม http://extras.ubuntu.com precise/main Translation-th
ข้าม http://ppa.launchpad.net precise/main Translation-en
ข้าม http://extras.ubuntu.com precise/main Translation-en
ข้าม http://archive.canonical.com precise/partner Translation-th_TH
ข้าม http://archive.canonical.com precise/partner Translation-th
ข้าม http://archive.canonical.com precise/partner Translation-en
W: ไม่สามารถดาวน์โหลด http://ppa.launchpad.net/michael-gruz/canon/ubuntu/dists/precise/main/source/Sources 404 Not Found

W: ไม่สามารถดาวน์โหลด http://ppa.launchpad.net/michael-gruz/canon/ubuntu/dists/precise/main/binary-amd64/Packages 404 Not Found

W: ไม่สามารถดาวน์โหลด http://ppa.launchpad.net/michael-gruz/canon/ubuntu/dists/precise/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
maszter@maszter-System-Product-Name:~$ sudo apt-get upgrade
กำลังอ่านรายชื่อแพกเกจ... เสร็จแล้ว
กำลังสร้างโครงสร้างลำดับความสัมพันธ์
กำลังอ่านข้อมูลสถานะ... เสร็จแล้ว
คุณอาจต้องเรียก 'apt-get -f install' เพื่อแก้ปัญหาเหล่านี้
แพกเกจต่อไปนี้ขาดแพกเกจที่ต้องใช้:
 gimp : ต้องใช้: libgimp2.0 (<= 2.6.12-z) แต่รุ่นที่ติดตั้งไว้คือ 2.8.0-1ubuntu0ppa3~precise
        ต้องใช้: gimp-data (<= 2.6.12-z) แต่รุ่นที่ติดตั้งไว้คือ 2.8.0-1ubuntu0ppa3~precise
E: รายการแพกเกจที่ต้องใช้ไม่ครบ กรุณาลองใช้ตัวเลือก -f
maszter@maszter-System-Product-Name:~$ sudo apt-get -f install
กำลังอ่านรายชื่อแพกเกจ... เสร็จแล้ว
กำลังสร้างโครงสร้างลำดับความสัมพันธ์
กำลังอ่านข้อมูลสถานะ... เสร็จแล้ว
กำลังแก้ปัญหาความขึ้นต่อกันระหว่างแพกเกจ... เสร็จแล้ว
The following packages were automatically installed and are no longer required:
  libkwwidgets1.0.1009 libtorque2 libunity6 libgdcm2.0 libgl2ps0 iwidgets4
  lib32gcc1 libbabl-0.0-0 libgegl-0.0-0 libteem1 tcllib libvtk5.8
  libopenmpi1.3 python-vtk libinsighttoolkit3.20 libhdf5-serial-1.8.4
  libopenigtlink1.9 itcl3 libnuma1 libibverbs1 tcl8.5-kwwidgets libcharls1
  itk3 tcl-vtk libnetcdf6
ใช้ 'apt-get autoremove' เพื่อลบแพกเกจดังกล่าวได้
จะติดตั้งแพกเกจเพิ่มเติมต่อไปนี้:
  gimp
จะปรับรุ่นแพกเกจต่อไปนี้ขึ้น:
  gimp
ปรับรุ่นขึ้น 1, ติดตั้งใหม่ 0, ถอดถอน 0 และไม่ปรับรุ่น 27
ต้องดาวน์โหลดแพกเกจ 0 B/6,086 kB
หลังจากการกระทำนี้ ต้องใช้เนื้อที่บนดิสก์อีก 2,121 kB
คุณต้องการจะดำเนินการต่อไปหรือไม่ [Y/n]?y
(กำลังอ่านฐานข้อมูล ... 313437 แฟ้มและไดเรกทอรีติดตั้งอยู่)
กำลังเตรียมแทนที่ gimp 2.6.12-1ubuntu1 (ด้วย .../gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb) ...
กำลังแตกแพกเกจแทนที่ gimp ...
dpkg: เกิดข้อผิดพลาดขณะประมวลผล /var/cache/apt/archives/gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb (--unpack):
 กำลังพยายามเขียนทับ '/usr/lib/gimp/2.0/plug-ins/file-xmc' ซึ่งอยู่ในแพกเกจ gimp-plugin-registry 3.5.4-1 เช่นกัน
dpkg-deb: error: subprocess แปะ was killed by signal (Broken pipe)
กำลังประมวลผลการสะกิดสำหรับ menu ...
เกิดข้อผิดพลาดขณะประมวลผล:
 /var/cache/apt/archives/gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

it is thai and

arnupharb (arnupharb-master) said : #5

And after i upgrade to 12.04 gimp is error because of the can't replace some file in older version
and make my ubuntu software centre broke this is a new ploblem after update to 12.04 and gimp 2.8
if you're not understand thai language please tell me
thanks

arnupharb (arnupharb-master) said : #6

installArchives() failed: (Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 313437 files and directories currently installed.)
Preparing to replace gimp 2.6.12-1ubuntu1 (using .../gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb) ...
Unpacking replacement gimp ...
dpkg: error processing /var/cache/apt/archives/gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/gimp/2.0/plug-ins/file-xmc', which is also in package gimp-plugin-registry 3.5.4-1
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for menu ...
Errors were encountered while processing:
 /var/cache/apt/archives/gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb
Error in function:
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)

i found this after software centre needs to fix it look like to relate to gimp

arnupharb (arnupharb-master) said : #7

gimp: Depends: python-gtk2 (>= 2.8.0) แต่ 2.24.0-3 ถูกติดตั้งแล้ว
      Depends: libc6 (>= 2.15) แต่ 2.15-0ubuntu10 ถูกติดตั้งแล้ว
      Depends: libfontconfig1 (>= 2.8.0) แต่ 2.8.0-3ubuntu9 ถูกติดตั้งแล้ว
      Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) แต่ 2.26.1-1 ถูกติดตั้งแล้ว
      Depends: libglib2.0-0 (>= 2.31.2) แต่ 2.32.1-0ubuntu2 ถูกติดตั้งแล้ว
      Depends: libgtk2.0-0 (>= 2.24.0) แต่ 2.24.10-0ubuntu6 ถูกติดตั้งแล้ว
      Depends: libjpeg8 (>= 8c) แต่ 8c-2ubuntu7 ถูกติดตั้งแล้ว
      Depends: librsvg2-2 (>= 2.14.4) แต่ 2.36.1-0ubuntu1 ถูกติดตั้งแล้ว
      Depends: zlib1g (>= 1:1.1.4) แต่ 1:1.2.3.4.dfsg-3ubuntu4 ถูกติดตั้งแล้ว
      Depends: python (>= 2.7.1-0ubuntu2) แต่ 2.7.3-0ubuntu2 ถูกติดตั้งแล้ว
 and this one after i use update manager

arnupharb (arnupharb-master) said : #8

Libgimp version mismatch!

The GIMP binary cannot run with a libgimp version
other than its own. This is GIMP 2.6.12, but the
libgimp version is 2.8.0.

Maybe you have GIMP versions in both /usr and /usr/local ?

and this message show after i want to use gimp

arnupharb (arnupharb-master) said : #9

แต่................... ถูกติดตั้งแล้ว
but...................is already install
translate from #7

could try:

sudo dpkg --force-all -i /var/cache/apt/archives/gimp_2.8.0-1ubuntu0ppa3~precise_amd64.deb; sudo apt-get -f install

Will force the duplicated file to be overwritten and install the app.

arnupharb (arnupharb-master) said : #11

within short sentense you can make my computer working again.

arnupharb (arnupharb-master) said : #12

Thanks actionparsnip, that solved my question.