i can't install gimp error please healp

Asked by z3r0c007 on 2012-03-11

Package dependencies cannot be resolved

This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time.

details:

The following packages have unmet dependencies:

gimp: Depends: python-gtk2 (>= 2.8.0) but 2.24.0-2 is to be installed
      Depends: libc6 (>= 2.11) but 2.13-20ubuntu5.1 is to be installed
      Depends: libfontconfig1 (>= 2.8.0) but 2.8.0-3ubuntu2 is to be installed
      Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but 2.25.2-0ubuntu2~oneiric1 is to be installed
      Depends: libglib2.0-0 (>= 2.24.0) but 2.31.21+git20120308.3fa73584-0ubuntu1~11.10~ricotz0 is to be installed
      Depends: libgtk2.0-0 (>= 2.20.0) but 2.24.6-0ubuntu5 is to be installed
      Depends: libjpeg62 (>= 6b1) but 6b1-1ubuntu2 is to be installed
      Depends: librsvg2-2 (>= 2.14.4) but 2.35.1-0ubuntu1~oneiric1 is to be installed
      Depends: zlib1g (>= 1:1.1.4) but 1:1.2.3.4.dfsg-3ubuntu3 is to be installed
      Depends: python (>= 2.7.1-0ubuntu2) but 2.7.2-7ubuntu2 is to be installed

output of this command : lsb_release -a; uname -a; apt-cache policy gimp

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux linux-Presario-V3000-RD996PA-UUF 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:49:42 UTC 2012 i686 i686 i386 GNU/Linux
gimp:
  Installed: (none)
  Candidate: 2.6.11-2ubuntu4
  Version table:
     2.7.5-2012020902~oo 0
        100 /var/lib/dpkg/status
     2.6.11-2ubuntu4 0
        500 http://es.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gimp Edit question
Assignee:
No assignee Edit question
Last query:
2012-03-11
Last reply:
2012-03-11

Seems you have some ppa enabled i think "~ricotz" related...

https://launchpad.net/~ricotz/+archive/testing

please try to disable that repository and try... you might also need to uninstall some packages coming from that ppa

z3r0c007 (kimchloekc) said : #2

i can't remove affecting some of my files any more suggestion or command

You can easily remove PPAs by deleting the related file in /etc/apt/sources.list.d and it will not affect any of your packages

Could also try:

sudo add-apt-repository ppa:matthaeus123/mrw-gimp-svn; sudo apt-get update; sudo apt-get install gimp

Can you help with this problem?

Provide an answer of your own, or ask z3r0c007 for more information if necessary.

To post a message you must log in.