Gimp do not lauching

Asked by Dale Crampton on 2011-12-05

GIMP IN LAUNCH BAR PULSES WHEN CLICKED BUT DOES NOT START. INSTALLED AND REMOVED PACKAGE THREE TIMES BEFORE UBUNTU SOFTWARE CENTER ADDED TO LAUNCH BAR.

When i press save https://answers.launchpad.net/ubuntu/+source/worker/+question/180918/+edit
I get There is no package name 'GIMP Image Editor' published in Ubuntu

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gimp Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-12-07
Last query:
2011-12-07
Last reply:
2011-12-07

This question was reopened

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | grep gimp

please don't post in all caps, it is unnecessary, harder to read and looks like you are shouting, so DON'T

Dale Crampton (dale1944) said : #2

Thanks actionparsnip, that solved my question.

Dale Crampton (dale1944) said : #3

dale@dale-p2-1033w:~$ lsb_release -a; uname -a; dpkg -l | grep gimp
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux dale-p2-1033w 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:25:36 UTC 2011 i686 athlon i386 GNU/Linux
ii gimp 2.7.4-2011102201~oo The GNU Image Manipulation Program
ii gimp-data 2.7.4-2011102201~oo Data files for GIMP
ii gimp-data-extras 1:2.0.1-3 An extra set of brushes, palettes, and gradients for The GIMP
ii gimp-dimage-color 1.1.0-3ubuntu1 GIMP plugin to convert Minolta DiMAGE pictures to sRGB colour space
ii gimp-gap 2.6.0+dfsg-1ubuntu1 The GIMP Animation Package
ii gimp-gmic 1.5.0.0+dfsg-1 GIMP plugin for GREYC's Magic Image Converter
ii gimp-gutenprint 5.2.7-2ubuntu4 print plugin for the GIMP
ii gimp-help-common 2.6.1-1 Data files for the GIMP documentation
ii gimp-help-en 2.6.1-1 Documentation for the GIMP (English)
ii gimp-lensfun 0.1.1-1 Gimp plugin to correct lens distortion using the lensfun library
ii gimp-ufraw 0.18-1.1 gimp importer for raw camera images
ii gimpshop 2.2.11-1 GimpShop package
ii libgimp2.0 2.7.4-2011102201~oo Libraries for the GNU Image Manipulation Program
dale@dale-p2-1033w:~$
****************
dale@dale-p2-1033w:~$ gimp
gimp: error while loading shared libraries: libart_lgpl_2.so.2: cannot open shared object file: No such file or directory
dale@dale-p2-1033w:~$
Verified Home -- lib and file libart_lgpl_2.so.2 is missing. Believe this happened with reinstall of evolution.
Don't know the source or how to replace missing file.
Don't think the instruction to click "that solved my question" is quite correct.

ok and what is the output of:

file `which gimp`

Dale Crampton (dale1944) said : #5

dale@dale-p2-1033w:~$ which gimp
/usr/local/bin/gimp
dale@dale-p2-1033w:~$

You ran:
which gimp

You were asked to run:
file `which gimp`

Dale Crampton (dale1944) said : #7

dale@dale-p2-1033w:~$ lsb_release -a; uname -a; dpkg -l | grep gimp
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux dale-p2-1033w 3.0.0-13-generic #22-Ubuntu SMP Wed Nov 2 13:25:36 UTC 2011 i686 athlon i386 GNU/Linux
ii gimp 2.7.4-2011102201~oo The GNU Image Manipulation Program
ii gimp-data 2.7.4-2011102201~oo Data files for GIMP
ii gimp-data-extras 1:2.0.1-3 An extra set of brushes, palettes, and gradients for The GIMP
ii gimp-dimage-color 1.1.0-3ubuntu1 GIMP plugin to convert Minolta DiMAGE pictures to sRGB colour space
ii gimp-gap 2.6.0+dfsg-1ubuntu1 The GIMP Animation Package
ii gimp-gmic 1.5.0.0+dfsg-1 GIMP plugin for GREYC's Magic Image Converter
ii gimp-gutenprint 5.2.7-2ubuntu4 print plugin for the GIMP
ii gimp-help-common 2.6.1-1 Data files for the GIMP documentation
ii gimp-help-en 2.6.1-1 Documentation for the GIMP (English)
ii gimp-lensfun 0.1.1-1 Gimp plugin to correct lens distortion using the lensfun library
ii gimp-ufraw 0.18-1.1 gimp importer for raw camera images
ii gimpshop 2.2.11-1 GimpShop package
ii libgimp2.0 2.7.4-2011102201~oo Libraries for the GNU Image Manipulation Program
dale@dale-p2-1033w:~$

Dale Crampton (dale1944) said : #8

dale@dale-p2-1033w:~$ `which gimp`
/usr/local/bin/gimp: error while loading shared libraries: libart_lgpl_2.so.2: cannot open shared object file: No such file or directory
dale@dale-p2-1033w:~$
Sorry didn't get the quotes in the first try.

You ran:
`which gimp`

You were asked to run:
file `which gimp`

Why are you finding it so hard to copy and paste the line I give? The word 'file' is PART of the command......

Dale Crampton (dale1944) said : #10

dale@dale-p2-1033w:~$ file `which gimp`
/usr/local/bin/gimp: symbolic link to `gimp-2.2'
dale@dale-p2-1033w:~$ file `which gimp`
Did not realize file was part of the syntax for the command line, new to Linux.

ok and the output of:

file `which gimp-2.2`

Thanks

Dale Crampton (dale1944) said : #12

dale@dale-p2-1033w:~$ file `which gimp-2.2`
/usr/local/bin/gimp-2.2: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.0, stripped
dale@dale-p2-1033w:~$

ok, it's 32bit gimp on 32bit OS, this is good.

ok what is the output of:

ls /usr/lib | grep libart_lgpl

Thanks

Dale Crampton (dale1944) said : #14

dale@dale-p2-1033w:~$ ls /usr/lib | grep libart_lgpl
dale@dale-p2-1033w:~$

Pasted ls /usr/lib | grep libart_lgpl pressed enter, instant prompt. Tried with 3 fresh terminals, all same - nothing.

Dale Crampton (dale1944) said : #15

RE ls /usr/lib | grep libart_lgpl from #13 See bottom of #3 trying to start gimp from terminal.

Try:

sudo apt-get install librsvg

Should give the file afaics.

Dale Crampton (dale1944) said : #17

dale@dale-p2-1033w:~$ sudo apt-get install librsvg
[sudo] password for dale:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package librsvg
dale@dale-p2-1033w:~$

Try:

sudo /sbin/ldconfig

Then run the app. If that fails then this should work:

sudo apt-get --purge remove gimp gimp-data gimpshop; sudo apt-get --purge autoremove; sudo apt-get clean; sudo apt-get update; sudo apt-get install gimp

Then retry.

Dale Crampton (dale1944) said : #19

dale@dale-p2-1033w:~$ sudo /sbin/ldconfig
[sudo] password for dale:
dale@dale-p2-1033w:~$
**failed**

dale@dale-p2-1033w:~$ sudo apt-get --purge remove gimp gimp-data gimpshop; sudo apt-get
[sudo] password for dale:
Sorry, try again.
[sudo] password for dale:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  gimp* gimp-data* gimp-dimage-color* gimp-gap* gimp-gmic* gimp-gutenprint*
  gimp-ufraw* gimpshop*
0 upgraded, 0 newly installed, 8 to remove and 20 not upgraded.
After this operation, 107 MB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 165695 files and directories currently installed.)
Removing gimp-ufraw ...
Removing gimp-gutenprint ...
Removing gimp-gmic ...
Removing gimp-gap ...
Removing gimp-dimage-color ...
Removing gimp ...
Purging configuration files for gimp ...
Removing gimp-data ...
Purging configuration files for gimp-data ...
Removing gimpshop ...
dpkg: warning: while removing gimpshop, directory '/usr/local/share' not empty so not removed.
dpkg: warning: while removing gimpshop, directory '/usr/local/lib' not empty so not removed.
dpkg: warning: while removing gimpshop, directory '/usr/local' not empty so not removed.
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for man-db ...
Processing triggers for menu ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for hicolor-icon-theme ...
apt 0.8.16~exp5ubuntu13 for i386 compiled on Oct 6 2011 15:25:29
Usage: apt-get [options] command
       apt-get [options] install|remove pkg1 [pkg2 ...]
       apt-get [options] source pkg1 [pkg2 ...]

apt-get is a simple command line interface for downloading and
installing packages. The most frequently used commands are update
and install.

Commands:
   update - Retrieve new lists of packages
   upgrade - Perform an upgrade
   install - Install new packages (pkg is libc6 not libc6.deb)
   remove - Remove packages
   autoremove - Remove automatically all unused packages
   purge - Remove packages and config files
   source - Download source archives
   build-dep - Configure build-dependencies for source packages
   dist-upgrade - Distribution upgrade, see apt-get(8)
   dselect-upgrade - Follow dselect selections
   clean - Erase downloaded archive files
   autoclean - Erase old downloaded archive files
   check - Verify that there are no broken dependencies
   changelog - Download and display the changelog for the given package
   download - Download the binary package into the current directory

Options:
  -h This help text.
  -q Loggable output - no progress indicator
  -qq No output except for errors
  -d Download only - do NOT install or unpack archives
  -s No-act. Perform ordering simulation
  -y Assume Yes to all queries and do not prompt
  -f Attempt to correct a system with broken dependencies in place
  -m Attempt to continue if archives are unlocatable
  -u Show a list of upgraded packages as well
  -b Build the source package after fetching it
  -V Show verbose version numbers
  -c=? Read this configuration file
  -o=? Set an arbitrary configuration option, eg -o dir::cache=/tmp
See the apt-get(8), sources.list(5) and apt.conf(5) manual
pages for more information and options.
                       This APT has Super Cow Powers.
dale@dale-p2-1033w:~$

Reinstalled with Ubuntu Software Center, in launch bar and appears to be working as advertised
THANKS

Try:

sudo apt-get --purge remove gimp gimp-data gimpshop
sudo apt-get --purge autoremove
sudo apt-get clean
sudo apt-get update
sudo apt-get install gimp

Copying multiple lines in one is clearly a challenge so I will break the command up, this gives more effort for you, but it will work. Run each line in turn

Dale Crampton (dale1944) said : #21

dale@dale-p2-1033w:~$ sudo apt-get --purge remove gimp gimp-data gimpshop
[sudo] password for dale:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package gimpshop
dale@dale-p2-1033w:~$ sudo apt-get --purge autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
dale@dale-p2-1033w:~$ sudo apt-get clean
dale@dale-p2-1033w:~$ sudo apt-get update
Ign http://security.ubuntu.com oneiric-security InRelease
Get:1 http://security.ubuntu.com oneiric-security Release.gpg [198 B]
Get:2 http://security.ubuntu.com oneiric-security Release [32.4 kB]
Get:3 http://security.ubuntu.com oneiric-security/main Sources [18.4 kB]
Get:4 http://security.ubuntu.com oneiric-security/restricted Sources [14 B]
Get:5 http://security.ubuntu.com oneiric-security/universe Sources [5,590 B]
Get:6 http://security.ubuntu.com oneiric-security/multiverse Sources [653 B]
Get:7 http://security.ubuntu.com oneiric-security/main i386 Packages [55.1 kB]
Get:8 http://security.ubuntu.com oneiric-security/restricted i386 Packages [14 B]
Get:9 http://security.ubuntu.com oneiric-security/universe i386 Packages [15.5 kB]
Get:10 http://security.ubuntu.com oneiric-security/multiverse i386 Packages [1,653 B]
Get:11 http://security.ubuntu.com oneiric-security/main TranslationIndex [73 B]
Get:12 http://security.ubuntu.com oneiric-security/multiverse TranslationIndex [71 B]
Get:13 http://security.ubuntu.com oneiric-security/restricted TranslationIndex [70 B]
Get:14 http://security.ubuntu.com oneiric-security/universe TranslationIndex [73 B]
Get:15 http://security.ubuntu.com oneiric-security/main Translation-en [28.4 kB]
Hit http://security.ubuntu.com oneiric-security/multiverse Translation-en
Hit http://security.ubuntu.com oneiric-security/restricted Translation-en
Hit http://security.ubuntu.com oneiric-security/universe Translation-en
Ign http://us.archive.ubuntu.com oneiric InRelease
Ign http://us.archive.ubuntu.com oneiric-updates InRelease
Ign http://us.archive.ubuntu.com oneiric-backports InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Hit http://us.archive.ubuntu.com oneiric Release.gpg
Get:16 http://us.archive.ubuntu.com oneiric-updates Release.gpg [198 B]
Hit http://ppa.launchpad.net oneiric Release.gpg
Hit http://us.archive.ubuntu.com oneiric-backports Release.gpg
Hit http://ppa.launchpad.net oneiric Release
Hit http://us.archive.ubuntu.com oneiric Release
Hit http://ppa.launchpad.net oneiric/main Sources
Get:17 http://us.archive.ubuntu.com oneiric-updates Release [32.4 kB]
Ign http://extras.ubuntu.com oneiric InRelease
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Get:18 http://extras.ubuntu.com oneiric Release.gpg [72 B]
Hit http://us.archive.ubuntu.com oneiric-backports Release
Hit http://extras.ubuntu.com oneiric Release
Hit http://us.archive.ubuntu.com oneiric/main Sources
Hit http://extras.ubuntu.com oneiric/main Sources
Hit http://extras.ubuntu.com oneiric/main i386 Packages
Ign http://extras.ubuntu.com oneiric/main TranslationIndex
Hit http://us.archive.ubuntu.com oneiric/restricted Sources
Hit http://us.archive.ubuntu.com oneiric/universe Sources
Hit http://us.archive.ubuntu.com oneiric/multiverse Sources
Hit http://us.archive.ubuntu.com oneiric/main i386 Packages
Hit http://us.archive.ubuntu.com oneiric/restricted i386 Packages
Hit http://us.archive.ubuntu.com oneiric/universe i386 Packages
Hit http://us.archive.ubuntu.com oneiric/multiverse i386 Packages
Hit http://us.archive.ubuntu.com oneiric/main TranslationIndex
Hit http://us.archive.ubuntu.com oneiric/multiverse TranslationIndex
Hit http://us.archive.ubuntu.com oneiric/restricted TranslationIndex
Hit http://us.archive.ubuntu.com oneiric/universe TranslationIndex
Get:19 http://us.archive.ubuntu.com oneiric-updates/main Sources [94.6 kB]
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Ign http://ppa.launchpad.net oneiric/main Translation-en
Get:20 http://us.archive.ubuntu.com oneiric-updates/restricted Sources [1,348 B]
Get:21 http://us.archive.ubuntu.com oneiric-updates/universe Sources [25.8 kB]
Get:22 http://us.archive.ubuntu.com oneiric-updates/multiverse Sources [1,992 B]
Get:23 http://us.archive.ubuntu.com oneiric-updates/main i386 Packages [219 kB]
Ign http://extras.ubuntu.com oneiric/main Translation-en_US
Ign http://extras.ubuntu.com oneiric/main Translation-en
Get:24 http://us.archive.ubuntu.com oneiric-updates/restricted i386 Packages [2,935 B]
Get:25 http://us.archive.ubuntu.com oneiric-updates/universe i386 Packages [64.1 kB]
Get:26 http://us.archive.ubuntu.com oneiric-updates/multiverse i386 Packages [4,396 B]
Get:27 http://us.archive.ubuntu.com oneiric-updates/main TranslationIndex [73 B]
Get:28 http://us.archive.ubuntu.com oneiric-updates/multiverse TranslationIndex [72 B]
Get:29 http://us.archive.ubuntu.com oneiric-updates/restricted TranslationIndex [71 B]
Get:30 http://us.archive.ubuntu.com oneiric-updates/universe TranslationIndex [73 B]
Hit http://us.archive.ubuntu.com oneiric-backports/main Sources
Hit http://us.archive.ubuntu.com oneiric-backports/restricted Sources
Hit http://us.archive.ubuntu.com oneiric-backports/universe Sources
Hit http://us.archive.ubuntu.com oneiric-backports/multiverse Sources
Hit http://us.archive.ubuntu.com oneiric-backports/main i386 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/restricted i386 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/universe i386 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/multiverse i386 Packages
Hit http://us.archive.ubuntu.com oneiric-backports/main TranslationIndex
Hit http://us.archive.ubuntu.com oneiric-backports/multiverse TranslationIndex
Hit http://us.archive.ubuntu.com oneiric-backports/restricted TranslationIndex
Hit http://us.archive.ubuntu.com oneiric-backports/universe TranslationIndex
Hit http://us.archive.ubuntu.com oneiric/main Translation-en
Hit http://us.archive.ubuntu.com oneiric/multiverse Translation-en
Hit http://us.archive.ubuntu.com oneiric/restricted Translation-en
Hit http://us.archive.ubuntu.com oneiric/universe Translation-en
Get:31 http://us.archive.ubuntu.com oneiric-updates/main Translation-en [99.5 kB]
Hit http://us.archive.ubuntu.com oneiric-updates/multiverse Translation-en
Hit http://us.archive.ubuntu.com oneiric-updates/restricted Translation-en
Hit http://us.archive.ubuntu.com oneiric-updates/universe Translation-en
Hit http://us.archive.ubuntu.com oneiric-backports/main Translation-en
Hit http://us.archive.ubuntu.com oneiric-backports/multiverse Translation-en
Hit http://us.archive.ubuntu.com oneiric-backports/restricted Translation-en
Hit http://us.archive.ubuntu.com oneiric-backports/universe Translation-en
Fetched 705 kB in 13s (51.3 kB/s)
Reading package lists... Done
dale@dale-p2-1033w:~$ sudo apt-get install gimp
Reading package lists... Done
Building dependency tree
Reading state information... Done
gimp is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
dale@dale-p2-1033w:~$

SHOUTING THANKS

Dale Crampton (dale1944) said : #22

Thanks actionparsnip, that solved my question.