impossible to lunch GIMP on ubuntu 11.10 on intel p6200 (64bit)

Asked by Hugo on 2011-10-01

I have tried in different way, with the svn, the stable source, from synaptique, or unity pakage installer, or command line ... Nothing ... The command line sudo gimp reply : gimp : Depends: gimp-data (<= 2.6.11-z) mais 2.7.3-2011082002~oo devra être installé
E: Unable to correct problems, you have held broken packages.

Here i am ... ;(

Don't hesitate to contact me if you need further informations

Take care

Hugo

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gimp Edit question
Assignee:
No assignee Edit question
Solved by:
Hugo
Solved:
2011-10-05
Last query:
2011-10-05
Last reply:
2011-10-04

This question was originally filed as bug #863854.

This question was reopened

  • 2011-10-03 by Hugo
Micah Gersten (micahg) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug. There is also a vibrant support community available at http://askubuntu.com and you might consider asking your question there.

Matthew Woerly (nattgew) said : #2

Run Synaptic and make sure that everything is up to date. The error you posted says there are broken packages, so check in Synaptic to make sure those are resolved (under "Custom Filters").
Also, is there a specific reason that you're running it as root (with sudo)?

Hugo (morizothugo-yahoo) said : #3

Thank's for your reply Matthew,

I tried to repare broken package in synaptic, the libgegl don't appear in synaptic as a broken package using personalized filter.

maitre@Serviteur:~$ gimp
gimp: error while loading shared libraries: libgegl-0.0.so.0: cannot open shared object file: No such file or directory
maitre@Serviteur:~$ sudo -i
[sudo] password for maitre:
root@Serviteur:~# gimp
gimp: error while loading shared libraries: libgegl-0.0.so.0: cannot open shared object file: No such file or directory
root@Serviteur:~# sudo gimp
gimp: error while loading shared libraries: libgegl-0.0.so.0: cannot open shared object file: No such file or directory
root@Serviteur:~#

Matthew Woerly (nattgew) said : #4

Look for libgegl in Synaptic and make sure it's installed.

Hugo (morizothugo-yahoo) said : #5

Off course i have cheked along time ago if the libgegl is installed, i have also installed the dev version in case ..

Hugo (morizothugo-yahoo) said : #6

in case the version is the good one but it did nothing ...

Hugo (morizothugo-yahoo) said : #7

i took a synaptic screenshot but i don't know how to send it to you ?

Hugo (morizothugo-yahoo) said : #8

oups ... some how i cliqued "solved" but it's not solved ..

It's NOT SOLVED

Matthew Woerly (nattgew) said : #9

That's strange that you can't attach things on questions...
You can upload it to some photo sharing service and link it.

Hugo (morizothugo-yahoo) said : #10

I've just tried to force version of libgegl "oneiric" but it did nothing

Matthew Woerly (nattgew) said : #11

I looked in my Synaptic and I found no "libgegl" but instead "libegl-mesa" and related packages... is that what you're seeing, too?

Hugo (morizothugo-yahoo) said : #12

I have no "libegl-mesa" ! only vers dev/i386/-0.0.0 of libgegl

Manfred Hampl (m-hampl) said : #13

Please issue the following commands in a terminal (ctrl-alt-t):

uname -a
lsb_release -a
apt-cache policy gimp libgegl
sudo apt-get install -f

then select all output (edit - select all) copy it (edit - copy) and paste it into a new message of this question thread.
(These commands will not solve the problem, but should provide more details about your system for identifying the root cause of the problem.)

Hugo (morizothugo-yahoo) said : #14

Hello, Manfred
Below the command line you gave me :
strange the package : Unable to locate package libgegl

maitre@Serviteur:~$ uname -a
Linux Serviteur 3.0.0-12-generic #19-Ubuntu SMP Fri Sep 23 21:23:39 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
maitre@Serviteur:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu oneiric (development branch)
Release: 11.10
Codename: oneiric
maitre@Serviteur:~$ apt-cache policy gimp libgegl
gimp:
  Installé : 2.6.11-2ubuntu4
  Candidat : 2.6.11-2ubuntu4
 Table de version :
 *** 2.6.11-2ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
N: Unable to locate package libgegl
maitre@Serviteur:~$ sudo apt-get install -f
[sudo] password for maitre:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libopenraw1 libumfpack5.4.0 liblensfun-data liblensfun0 libamd2.2.0
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 7 non mis à jour.
maitre@Serviteur:~$

Manfred Hampl (m-hampl) said : #15

the commands that I gave have not provided all the information that I hoped to see, so please try again with

apt-cache policy gimp* libgegl*
apt-get --simulate dist-upgrade

and paste the output again

Hugo (morizothugo-yahoo) said : #16

Here :
maitre@Serviteur:~$ apt-cache policy gimp* libgegl*
gimp:
  Installé : 2.6.11-2ubuntu4
  Candidat : 2.6.11-2ubuntu4
 Table de version :
 *** 2.6.11-2ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
libgimp2.0:
  Installé : 2.6.11-2ubuntu4
  Candidat : 2.6.11-2ubuntu4
 Table de version :
 *** 2.6.11-2ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gimp-data:
  Installé : 2.6.11-2ubuntu4
  Candidat : 2.6.11-2ubuntu4
 Table de version :
 *** 2.6.11-2ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
libgegl-0.0-0:
  Installé : 0.0.22-2ubuntu2
  Candidat : 0.0.22-2ubuntu2
 Table de version :
 *** 0.0.22-2ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gimp-help-en:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-data-extras:
  Installé : 1:2.0.1-3
  Candidat : 1:2.0.1-3
 Table de version :
 *** 1:2.0.1-3 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status
gimp-gnomevfs:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-helpbrowser:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-libcurl:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-print:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-python:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-svg:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-wget:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
libgimp-perl:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-dbg:
  Installé : (aucun)
  Candidat : 2.6.11-2ubuntu4
 Table de version :
     2.6.11-2ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-common:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-de:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-es:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-fr:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-it:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-ko:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-nl:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-nn:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-pl:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-ru:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-help-sv:
  Installé : (aucun)
  Candidat : 2.6.1-1
 Table de version :
     2.6.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gimp-gutenprint:
  Installé : (aucun)
  Candidat : 5.2.7-2ubuntu4
 Table de version :
     5.2.7-2ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
libgegl-0.0-dev:
  Installé : (aucun)
  Candidat : 0.0.22-2ubuntu2
 Table de version :
     0.0.22-2ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
libgegl-0.0-doc:
  Installé : (aucun)
  Candidat : 0.0.22-2ubuntu2
 Table de version :
     0.0.22-2ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
libgimp2.0-dev:
  Installé : (aucun)
  Candidat : 2.6.11-2ubuntu4
 Table de version :
     2.6.11-2ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
libgimp2.0-doc:
  Installé : (aucun)
  Candidat : 2.6.11-2ubuntu4
 Table de version :
     2.6.11-2ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
slugimage:
  Installé : (aucun)
  Candidat : 1:0.0+r104-5
 Table de version :
     1:0.0+r104-5 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
extremetuxracer-gimp-dev:
  Installé : (aucun)
  Candidat : 0.4-4
 Table de version :
     0.4-4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
planetpenguin-racer-gimp-dev:
  Installé : (aucun)
  Candidat : 0.4-4
 Table de version :
     0.4-4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
flegita-gimp:
  Installé : (aucun)
  Candidat : 0.6.2-0ubuntu4
 Table de version :
     0.6.2-0ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimmix:
  Installé : (aucun)
  Candidat : 0.5.7.1-2
 Table de version :
     0.5.7.1-2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-cbmplugs:
  Installé : (aucun)
  Candidat : 1.2.2-1
 Table de version :
     1.2.2-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp1.2-cbmplugs:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp1.3-cbmplugs:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-dcraw:
  Installé : (aucun)
  Candidat : 1.31-1.1
 Table de version :
     1.31-1.1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-dds:
  Installé : (aucun)
  Candidat : 2.0.9-3
 Table de version :
     2.0.9-3 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-dimage-color:
  Installé : (aucun)
  Candidat : 1.1.0-3ubuntu1
 Table de version :
     1.1.0-3ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp1.2-perl:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-gap:
  Installé : (aucun)
  Candidat : 2.6.0+dfsg-1ubuntu1
 Table de version :
     2.6.0+dfsg-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-gluas:
  Installé : (aucun)
  Candidat : 0.1.20-1
 Table de version :
     0.1.20-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-gmic:
  Installé : (aucun)
  Candidat : 1.5.0.0+dfsg-1
 Table de version :
     1.5.0.0+dfsg-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-lensfun:
  Installé : (aucun)
  Candidat : 0.1.1-1
 Table de version :
     0.1.1-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-normalmap:
  Installé : (aucun)
  Candidat : 1.2.2-0ubuntu2
 Table de version :
     1.2.2-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-plugin-registry:
  Installé : (aucun)
  Candidat : 3.5.4-1
 Table de version :
     3.5.4-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-refocus:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-save-for-web:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
gimp-resynthesizer:
  Installé : (aucun)
  Candidat : 0.16-1.1
 Table de version :
     0.16-1.1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-texturize:
  Installé : (aucun)
  Candidat : 2.0-2
 Table de version :
     2.0-2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimp-ufraw:
  Installé : (aucun)
  Candidat : 0.18-1.1
 Table de version :
     0.18-1.1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gtkam-gimp:
  Installé : (aucun)
  Candidat : 0.1.17-1
 Table de version :
     0.1.17-1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
libggimisc2:
  Installé : (aucun)
  Candidat : 2.2.2-2.1
 Table de version :
     2.2.2-2.1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
libggimisc2-dev:
  Installé : (aucun)
  Candidat : 2.2.2-2.1
 Table de version :
     2.2.2-2.1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
mrwtoppm-gimp:
  Installé : (aucun)
  Candidat : 0.1.1-2.2
 Table de version :
     0.1.1-2.2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gimageview:
  Installé : (aucun)
  Candidat : (aucun)
 Table de version :
maitre@Serviteur:~$ apt-get --simulate dist-upgrade
NOTE: Ceci n'est qu'une simulation !
      apt-get a besoin des privilèges du superutilisateur
      pour pouvoir vraiment fonctionner.
      Veuillez aussi noter que le verrouillage est désactivé,
      et la situation n'est donc pas forcément représentative
      de la réalité !
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calcul de la mise à jour... Fait
Les paquets suivants seront mis à jour :
  libnm-gtk-common libnm-gtk0 network-manager-gnome rsyslog tzdata upstart
  xdg-utils
7 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Inst tzdata [2011j-1] (2011k-1 Ubuntu:11.10/oneiric [amd64])
Conf tzdata (2011k-1 Ubuntu:11.10/oneiric [amd64])
Inst upstart [1.3-0ubuntu9] (1.3-0ubuntu10 Ubuntu:11.10/oneiric [amd64])
Inst rsyslog [5.8.1-1ubuntu1] (5.8.1-1ubuntu2 Ubuntu:11.10/oneiric [amd64])
Inst libnm-gtk-common [0.9.1.90-0ubuntu5] (0.9.1.90-0ubuntu6 Ubuntu:11.10/oneiric [all])
Inst libnm-gtk0 [0.9.1.90-0ubuntu5] (0.9.1.90-0ubuntu6 Ubuntu:11.10/oneiric [amd64])
Inst network-manager-gnome [0.9.1.90-0ubuntu5] (0.9.1.90-0ubuntu6 Ubuntu:11.10/oneiric [amd64])
Inst xdg-utils [1.1.0~rc1-2ubuntu5] (1.1.0~rc1-2ubuntu6 Ubuntu:11.10/oneiric [all])
Conf upstart (1.3-0ubuntu10 Ubuntu:11.10/oneiric [amd64])
Conf rsyslog (5.8.1-1ubuntu2 Ubuntu:11.10/oneiric [amd64])
Conf libnm-gtk-common (0.9.1.90-0ubuntu6 Ubuntu:11.10/oneiric [all])
Conf libnm-gtk0 (0.9.1.90-0ubuntu6 Ubuntu:11.10/oneiric [amd64])
Conf network-manager-gnome (0.9.1.90-0ubuntu6 Ubuntu:11.10/oneiric [amd64])
Conf xdg-utils (1.1.0~rc1-2ubuntu6 Ubuntu:11.10/oneiric [all])
maitre@Serviteur:~$

Manfred Hampl (m-hampl) said : #17

I do not see anything wrong.

try

sudo apt-get install --reinstall libgegl-0.0-0

and then try starting gimp again.

Hugo (morizothugo-yahoo) said : #18

I just tried, nothing

maitre@Serviteur:~$ sudo apt-get install --reinstall libgegl-0.0-0
[sudo] password for maitre:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libopenraw1 libumfpack5.4.0 liblensfun-data liblensfun0 libamd2.2.0
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 7 non mis à jour.
Il est nécessaire de prendre 0 o/361 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 146491 fichiers et répertoires déjà installés.)
Préparation du remplacement de libgegl-0.0-0 0.0.22-2ubuntu2 (en utilisant .../libgegl-0.0-0_0.0.22-2ubuntu2_amd64.deb) ...
Dépaquetage de la mise à jour de libgegl-0.0-0 ...
Paramétrage de libgegl-0.0-0 (0.0.22-2ubuntu2) ...
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
maitre@Serviteur:~$

the bug is stile the same : a logo "jpg" appear in the unity laucher instead of the logo "gimp" and after 4 seconds the incone desapear ....

Manfred Hampl (m-hampl) said : #19

The issue with the unity launcher is different from the problem in comment #3 (gimp does not start because of missing libgegl-0.0.so.0).
The solutions given in my posts were targetting to get the 'missing libgegl' problem solved.

Just to finish working on that problem, can you please check if gimp is running when you start it from a command line (without sudo).

Please also execute the command

ls -la /usr/lib/libgegl*

to check if the libgegl library is available now.

The unity launcher problem is something different.

Hugo (morizothugo-yahoo) said : #20

I am sorry, i cliqued on solved by mistake, the bug is the same since the begining : when triing to launch gimp (as a clic right or directly via the menu) a logo "jpg" appear in the unity laucher instead of the logo "gimp" and after 4 seconds the incon desapear

below the command you ask :

maitre@Serviteur:~$ gimp
*gimp: error while loading shared libraries: libbabl-0.0.so.0: cannot open shared object file: No such file or directory

maitre@Serviteur:~$ ls -la /usr/lib/libgegl*
lrwxrwxrwx 1 root root 21 2010-08-04 09:39 /usr/lib/libgegl-0.0.so.0 -> libgegl-0.0.so.0.22.0
-rw-r--r-- 1 root root 313248 2010-08-04 09:39 /usr/lib/libgegl-0.0.so.0.22.0
maitre@Serviteur:~$

Manfred Hampl (m-hampl) said : #21

The error message has changed!

in command# 3 gimp could not load because of missing libgegl, now it is libbabl that is missing!

try again:

ls -la /usr/lib/libbabl*
sudo apt-get install --reinstall libbabl-0.0-0
ls -la /usr/lib/libbabl*
gimp

and tell if gimp can start, or if there are new error messages displayed

Hugo (morizothugo-yahoo) said : #22

I'll see you latter i am so late to an appoitement ...

maitre@Serviteur:~$ ls -la /usr/lib/libbabl*
-rw-r--r-- 1 root root 959 2011-08-20 07:04 /usr/lib/libbabl-0.1.la
lrwxrwxrwx 1 root root 22 2011-08-20 07:04 /usr/lib/libbabl-0.1.so -> libbabl-0.1.so.0.104.1
lrwxrwxrwx 1 root root 22 2011-08-20 07:04 /usr/lib/libbabl-0.1.so.0 -> libbabl-0.1.so.0.104.1
-rw-r--r-- 1 root root 112992 2011-08-20 07:04 /usr/lib/libbabl-0.1.so.0.104.1
maitre@Serviteur:~$ sudo apt-get install --reinstall libbabl-0.0-0
[sudo] password for maitre:
Sorry, try again.
[sudo] password for maitre:
Sorry, try again.
[sudo] password for maitre:
Reading package lists... Done
Building dependency tree
Reading state information... Done
La réinstallation de libbabl-0.0-0 est impossible, il ne peut pas être téléchargé.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 7 non mis à jour.
maitre@Serviteur:~$ ls -la /usr/lib/libbabl*
-rw-r--r-- 1 root root 959 2011-08-20 07:04 /usr/lib/libbabl-0.1.la
lrwxrwxrwx 1 root root 22 2011-08-20 07:04 /usr/lib/libbabl-0.1.so -> libbabl-0.1.so.0.104.1
lrwxrwxrwx 1 root root 22 2011-08-20 07:04 /usr/lib/libbabl-0.1.so.0 -> libbabl-0.1.so.0.104.1
-rw-r--r-- 1 root root 112992 2011-08-20 07:04 /usr/lib/libbabl-0.1.so.0.104.1
maitre@Serviteur:~$ sudo apt-get install --reinstall libbabl-0.0-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
La réinstallation de libbabl-0.0-0 est impossible, il ne peut pas être téléchargé.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 7 non mis à jour.
maitre@Serviteur:~$ ls -la /usr/lib/libbabl*
-rw-r--r-- 1 root root 959 2011-08-20 07:04 /usr/lib/libbabl-0.1.la
lrwxrwxrwx 1 root root 22 2011-08-20 07:04 /usr/lib/libbabl-0.1.so -> libbabl-0.1.so.0.104.1
lrwxrwxrwx 1 root root 22 2011-08-20 07:04 /usr/lib/libbabl-0.1.so.0 -> libbabl-0.1.so.0.104.1
-rw-r--r-- 1 root root 112992 2011-08-20 07:04 /usr/lib/libbabl-0.1.so.0.104.1
maitre@Serviteur:~$ gimp
gimp: error while loading shared libraries: libbabl-0.0.so.0: cannot open shared object file: No such file or directory
maitre@Serviteur:~$

Manfred Hampl (m-hampl) said : #23

It seems that you have a version of libbabl from a ppa that is tot fitting to your current version if gimp.

please issue the command

apt-cache policy libbabl*

and paste the output.

If my assumtion about the ppa is correct, you have to disable that ppa, run 'sudo apt-get update' and 'sudo apt-get install --reinstall libbabl-0.0-0' and then check again if there is an error message by starting gimp from a terminal command prompt.

Hugo (morizothugo-yahoo) said : #24

Here the result of the command :

It says the libbabl can't be downloaded ??? i will trye to install it from .deb package to see ...

==>
maitre@Serviteur:~$ apt-cache policy libbabl*
libbabl-0.0-0:
  Installé : 0.1.5-2011081901~oo
  Candidat : 0.1.5-2011081901~oo
 Table de version :
 *** 0.1.5-2011081901~oo 0
        100 /var/lib/dpkg/status
     0.0.22-1build1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
libbabl-0.0-0-dev:
  Installé : 0.1.5-2011081901~oo
  Candidat : 0.1.5-2011081901~oo
 Table de version :
 *** 0.1.5-2011081901~oo 0
        100 /var/lib/dpkg/status
     0.0.22-1build1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
libbabl-0.0-doc:
  Installé : (aucun)
  Candidat : 0.0.22-1build1
 Table de version :
     0.0.22-1build1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
maitre@Serviteur:~$
maitre@Serviteur:~$ sudo apt-get update
[sudo] password for maitre:
Ign http://archive.canonical.com oneiric InRelease
Ign http://extras.ubuntu.com oneiric InRelease
Atteint http://archive.canonical.com oneiric Release.gpg
Ign http://archive.ubuntu.com oneiric InRelease
Ign http://archive.ubuntu.com oneiric-updates InRelease
Ign http://archive.ubuntu.com oneiric-security InRelease
Atteint http://extras.ubuntu.com oneiric Release.gpg
Atteint http://archive.canonical.com oneiric Release
Ign http://archive.ubuntu.com oneiric-proposed InRelease
Ign http://archive.ubuntu.com oneiric-backports InRelease
Atteint http://archive.ubuntu.com oneiric Release.gpg
Atteint http://archive.ubuntu.com oneiric-updates Release.gpg
Atteint http://extras.ubuntu.com oneiric Release
Atteint http://archive.ubuntu.com oneiric-security Release.gpg
Atteint http://archive.ubuntu.com oneiric-proposed Release.gpg
Atteint http://archive.canonical.com oneiric/partner Sources
Atteint http://extras.ubuntu.com oneiric/main Sources
Atteint http://archive.ubuntu.com oneiric-backports Release.gpg
Atteint http://archive.ubuntu.com oneiric Release
Atteint http://archive.canonical.com oneiric/partner amd64 Packages
Atteint http://archive.canonical.com oneiric/partner i386 Packages
Ign http://archive.canonical.com oneiric/partner TranslationIndex
Atteint http://extras.ubuntu.com oneiric/main amd64 Packages
Atteint http://extras.ubuntu.com oneiric/main i386 Packages
Ign http://extras.ubuntu.com oneiric/main TranslationIndex
Atteint http://archive.ubuntu.com oneiric-updates Release
Atteint http://archive.ubuntu.com oneiric-security Release
Atteint http://archive.ubuntu.com oneiric-proposed Release
Atteint http://archive.ubuntu.com oneiric-backports Release
Atteint http://archive.ubuntu.com oneiric/main Sources
Atteint http://archive.ubuntu.com oneiric/restricted Sources
Atteint http://archive.ubuntu.com oneiric/universe Sources
Atteint http://archive.ubuntu.com oneiric/multiverse Sources
Atteint http://archive.ubuntu.com oneiric/main amd64 Packages
Atteint http://archive.ubuntu.com oneiric/restricted amd64 Packages
Atteint http://archive.ubuntu.com oneiric/universe amd64 Packages
Atteint http://archive.ubuntu.com oneiric/multiverse amd64 Packages
Atteint http://archive.ubuntu.com oneiric/main i386 Packages
Atteint http://archive.ubuntu.com oneiric/restricted i386 Packages
Atteint http://archive.ubuntu.com oneiric/universe i386 Packages
Atteint http://archive.ubuntu.com oneiric/multiverse i386 Packages
Ign http://archive.ubuntu.com oneiric/main TranslationIndex
Ign http://archive.ubuntu.com oneiric/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric/universe TranslationIndex
Atteint http://archive.ubuntu.com oneiric-updates/main Sources
Atteint http://archive.ubuntu.com oneiric-updates/restricted Sources
Atteint http://archive.ubuntu.com oneiric-updates/universe Sources
Atteint http://archive.ubuntu.com oneiric-updates/multiverse Sources
Atteint http://archive.ubuntu.com oneiric-updates/main amd64 Packages
Atteint http://archive.ubuntu.com oneiric-updates/restricted amd64 Packages
Atteint http://archive.ubuntu.com oneiric-updates/universe amd64 Packages
Atteint http://archive.ubuntu.com oneiric-updates/multiverse amd64 Packages
Atteint http://archive.ubuntu.com oneiric-updates/main i386 Packages
Atteint http://archive.ubuntu.com oneiric-updates/restricted i386 Packages
Atteint http://archive.ubuntu.com oneiric-updates/universe i386 Packages
Atteint http://archive.ubuntu.com oneiric-updates/multiverse i386 Packages
Ign http://archive.ubuntu.com oneiric-updates/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-updates/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-updates/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-updates/universe TranslationIndex
Atteint http://archive.ubuntu.com oneiric-security/main Sources
Atteint http://archive.ubuntu.com oneiric-security/restricted Sources
Atteint http://archive.ubuntu.com oneiric-security/universe Sources
Atteint http://archive.ubuntu.com oneiric-security/multiverse Sources
Atteint http://archive.ubuntu.com oneiric-security/main amd64 Packages
Atteint http://archive.ubuntu.com oneiric-security/restricted amd64 Packages
Atteint http://archive.ubuntu.com oneiric-security/universe amd64 Packages
Atteint http://archive.ubuntu.com oneiric-security/multiverse amd64 Packages
Atteint http://archive.ubuntu.com oneiric-security/main i386 Packages
Atteint http://archive.ubuntu.com oneiric-security/restricted i386 Packages
Atteint http://archive.ubuntu.com oneiric-security/universe i386 Packages
Atteint http://archive.ubuntu.com oneiric-security/multiverse i386 Packages
Ign http://archive.ubuntu.com oneiric-security/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-security/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-security/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-security/universe TranslationIndex
Atteint http://archive.ubuntu.com oneiric-proposed/restricted amd64 Packages
Atteint http://archive.ubuntu.com oneiric-proposed/main amd64 Packages
Atteint http://archive.ubuntu.com oneiric-proposed/multiverse amd64 Packages
Atteint http://archive.ubuntu.com oneiric-proposed/universe amd64 Packages
Atteint http://archive.ubuntu.com oneiric-proposed/restricted i386 Packages
Atteint http://archive.ubuntu.com oneiric-proposed/main i386 Packages
Atteint http://archive.ubuntu.com oneiric-proposed/multiverse i386 Packages
Atteint http://archive.ubuntu.com oneiric-proposed/universe i386 Packages
Ign http://archive.ubuntu.com oneiric-proposed/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-proposed/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-proposed/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-proposed/universe TranslationIndex
Atteint http://archive.ubuntu.com oneiric-backports/restricted amd64 Packages
Atteint http://archive.ubuntu.com oneiric-backports/main amd64 Packages
Atteint http://archive.ubuntu.com oneiric-backports/multiverse amd64 Packages
Atteint http://archive.ubuntu.com oneiric-backports/universe amd64 Packages
Atteint http://archive.ubuntu.com oneiric-backports/restricted i386 Packages
Atteint http://archive.ubuntu.com oneiric-backports/main i386 Packages
Atteint http://archive.ubuntu.com oneiric-backports/multiverse i386 Packages
Atteint http://archive.ubuntu.com oneiric-backports/universe i386 Packages
Ign http://archive.ubuntu.com oneiric-backports/main TranslationIndex
Ign http://archive.ubuntu.com oneiric-backports/multiverse TranslationIndex
Ign http://archive.ubuntu.com oneiric-backports/restricted TranslationIndex
Ign http://archive.ubuntu.com oneiric-backports/universe TranslationIndex
Ign http://archive.canonical.com oneiric/partner Translation-fr_FR
Atteint http://archive.ubuntu.com oneiric/main Translation-fr
Atteint http://archive.ubuntu.com oneiric/main Translation-en
Atteint http://archive.ubuntu.com oneiric/multiverse Translation-fr
Atteint http://archive.ubuntu.com oneiric/multiverse Translation-en
Ign http://archive.canonical.com oneiric/partner Translation-fr
Atteint http://archive.ubuntu.com oneiric/restricted Translation-fr
Atteint http://archive.ubuntu.com oneiric/restricted Translation-en
Ign http://archive.canonical.com oneiric/partner Translation-en
Ign http://extras.ubuntu.com oneiric/main Translation-fr_FR
Atteint http://archive.ubuntu.com oneiric/universe Translation-fr
Ign http://extras.ubuntu.com oneiric/main Translation-fr
Ign http://extras.ubuntu.com oneiric/main Translation-en
Atteint http://archive.ubuntu.com oneiric/universe Translation-en
Ign http://archive.ubuntu.com oneiric/main Translation-fr_FR
Ign http://archive.ubuntu.com oneiric/multiverse Translation-fr_FR
Ign http://archive.ubuntu.com oneiric/restricted Translation-fr_FR
Ign http://archive.ubuntu.com oneiric/universe Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-updates/main Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-updates/main Translation-fr
Ign http://archive.ubuntu.com oneiric-updates/main Translation-en
Ign http://archive.ubuntu.com oneiric-updates/multiverse Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-updates/multiverse Translation-fr
Ign http://archive.ubuntu.com oneiric-updates/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-updates/restricted Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-updates/restricted Translation-fr
Ign http://archive.ubuntu.com oneiric-updates/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-updates/universe Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-updates/universe Translation-fr
Ign http://archive.ubuntu.com oneiric-updates/universe Translation-en
Ign http://archive.ubuntu.com oneiric-security/main Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-security/main Translation-fr
Ign http://archive.ubuntu.com oneiric-security/main Translation-en
Ign http://archive.ubuntu.com oneiric-security/multiverse Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-security/multiverse Translation-fr
Ign http://archive.ubuntu.com oneiric-security/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-security/restricted Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-security/restricted Translation-fr
Ign http://archive.ubuntu.com oneiric-security/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-security/universe Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-security/universe Translation-fr
Ign http://archive.ubuntu.com oneiric-security/universe Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/main Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-proposed/main Translation-fr
Ign http://archive.ubuntu.com oneiric-proposed/main Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/multiverse Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-proposed/multiverse Translation-fr
Ign http://archive.ubuntu.com oneiric-proposed/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/restricted Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-proposed/restricted Translation-fr
Ign http://archive.ubuntu.com oneiric-proposed/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-proposed/universe Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-proposed/universe Translation-fr
Ign http://archive.ubuntu.com oneiric-proposed/universe Translation-en
Ign http://archive.ubuntu.com oneiric-backports/main Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-backports/main Translation-fr
Ign http://archive.ubuntu.com oneiric-backports/main Translation-en
Ign http://archive.ubuntu.com oneiric-backports/multiverse Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-backports/multiverse Translation-fr
Ign http://archive.ubuntu.com oneiric-backports/multiverse Translation-en
Ign http://archive.ubuntu.com oneiric-backports/restricted Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-backports/restricted Translation-fr
Ign http://archive.ubuntu.com oneiric-backports/restricted Translation-en
Ign http://archive.ubuntu.com oneiric-backports/universe Translation-fr_FR
Ign http://archive.ubuntu.com oneiric-backports/universe Translation-fr
Ign http://archive.ubuntu.com oneiric-backports/universe Translation-en
Reading package lists... Done
maitre@Serviteur:~$ sudo apt-get install --reinstall libbabl-0.0-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
La réinstallation de libbabl-0.0-0 est impossible, il ne peut pas être téléchargé.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 31 non mis à jour.
maitre@Serviteur:~$

Hugo (morizothugo-yahoo) said : #25

Pretty incredible !!!

i downloaded from http://packages.debian.org/fr/sid/amd64/libbabl-0.0-0/download

tring to open destination folder "download" the fact to clic on the folder to open it make all the desktop shut down !!!!!!!!

Hugo (morizothugo-yahoo) said : #26

I found it !!!!

(impossible is not french !)

  : : == >

maitre@Serviteur:~$ sudo apt-get remove libbabl*
[sudo] password for maitre:
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Note : sélection de libbabl-0.0-0 pour l'expression rationnelle « libbabl* »
Note : sélection de libbabl-0.0-0-dev pour l'expression rationnelle « libbabl* »
Note : sélection de libbabl-0.0-doc pour l'expression rationnelle « libbabl* »
Le paquet libbabl-0.0-doc n'est pas installé, et ne peut donc être supprimé
Les paquets suivants seront ENLEVÉS :
  gimp libbabl-0.0-0 libbabl-0.0-0-dev libgegl-0.0-0
0 mis à jour, 0 nouvellement installés, 4 à enlever et 0 non mis à jour.
Après cette opération, 16,0 Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? o
(Lecture de la base de données... 146513 fichiers et répertoires déjà installés.)
Suppression de gimp ...
Suppression de libbabl-0.0-0-dev ...
Suppression de libgegl-0.0-0 ...
Suppression de libbabl-0.0-0 ...
Traitement des actions différées (« triggers ») pour « gnome-menus »...
Traitement des actions différées (« triggers ») pour « bamfdaemon »...
Rebuilding /usr/share/applications/bamf.index...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
maitre@Serviteur:~$ apt-get install gimp
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13: Permission non accordée)
E: Impossible de verrouiller le répertoire d'administration (/var/lib/dpkg/). Avez-vous les privilèges du superutilisateur ?
maitre@Serviteur:~$ sudo apt-get install gimp
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés :
  libbabl-0.0-0 libgegl-0.0-0
Paquets suggérés :
  gimp-help-en gimp-help
Les NOUVEAUX paquets suivants seront installés :
  gimp libbabl-0.0-0 libgegl-0.0-0
0 mis à jour, 3 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 81,4 ko/5 291 ko dans les archives.
Après cette opération, 15,9 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
Réception de : 1 http://archive.ubuntu.com/ubuntu/ oneiric/main libbabl-0.0-0 amd64 0.0.22-1build1 [81,4 kB]
81,4 ko réceptionnés en 4s (18,3 ko/s)
Sélection du paquet libbabl-0.0-0 précédemment désélectionné.
(Lecture de la base de données... 146139 fichiers et répertoires déjà installés.)
Dépaquetage de libbabl-0.0-0 (à partir de .../libbabl-0.0-0_0.0.22-1build1_amd64.deb) ...
Sélection du paquet libgegl-0.0-0 précédemment désélectionné.
Dépaquetage de libgegl-0.0-0 (à partir de .../libgegl-0.0-0_0.0.22-2ubuntu2_amd64.deb) ...
Sélection du paquet gimp précédemment désélectionné.
Dépaquetage de gimp (à partir de .../gimp_2.6.11-2ubuntu4_amd64.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « gnome-menus »...
Traitement des actions différées (« triggers ») pour « bamfdaemon »...
Rebuilding /usr/share/applications/bamf.index...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Paramétrage de libbabl-0.0-0 (0.0.22-1build1) ...
Paramétrage de libgegl-0.0-0 (0.0.22-2ubuntu2) ...
Paramétrage de gimp (2.6.11-2ubuntu4) ...
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place
maitre@Serviteur:~$ gimp

(gimp:7415): GLib-WARNING **: /build/buildd/glib2.0-2.30.0/./glib/goption.c:2168: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

(gimp:7415): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(file-uri:7454): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(gimp:7415): Gimp-Widgets-WARNING **: gimp_dialog_factory_dispose: stale non-toplevel entries in factory->open_dialogs

maitre@Serviteur:~$

I think an explanation would be that i first try to install gimp with synaptic, and as you says somme ppa are not compatible with ubuntu 11.10

it's something like that ...

               *** SOLVED by the nweebis ***