Gimp is not opening

Asked by Sukhendu Ghosal on 2011-06-28

I have just installed Gimp in my Kubuntu 11.04 ,64bit system. I have downloaded it from System setting > Software management > Get & Remove Software > Graphics > Image editing > Gimp. But after successful installation when I am opening it the icon is blinking sometime then nothing happens. then I thought there is some problems then I removed and reinstalled,but the problem still there.what should I do ? need help.
thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gimp Edit question
Assignee:
No assignee Edit question
Solved by:
Sukhendu Ghosal
Solved:
2011-07-03
Last query:
2011-07-03
Last reply:
2011-07-02
marcus aurelius (adbiz) said : #1

gimp is a horribly written software. did you wait long enough for it to load? when i load it, it usually takes 2 to 3 minutes. have you tried loading it a few times when it didn't work the first time?

how much ram do you have on your system?

Yes I waited long, but still not opened. I have 3 GB ram.

mycae (mycae) said : #3

open a terminal )Not sure about kubuntu, might be ctrl+alt+T, or you may have to find it in the menu), then type

gimp

What is the result? Please post it back here

Sir the output is

sukhendu@Moon:~$ gimp

(gimp:2768): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
Segmentation fault
sukhendu@Moon:~$

mycae (mycae) said : #5

This appears to be a kubuntu bug? Apparently, changing the theme can help, as in here:
http://ubuntuforums.org/archive/index.php/t-1746905.html

Though I am not clear why that works, I must admit. It could be worth a shot though.

Mohsin Falak (fi8er1) said : #7

This had been filed as a bug and been linked to your question. Head over to there for
further assistance. Thanks.

try:

mkdir ~/.gimp-2.6

Then run the app

thanks a lot to this community.
After changing theme my gimp is opening. Great thinking. But is it the solution? thanks again

After succesfully opening the output of gimp is

sukhendu@Moon:~$ gimp

(gimp:2160): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
-:58: error: unexpected character `}', expected character `{'
-:58: error: unexpected character `}', expected character `{'

(gimp:2160): Gimp-Widgets-WARNING **: gimp_dialog_factory_dispose: stale non-toplevel entries in factory->open_dialogs

sukhendu@Moon:~$

@ actionparsnip
the out put is

sukhendu@Moon:~$ mkdir ~/.gimp-2.6
mkdir: cannot create directory `/home/sukhendu/.gimp-2.6': File exists
sukhendu@Moon:~$

Can you give the output of:

lsb_release -a

Thanks

@ actionparsnip

Sir the output of:

lsb_release -a is

sukhendu@Moon:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
sukhendu@Moon:~$

That's cool, is all well and good now?

Sir,
 I am just being a simple user can't say all is well or not. I can just inform that now getting help from here,I am able to open and use gimp. If there is some command line to test it ,please provide me , then I can give you the output.
thanks

If you are able to run GIMP, and you are able to use it without problems, then we can assume that your problem is solved. (And if that is the case, you can come to this question page -- https://answers.launchpad.net/ubuntu/+source/gimp/+question/163036 -- and mark the question as Solved.)

thaks to all.