Gimp only loads from terminal I get; (gimp:3910): LibGimpBase-WARNING **: gimp: wire_read(): error

Asked by PsychJim on 2010-06-11

I can only load Gimp through the terminal. I can't open graphics files from "right-click dialogue", nor from the icon shortcut. When I load from the terminal I get; (gimp:3910): LibGimpBase-WARNING **: gimp: wire_read(): error. Any ideas?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gimp Edit question
Assignee:
No assignee Edit question
Last query:
2010-06-12
Last reply:
2010-06-12
David Mawdsley (dm-madmod) said : #1

I'd suggest that you go to terminal and issue the command to remove command-line gimp. (The following applies to Ubuntu 10.04.)
sudo apt-get remove gimp

Next clean things up a bit with
sudo apt-get autoremove

Once done, go to the Applications | Ubuntu Software Center. Once there click on Graphics and scroll to the GIMP Image Editor. Then install it. When done you should see it in the Application | Graphics menu.

It should work okay then. Best of luck.

PsychJim (jim-daulby) said : #2

Thanks for your response, David. However, I followed your instructions and still can't access Gimp. I now get; "(gimp:3120): LibGimpBase-WARNING **: gimp: wire_read(): error". (Incidentally, I'm using Ubuntu 10.04.) The error seems to have changed from "3910" to "3120".

Please check your partition for errors from terminal type:

sudo touch /forcefsck

then reboot type:

sudo reboot

Then after reboot and partition check, please try to remove your user settings of gimp using terminal type:

rm -fr .gimp-2.6/

Then run gimp from terminal.

Hth

Can you help with this problem?

Provide an answer of your own, or ask PsychJim for more information if necessary.

To post a message you must log in.