Boot problem after compiling gfxboot-theme-ubuntu with default language

Asked by Denis on 2008-09-17

Hello,
i try to localize a 8.04.1 live-cd into breton.
There are two parts in this project one in the squashfs and the other with the gfxboot-theme-ubuntu.
Breton is not in the default langlist, i have to compile it.
To compile it four things have been changed :
- I writed "br" in the langlist,
-I writed [ "br" "br_FR" "Breton" ] in the langnames.inc
- br has been written as default language in the makefile,
- I added the br.po in the po folder.
then $ make
I burned my iso and tested it.
First thing : some string still en english (ie the first line displayed was in english : Try ubuntu without...)
Second thing : the boot sequence does not set the right locale in the system. Here is my /etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LANGUAGE="br_FR:br:fr_FR:fr:en_GB:en"
RUNNING_UNDER_GDM="yes"
LANG="br_FR.UTF-8"
RUNNING_UNDER_GDM="yes"
LANG="en_US.UTF-8"

The two last lines has been set by the system, the others were written "hard" in the squashfs on the cd.

What did I make wrong ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gfxboot-theme-ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Denis
Solved:
2008-09-18
Last query:
2008-09-18
Last reply:
Denis (bibar) said : #1

My first problem is solved : there were some fuzzy strings in my br.po. It's no more a problem !
My second problem is that /etc/default/locale and then /etc/environment are not set like the language I choose at boot time.
What process write /etc/default/locale and where do its variables come from ?

Denis (bibar) said : #2

On progress...
I still don't know who set the /etc/default/locale, but I think my problem is before.
The live-cd i cook should boot in breton, so the file lang contains br. The first page is displayed in breton but then the system boot with en_US locales.
I tried without this file lang. When english or french is choosen no problem. But when breton is choosen, same problem the first page is ok but the system boot in en_US.
Is there a place i forgot to declare my br ?

Denis (bibar) said : #3

Well, I've found my problem !
In the localechooser there is a languagelist file which does not contains breton.
After correction of this file, my language is set in the /etc/default/locale by localechooser
Sorry, thanks for attention,