Get-iplayer failing to load programme lists

Asked by Michael Griffiths on 2015-06-03

command: -

"get-iplayer --pid p00zv0wk"

Output: -
"get_iplayer 2.92-ppa22, Copyright (C) 2008-2010 Phil Lewis
  This program comes with ABSOLUTELY NO WARRANTY; for details use --warranty.
  This is free software, and you are welcome to redistribute it under certain
  conditions; use --conditions for details.

INFO: Episode-only pid detected
INFO: Trying pid: p00zv0wk using type: tv
INFO: Trying to stream pid using type tv
INFO: pid not found in tv cache
Matches:

INFO: 1 Matching Programmes
Not a SCALAR reference at /usr/bin/get-iplayer line 7099."

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu get-iplayer Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2015-06-03
Last query:
2015-06-03
Last reply:
2015-06-03

What is the output of:

lsb_release -a; uname -a; apt-cache policy get-iplayer

Do you use a proxy to get Web access?

Thanks

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.2 LTS
Release: 14.04
Codename: trusty

 uname -a
Linux michael-LIFEBOOK-S7020 3.13.0-54-generic #91-Ubuntu SMP Tue May 26
19:15:38 UTC 2015 i686 i686 i686 GNU/Linux

apt-cache policy get-iplayer
get-iplayer:
  Installed: 2.92-ppa22~trusty
  Candidate: 2.92-ppa22~trusty
  Version table:
 *** 2.92-ppa22~trusty 0
        500 http://ppa.launchpad.net/jon-hedgerows/get-iplayer/ubuntu/
trusty/main i386 Packages
        100 /var/lib/dpkg/status
     2.83-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ trusty/universe i386
Packages

No proxy used

Also note

same symptoms on other two computers. Therefore suspect BBC messing
about again.

Best Regards

On Wed, 2015-06-03 at 06:42 +0000, actionparsnip wrote:
> Your question #267703 on get-iplayer in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/get-iplayer/+question/267703
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> What is the output of:
>
> lsb_release -a; uname -a; apt-cache policy get-iplayer
>
> Do you use a proxy to get Web access?
>
> Thanks
>

Then you are using a PPA. I suggest you either remove it and use the version in the official repos. Or contact the PPA maintainer to report the issue

arochester (arochester) said : #4

I like this: https://squarepenguin.co.uk/wiki/documentation/

To get a list of programmes just use: get_iplayer

Wilfm (wilf-s) said : #5

I am getting this exact issue (I have not had it previously) , using the Fedora 21 build of get_iplayer (v2.92) - from rpmfusion, no patches applied

Line 7099 is the main::logger bit in this section

      if (!grep { /^#EXTINF:/ } @lines) {
                my (@streams, $last_stream);
                foreach my $line (@lines) {
                        if ($line =~ /^#EXT-X-STREAM-INF:(.*)$/) {
                                $last_stream = { parse_m3u_attribs($conn->{href}, $1) };
                                push @streams, $last_stream;
                        } elsif ($line !~ /^#EXT/) {
                                if ( ! defined $last_stream ) {
                                        main::logger "WARNING: Missing #EXT-X-STREAM-INF for URL: $line ($$conn->{href})\n" ;
                                        return
                                }
                                $last_stream->{'URL'} = $line;
                                $last_stream = undef;
                        }
                }
                if ( ! @streams ) {
                        main::logger "WARNING: No streams found in HLS playlist ($$conn->{href})\n";
                        return,
                };

downgrading to v2.90 just results in "ERROR: Failed to get version pid metadata from iplayer site".

I then tried the projects github page
https://github.com/get-iplayer/get_iplayer
and downloading the new v2.93 version works great:

    wget https://raw.github.com/get-iplayer/get_iplayer/latest/get_iplayer
    chmod +x ./get_iplayer
    ./get_iplayer #options go ere

So I think it is a matter that the package just needs to be updated. I will add this over on RPMfusion as well :)

PPA now updated with thanks to all.