gnome-genius package availability for Bionic Beaver 18.04?

Asked by Keith Mann on 2018-05-14

I have installed both Ubuntu 18.04 and Ubuntu Mate 18.04 LTS on my laptops and found the GUI front end (gnome-genius) for Genius maths calculator is not available in the Bionic Beaver software repositories, whereas the CLI engine (genius, genius-common, etc) is.

Artful Aardvark includes gnome-genius, as I was using this application when running Ubuntu 17.10 prior to upgrade.

When will gnome-genius be available on Bionic Beaver?

Regards,
Keith

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu genius Edit question
Assignee:
No assignee Edit question
Solved by:
Keith Mann
Solved:
2018-05-15
Last query:
2018-05-15
Last reply:
2018-05-14
Manfred Hampl (m-hampl) said : #1

From the change log:

Changelog
genius (1.0.23-3) unstable; urgency=medium

  * Update Vcs-* fields to point to salsa
  * Disable gnome interface.
    It depends on components (vte) to be removed from debian. (Closes: https://bugs.debian.org/790171 )

It seems that gnome-genius depends on an obsolete package that is not available in bionic any more, and it can be re-introduced only if it is re-programmed to use the successors of that other package.

Keith Mann (mannkeithc) said : #2

Thank you for your reply. I can see from the bug report that vte will be removed from Debian 10 (Buster).

I did try installing the artful version of gnome-genius, but it fails with libmpfr4 dependency. There was no mention of a vte dependency. The Ubuntu package website advises artful gnome-genius has a dependency on libvte9, but this is still available in the bionic universe (confirmed via synaptic search).

I loaded artful libmpfr4 in GDebi app, which didn't flag any missing dependencies, but so far, I have been reluctant to install over possible conflict concerns with libmpfr6 which is included in the bionic universe, and used by genius (math tool's cli interface - also in the bionic universe).

So in addition to removing the vte dependency, it appears the gnome-genius maintainers also need ensure it is moved up to use libmpfr6.

Regards,
Keith

Manfred Hampl (m-hampl) said : #3

Just a comment:

Looking at the package contents I do not find anything that would prevent installing libmpfr4 (from Artful) and libmpfr6 (from Bionic) at the same time.

But it seems that gnome-genius from artful has a dependency on genius-common (>= 1.0.23-2 and <= 1.0.23-2.) which is not met by the bionic version, but only by the one from artful.