Language/Autocheck spelling must be set each time

Asked by Bob Plantz

Is there a way to make my language preference and "Autocheck Spelling" stick so that I don't have to set them every time I start gedit?

Each time I start gedit I must do two things:

1. Select Tools->Autocheck Spelling

2. Select Tools->Language... and select the language for spell checking

It should be possible to make these options stick so that one does not need to change them every time gedit is started.

I'm guessing that the problem here is that plugins are not allowed to write to the preferences file.

Question information

English Edit question
Needs information
Ubuntu gedit Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Steven Danna (ssd7) said :

This issue seems to be a known bug:

I believe that the language setting is a per-document setting and should be persistent through restarts if opening the same document.

Revision history for this message
Bob Plantz (plantz) said :

Previous versions of gedit behaved as you describe. But the version included with Ubuntu 9.04 (gedit 2.26.1) loses the language setting when the document is closed.

I changed the language in two files and saved them. I then opened one. I had to change the language setting for the document. I did not close this document and opened the second one in the still executing gedit. I also had to change the language setting for the second document.

So I conclude that gedit 2.26.1 does save the language setting with the document, nor does it carry the setting across to another document when it is opened in the same instance of gedit.

Revision history for this message
Steven Danna (ssd7) said :

I've done some testing using my own system and gedit 2.26.1. From what I am seeing it is saving the language settings if I change them from English to Turkish, but it isn't changing them if I change the language from English to English(United Kingdom).

Is this similar to the symptoms you are experiencing or is it not saving the language settings at all?

Either way it seems like this should be filed as a bug.

Revision history for this message
Steven Danna (ssd7) said :

After even more testing it seems that whether it save the language for me is completely random for non-english language and never occurs for English langauge variants.

Revision history for this message
Steven Danna (ssd7) said :

I reported and linked a bug for the symptoms I could reproduce reliably. Please comment on the bug to provide further information.

Revision history for this message
Bob Plantz (plantz) said :

Thank you, Steven, for your testing and reporting. I only tried the US variant of English, did not try other languages. I will follow the bug. Never a dull moment in this business. :-)

Revision history for this message
Mathilda Young (gtrsdk) said :

Does the problem still happen in the newer version of gedit?

Revision history for this message
xoristzatziki (simsonbike-bugs) said :

First of all plain text files cannot (and should not) include languages settings. Gedit is mainly a plain text editor.
Hence (I think that) the idea is:
Since user can open any file, in any language, and since language settings cannot be saved, why "force" a language (even the installed one)? This will confuse user if he opens a file written in a different language in which some words are "correct" (ex in other english variants).
Anyway, this maybe can be accomplished by GIO metadata (e.x. as evince does for bookmarks?). But it will be specific for the file in the specified place and will not be transported.

Can you help with this problem?

Provide an answer of your own, or ask Bob Plantz for more information if necessary.

To post a message you must log in.