When I save a file a second file is created

Asked by kevpower

Hi I am fairly new to Ubuntu and this is my first bug report. I find this ubuntu forum very difficult to navigate and perhaps this bug is already known - I tried to search for this bug and cannot find one listed so I am opening this one.
 Here is my problem :
  Every time I open a text document and I want to type something in it, I can do so. But when I then decided to type something new into my file, I of course want to save the info , so I go "file -save". The file IS saved; but it also creates a second file in whatever folder I am in, and now I have two of them.
 If I go into either of these two files, and type anything , and then hit "save" , I will end up with THREE files!
 It is highly annoying and I keep having to delete the duplicate files. Can some one please tell me how to solve this problem, I think I am using release 7.1 of Gutsy Gibbon thank you ,Kev

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gedit Edit question
Assignee:
No assignee Edit question
Solved by:
kevpower
Solved:
Last query:
Last reply:

This question was originally filed as bug #195672.

Revision history for this message
Dennis Dirdjaja (dcd-ditsch) said :
#1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report and subsequently we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at [WWW] https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see [WWW] https://help.ubuntu.com/community/ReportingBugs .

Revision history for this message
S├ębastien Corriveau (sebcor-deactivatedaccount) said :
#2

The default behavior of gedit is to make a backup copy of a file before saving it. This filename of the backup copy will end with the tilde character: "~". Here's how you can change this behavior:

In gedit, select the following menu options: "Edit" -> "Preferences"
Then, into the second page ("Editor"), uncheck the option to make a backup copy of your file before saving.

Was it what you where looking for ?

Revision history for this message
kevpower (jabodude) said :
#3

   Thank you very much, this solved my very annoying problem!!! I do
wish there was an "easy list" of things like this that differ from Windows,
so that beginners could get their systems set up properly - but then again there
probably is and I am just unable to find it! I have not found Ubuntu to be the easiest thing in the world, I am sure I am not alone in that.Kev