How do I stop displaying the side panel any time I save a file?

Asked by Lou on 2012-07-01

I'm using gedit 3.4.1 as my programming editor, there's an annoying feature: Any time I save changes, the side panel pops up telling me that I have trailing spaces and that my code has lines that exceeded 80 characters, or simply that there are no problems. I would like to stop this panel from showing up, but can't figure out how. Help, please.


Question information

English Edit question
Ubuntu gedit Edit question
No assignee Edit question
Solved by:
Curtis Hovey
Last query:
Last reply:
Best Curtis Hovey (sinzui) said : #1

This does not sound like gedit. The behaviour is indicative of the GDP Format plugin from gedit-developer-plugins. If this is the case, you hush Style and syntax warnings from the menu:
    Menu > Tools > Show syntax errors only

The feature was added in the last six months and the version that support this feature shipped with Ubuntu 12.04. The panel should not appear if there are no warnings...there is a rule to not show the panel if there is nothing to say.

Lou (luism) said : #2

Hi Curtis:

Thanks a lot for your answer. So simple solution. I looked everywhere for it and had the solution right in front of me.


Nightlight (nightlight) said : #3

"Menu > Tools > Show syntax errors only" -- there is no such menu option in Gedit (2.30.04, on Ubuntu 11.03) GDP Format plugin I installed today (from Ubuntu Software Center, it was a plugin section of Gedit entry in U.S.C). The version info on "Gedit developer plugins" is 0.4.5-0. The GDP Format has no specific version, just a copyright 2009 Curtis Hovey.

Any time save some file, it changes my open file or folder selection panel to another one about lines longer than 78 char and trailing blanks, neither of witch I could care less about. The only way to disable the "helpful" unasked for panel switching in this OS/Gedit/GDP Format version seems to be to uncheck GDP Format altogether (and give up on few other features).