Can't find out how to stop the search filelds from autocompleting.

Asked by Mysha on 2012-02-11

When doing a search in GEdit 2.30.3 within Gnome 2.30.2 under Ubuntu 10.04 LTS, the field in the search window will auto-complete the search term for me.

Typically, this means that if I search for a long term and get no hits, I will then search for the exact same term again, and again get no hits. That's not because I want to search for the same thing again, but because I want to search for a shorter term next, and the search window then improworsens my input, and needing to look at my typing I'm unable to see that what goes in is not the same thing I type.

I would like to switch of this behaviour. Is there a way to do so?

From searching the web, I find I'm not the only one who would like to do so. I also find it's unlikely that switching this off is possible at the moment, as questions about it have been up for more than a year on several websites, without any replies.

If it's indeed impossible to switch it off, currently, I would like to request a setting for this. Where and how does one enter such a request? (Where there are preference settings that I would prefer to be in the menu, so I could switch them on and off as needed, this specific setting is definitely preference material for me, as I do not normally have any purpose for this search-auto-completion. I don't know whether a request would have to go into details of an option versus a preference, though.)

And as a side question: Why does the text below this window implore me to basically add as much bug-report information as possible, even though I indicated I wanted to ask a question?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gedit Edit question
Assignee:
No assignee Edit question
Last query:
2012-02-11
Last reply:
2012-02-12

Disable the plugin maybe...

Chris (fabricator4) said : #2

I don't believe that the search history is a plugin - there isn't one that I can find.

In any case the previous search term is automatically marked when the dialogue box comes up. That means you can get rid if just by hitting the del key once. You can also type a partial, then hit the del key to remove the rest of it, or mark the bits you don't want, then hit the del key. Since the work-around is so simple and easy I guess the developers did not really think it would be objectionable. Certainly I find it a very useful feature since it's the absolute best of both worlds.

Chris

Curtis Hovey (sinzui) said : #3

You cannot configure the behaviour of find.

The find feature was completely reimplemented in subsequent version of gedit. The autocomplete feature is in the actual text editor window and uses the native gtk text find features, The suggestions are from the document's history only. It make few mistakes when suggesting, but I think the paste rule are different because it appends to the text in the find field instead of replace.

Can you help with this problem?

Provide an answer of your own, or ask Mysha for more information if necessary.

To post a message you must log in.