Turn off GDM sound in Karmic?

Asked by Paul V. Stodghill on 2009-10-23

Under Jaunty, the sound the was played when GDM displayed the login window could be modified/disabled by System -> Administration -> Login Window -> Accessibility. Under Karmic, there is no longer an Accessibility tab, nor does there appear any option for disabling sound for GDM.

Under Karmic, how is one supposed to disable sound for GDM?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdm Edit question
Assignee:
No assignee Edit question
Solved by:
Cristi Nistor
Solved:
2009-10-24
Last query:
2009-10-24
Last reply:
2009-10-23
Simon Déziel (sdeziel) said : #1

Go in System->Preferences->Startup Applications you will then find GNOME Login Sound.

Simon Déziel (sdeziel) said : #2

What I usually do instead is disable Ubuntu sound theme in System->Preferences->Sound.

Both of these solutions will turn off sounds in my session AFTER I have logged in.

How do I disable the sound associated with the login screen (GDM)?

Thanks.

Best Cristi Nistor (cristi-nistor) said : #4

You can run this command in a terminal:

sudo -u gdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false

More details about this "noise" here:

https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/437429

Good luck.

Thanks Cristi Nistor, that solved my question.