Ubuntu 12.10 beta 2 upgrade - login issue, moved /home

Asked by Davide on 2012-10-01

Hi guys,

I upgraded ubuntu from version 12.04 to version 12.10 beta2 last days.
The main problem is that I can't login to my desktop, when i login the form turns back to lightdm.

The only thing that i can do is to access on TTY1, I found some threads throught Google but no one solutions resulting useful.

1 - Using GDM i receive an error like "ICEauthority" is not exists
2 - I can't move or delete Xauthority / ICEauthority because they are not exists in home dir.
3 - I removed amd video drivers when I upgraded because they are not already developed for ubuntu 12.10, The catalyst 12.9 driver is not working with my card (HD6850) so I'm using standard drivers.

I think that the issue is related to the moving of my home directory from /home/dave to /root/dave infact i found my documents on /root/dave.... I tried to change my home directory with the command usermod but i can't do nothing.

Help me please, I have to work! and I can't continue with my laptop!!

Thank you
Davide

ps. I'm still upgrading the OS every days

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdm Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2012-10-02
Last query:
2012-10-02
Last reply:
2012-10-01

Can you give the output of:

ls -la ~/.ICEauthority
ls -la ~/.Xauthority

Thanks

Davide (pigroz) said : #2

Yep!

all commands return me the following strings:
ls: impossible to access to //.ICEauthority: File or directory not exists
ls: impossible to access to //.Xauthority: File or directory not exists

and the same is when I run commands on root@ using "sudo -i"

Did you run the commands I gave in a terminal?

Davide (pigroz) said : #4

Yep,

I run your commands on TTY1 (ctrl + alt + f1)

Funny because if I use ls -la on a file that doesn't exist, I get this:

andy@D420:~$ ls -la ~/.ICEauthorityp
ls: cannot access /home/andy/.ICEauthorityp: No such file or directory

So you must ave typed it wrong.....

What is the output of:

cat /etc/lsb-release; uname -a

Thanks

Davide (pigroz) said : #7

Yep, I'm translating from Italian distribution to english so is not a perfect translation.

Your last command return me :

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.10
DISTRIB_CODENAME=quantal
DISTRIB_DESCRIPTION="Ubuntu quantal (development branch)"
Linux mymachinename 3.5.0-16-generic #25-Ubuntu SMP Fri Sep 28 22:31:15 UTC 2012 x86_64 x86_64 x86_64 GNU/linux

Try:

touch

touch ~/.ICEauthority

Then retry your commands

Davide (pigroz) said : #9

ok! I tried to do the touch command.

If i use it on dave@ i got "permission denied":

touch: impossible do touch of "//.ICEauthority": Permission denied

If i use it on root@

root@mymachinename:~# touch ~/.ICEauthority
root@mymachinename:~# ls -la ~/.ICEauthority
ls: cannot access to /root/.ICEauthority: No such file or directory
root@mymachinename:~# ls -la .ICEauthority
ls: cannot access to .ICEauthority: No such file or directory

why are you root? You need to run this stuff as your user. This is all probably caused by you messing around a root, rather than using sudo as the OS is designed

Davide (pigroz) said : #11

I never used root until today, when i learnt the command sudo -i

As already done, if i write touch as you said:

dave@mymachinename:~# touch ~/.ICEauthority
touch: impossible do touch of "//.ICEauthority": Permission denied

then run:

exit

and use YOUR user, you'll have fewer issues.

Davide (pigroz) said : #13

I already done, I've rebooted the system and logged in TTY1 with my account (dave):

this is the result of touch command

dave@mymachinename:~# touch ~/.ICEauthority
touch: impossible do touch of "//.ICEauthority": Permission denied

Then run:

sudo chown -R dave:dave /home/dave

And it will help, you'll get a warning but it's ok

Davide (pigroz) said : #15

Ok, done.

dave@mymachinename:~# sudo chown -R dave:dave /home/dave
chown: cannot access to "/home/dave": No such file or directory

I rebooted another time and seems not working, when I write my password on lightDM return into lightDM

note: i read in TTY1 on the last line of the login header:
Ubuntu come with ABSOLUTELY NO WARRANTY, to the extent permitted by applicable law.

No directory, logging in with HOME=/

You haven't changed user as the prompt is still # so you are simply changing the word 'root' to 'dave'. This isn't even a user in your system which further concretes my idea.

Davide (pigroz) said : #17

you are right, the symbol between the command line and / is a dollar $, I'm sorry but I copied the lines of the old post to write faster

N1ck 7h0m4d4k15 (nicktux) said : #18

Can you give the results of these 2 commands ?

sudo blkid

cat /etc/fstab

Thanks

Davide (pigroz) said : #19

yep!

sudo blkid

/dev/sda1: UUID="da264fd1-fda8-461b-8ee7-bfd06ae31081" TYPE="ext4"
/dev/sda5: UUID="02c946c1-899d-47c8-960a-bcb2624fc69d" TYPE="swap"
/dev/sdb1: LABEL="Volume" UUID="FC5EDA425ED9F57C" TYPE="ntfs"

and cat/etc/fstab

(not commented lines)
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=da264fd1-fda8-471b-8ee7-bfd06ae31081 / ext4 errors=remount-ro 0 1
#swap was on /dev/sda5 during installation
UUID=02c946c1-899d-47c8-960a-bcb2624fc69d none swap sw 0 0

Best N1ck 7h0m4d4k15 (nicktux) said : #21

You can try these commands

1) mkdir /home

2) sudo rsync -aSv /root/dave /home/

Thanks

Davide (pigroz) said : #22

Thank you very much!! you saved my pc!!

your rsync works well

Davide (pigroz) said : #23

Thanks NikTh, that solved my question.