How do I change default window manager in gdm?

Asked by Todd Taft on 2012-07-24

How do I change the default window manager that gdm selects (e.g. GNOME, GNOME Classic, Ubuntu, etc.) in Ubuntu 12.04 (precise)? I want to change which one is selected by default (without disabling the other options) for all users on the machine.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gdm Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-07
Last reply:
2012-08-07

When you log in, the last session is remembered.

Todd Taft (taft) said : #2

That does not address the way to select the default for ALL users of a system. I don't have a problem with individual users changing the default for their own account, but how do I set the default session for someone who has never logged in or who has only logged in to a system with an older OS release (e.g. 10.04)?

Andy Ruddock (andy-ruddock) said : #3

It's x-session-manager that determines the default.
Open a terminal and type :

sudo update-alternatives --config x-session-manager

If there's only one option available (as there probably is after a clean install) you'll get the following :

There is only one alternative in link group x-session-manager: /usr/bin/gnome-session
Nothing to configure.

Otherwise you'll get a list of available session managers to choose from, one of which will already be selected as the default.

Use "man update-alternatives" for more info.

Todd Taft (taft) said : #4

So, how do I select among the different Gnome options? (e.g. GNOME, GNOME Classic, Ubuntu, etc.)

When I run the update-alternatives command given above, I'm not given any options, but the gdm login screen gives multiple options.

Use the Ubuntu logo near your username before you log in

Todd Taft (taft) said : #6

That doesn't change the default. I want to change the default.

It does as the last session is remembered for each user

Andy Ruddock (andy-ruddock) said : #8

The "default" is that session for a user who hasn't logged in yet, so doesn't have a previous session to remember.

12.04 has changed the default display manager from gdm to lightdm, the default is set in /etc/lightdm/lightdm.conf
I found this http://askubuntu.com/questions/62833/how-do-i-change-the-default-session-for-when-using-auto-logins which may help.

Can you help with this problem?

Provide an answer of your own, or ask Todd Taft for more information if necessary.

To post a message you must log in.