Xubuntu 11.04 fails to logon correctly

Asked by Geoff Smith on 2011-09-06

After powering on, xubuntu 11.04 log on screen is distorted and system won't logon with correct password - simply goes back to another logon screen (not distorted this time) however password still not accepted. Eventually tried entering recovery mode and without really knowing what I was doing (I tried most options) eventually after a reboot I was able to log on correctly. This is second time I have had this error occur, previously I did a re-install to fix problem. I am really a novice user however is there a command or series of commands I can implement from Ctrl-Alt-F5 terminal to rectify if this problem occurs again? Should I consider this a bug and if so is quoting the relevant configuration & log files necessary?

Thank you,
With kind regards,
Geoff Smith

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdm Edit question
Assignee:
No assignee Edit question
Solved by:
Geoff Smith
Solved:
2011-09-06
Last query:
2011-09-06
Last reply:
2011-09-06

This question was reopened

Press CTRL+ALT+F1 and login there, can you then run:

sudo apt-get clean; df -h

Is there some free space on all partitions listed?

Thanks

Geoff Smith (taurusone) said : #2

Hello and thanks Andrew,
Firstly I apologize in the delay of my reply but after issuing recommended commands I again had problem when rebooting. As a result I ended up re-installing. First results showed -
                                          used
/sda1/ ext 3 2GB 110Mb /boot
/sda3/ ext3 9998MB 9498 100% /
/sda5/ext4 18499 3201Mb /home

After new installation gparted shows
                                                       used unused
sda1/ ext3 1.86Gb 105.8 Mb 1.76 Mb /boot
sda3/ ext3 9.31Gb 3.43 Gb 5.88 Gb /
sda5/ ext4 17.23Gb 2.98 Gb 14.25 Gb /home

I can't understand why original installation showed 9.498 Gb used in / partition. (now 3.43 Gb)
Would you have any explanation for that Andrew?
At this stage it would appear that problem may be solved.
Thank you very much for your assistance Andrew.
With kind regards,
Geoff Smith.

can you give the output of:

dpkg -l | grep linux-image

I may be able to free some space for you

Geoff Smith (taurusone) said : #4

Hello and thanks Andrew,

geoff@ABC:~$ dpkg -l | grep linux-image
ii linux-image-2.6.38-11-generic 2.6.38-11.48 Linux kernel image for version 2.6.38 on x86/x86_64
ii linux-image-2.6.38-8-generic 2.6.38-8.42 Linux kernel image for version 2.6.38 on x86/x86_64
ii linux-image-generic 2.6.38.11.26 Generic Linux kernel image

I have noticed that the used part of / has crept up to 3.77 Gb with no usage as far as I can tell other than the screensaver.

Kind regards,
Geoff Smith.

ok and the output of:

uname -a

(just to be double sure) Thanks

Geoff Smith (taurusone) said : #6

Thanks Andrew,

geoff@ABC:~$ uname -a
Linux ABC 2.6.38-11-generic #48-Ubuntu SMP Fri Jul 29 19:05:14 UTC 2011 i686 i686 i386 GNU/Linux

sudo apt-get --purge remove linux-image-2.6.38-8-generic; sudo apt-get --purge autoremove

Should free up a fair whack of space. I also suggest you install bleachbit and run it as both root and user (have as many apps closed as possiblt). Watch settings that say they wil take a long time and watch your app settings (especially browsers) as it will remove settings you want.

If you have libreoffice installed but only use spreadsheet and writer, you can uninstall the whiole suite (300Mb) and install abiword (15Mb) and gnumeric (15Mb), which will save more space.

Geoff Smith (taurusone) said : #8

Hello,

I will follow your instructions - thank you very much for all of your help Andrew.

With kind regards,
Geoff Smith.

You need some free space, or logins don't work :)

Geoff Smith (taurusone) said : #10

My setup is as follows -
sda1 ext3 1.86 Gb boot
unallocated 6.06 Gb
sda3 ext3 9.31 /
unallocated 1.16 Mb
sda2 Extended 20.04 Gb
sda5 Ext4 /home 17.23 Gb
sda6 swap 2.81 Gb
Would it be possible for me to adjust / partition via the 6.06 Gb unallocated space next to it via gparted in CD?
If it is I may have to ask for help on the forum as I don't know what to do unless you can help me.

Thanks very much for your help to now Andrew.

Geoff Smith (taurusone) said : #11

Hi Andrew,
I took the plunge and used gparted to increase the size of the / partition to 15.36 Gb - There don't seem to be any problems - logged on O.K. I assume all should be well now. The home partition is not particularly large but will suit my needs for now. I am planning to purchase another computer in around six months so this one only has to last until then. Thank you very much for putting me on the right track Andrew, I don't expect I will be hearing from you again regarding this question unless I have missed something.
I will mark the problem as solved.
With kind regards,
Geoff Smith.