10.04 wont accept password

Asked by Terry King on 2011-06-27

Ubuntu 10.04 worked fine until about an hour ago. After installing the gui interface for Samba I restarted the computer and tried to log in. At each attempt the screen just returned to the login screen. If I choose recovery mode in Grub I can log in without any trouble, so my password and user name are both OK. If I type "startx" after logging in the computer hangs with just the cursor and a blank screen. I have run package repair but to no avail. What should I do next?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdm Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2011-07-01
Last query:
2011-07-01
Last reply:
2011-06-30

Why do you have to run startx? did you install some video driver which stops the GUI loading at bootup? Which samba gui did you insteall?

Terry King (terryking) said : #2

My Ubuntu installation was set to ask for my password on startup, after typing in the password it would then go to the graphic desktop. Until today, that is. I can't remember the Samba gui and I don't know how to check which one it was without getting to the desktop. I haven't made any recent changes to the video driver. I ran startx after successfully using my user name and password at the command line that I reached after choosing recovery mode from Grub. I wanted to see whether that would get me to the graphic desktop.

Try:

sudo apt-get --reinstall install gdm; sudo dpkg-reconfigure gdm

May help

Terry King (terryking) said : #4

Thanks but problem unchanged

Sam_ (and-sam) said : #5

> Samba gui and I don't know how to check which one it was without getting to the desktop

Actually you can do anything in console or recovery mode (root shell).
dpkg -l samba* | grep ii

apt-get purge <package>
gdm stop
dpkg-reconfigure gdm
gdm start
exit

List of Samba packages for Lucid.
http://packages.ubuntu.com/search?suite=lucid&arch=any&searchon=names&keywords=samba

Sam_ (and-sam) said : #6

Erratum.
Mistakenly converted Upstart commands.
It's
stop gdm
start gdm

Sam_ (and-sam) said : #7

It may also be the case you're in a gdm loop, which can happen when there is less disk space available and it can't create a tmp directory.
Clean up the disk.
apt-get clean
apt-get autoclean
apt-get autoremove

In case purge former kernel images, but of course not the one you're booting with.
First find out which image is booted:
uname -a

Search for other images:
dpkg -l linux-image* | grep ii

Remove image.
apt-get purge <package>

http://chrisjean.com/2009/03/05/cleaning-out-old-linux-kernels-in-ubuntu/

Terry King (terryking) said : #8

Thanks again for your attention to my problem. The package that I installed was system-config-samba. I removed it and then followed your suggestion to reconfigure gdm. The problem is still there. The timing of the problem, coming just after the Samba gui installation was probably a coincidence. Disk space is not a factor here, only about 40% of a 250G drive is in use.

What happens if you change the session type in the graphical login screen, for example, from "GNOME" to "Failsafe GNOME"? (This setting is available in the bottom bar, after you have specified your username, while you are being prompted for your password.)

Terry King (terryking) said : #10

Thanks for the suggestion but this setting is not available on my computer. Only language and keyboard choices are shown.

Terry King (terryking) said : #11

It seems that, while I haven't consciously made any changes to the driver, actionparsnip's original suspicion in his comment (#1) about the video driver might be right on target. Going back to the recovery console and choosing the low graphics startup option I get the error messages

(EE) [drm] failed to open device
(EE) failed to initialize GLX extension (compatible NVIDIA X driver not found)

Sam_ (and-sam) said : #12

apt-get update
apt-get upgrade
apt-get -f install
apt-get install nvidia-current
reboot

Terry King (terryking) said : #13

Thanks for trying Sam but the problem remains unchanged.

Terry King (terryking) said : #14

I should have pointed out that my machine has on old GeForce2 MX400 graphics card.

Best Sam_ (and-sam) said : #15

Not on my pc at the moment, could it be that installation of samba-config removed ubuntu-desktop?
apt-get install ubuntu-desktop
or
dpkg-reconfigure ubuntu-desktop

Try a websearch with ubuntu+GeForce2 MX400, e.g.
http://ubuntuforums.org/showthread.php?p=10073441

Terry King (terryking) said : #16

Thanks Sam. It worked. Thanks also to everyone else who responded.

Terry King (terryking) said : #17

Thanks Sam_, that solved my question.