Ubuntu

Deleted users and cannot sign in to computer

Asked by Matthew Jones on 2011-05-28

I was trying to delete accounts on my Dell Mini 9 so it would boot without having to login but i deleted all the accounts and cannot get passed the login screen. After several tries, it now wont even let me type or use my mouse..... i have no clue how to do anything on ubuntu so i need some serious help. I feel like a complete factory reset would work but i need some directions......

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdm Edit question
Assignee:
No assignee Edit question
Solved by:
Matthew Jones
Solved:
2011-05-29
Last query:
2011-05-29
Last reply:
2011-05-28

Boot to root recovery mode and run:

useradd santa; usermod -a -G admin santa

Then run:

reboot

You can now log in as santa with the password you set, it is part of the admin group so can run sudo and gksudo commands to get admin access.

i dont know how to do any of that... i keep trying to figure out how to get into recovery mode and i cant get it to work

Hold shift at boot, select recovery mode then select root

holding shift gets me to a black screen that says: MBR 2FA: and then a blinking _

Not good, have you tested your RAM using liveCD or USB

theres no cd drive but it does have usb ports.... deleting the accounts mustve messed up some crucial setting

i tried using my old administrative account and password and somehow it came back.... ubuntu must be mistake proof