Cant decrypt home folders

Asked by Path on 2011-05-19

I did a clean install of Natty (11.04) Gnome 2.32.1 on my wife's laptop with the option to encrypt the home folder
She complains about always having to enter her user-name and password, so i turned off entering of password on start-up.
Now when the computer starts up it only asks for user-name and not password. Now it does not decrypt the home folder and i get error mgs. I don't get anything on my desktop just a screen with the background she choose. How can i get back into what ever is is i need to get back into to change back to entering password on start-up??

P.S. Im still a greenhorn to Linux about (user for about 10 months). and i love Linux by by windows.

Path

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdm Edit question
Assignee:
No assignee Edit question
Solved by:
Path
Solved:
2011-05-19
Last query:
2011-05-19
Last reply:
2011-05-19
wojox (wojox) said : #1

You enabled Automatic Login? Well I guess I won't give you the speech on why not to do that since you probably figured it out. :)

You need to boot of of a Live-CD and mount your Ubuntu partition and run

sudo nano /etc/gdm/custom.conf

Look for this line and change it to false:

automaticloginenable=true

Save and reboot.

Path (unix-linux-ubuntu) said : #2

i followed your instructions but i still get these error msg. 1. Could not update ICEauthority file /home/pauline/.ICEauthority

2. There is a problem with the configuration server. (/usr/lib/libgconf2-4 /gconf-sanity-check-2 exited with status 256)

wojox (wojox) said : #3

Log into the Recovery Console and run

chown pauline:pauline /home/pauline/.ICEauthority
chmod 644 /home/pauline/.ICEauthority
exit

Path (unix-linux-ubuntu) said : #4

Thank you soo much
pat