updated and now have no password box?

Asked by Phil harflett on 2011-04-03

just done the update manager and now I have no password box when I start my laptop? I can see no way of getting past the initial screen? All there is on the screen is a box in the centre with ubuntu 10.10 on it and botton right I have a Universal Access Preferences symbol, day and time and Shut Down options? Please help!!!!!!!!!!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdm Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2011-04-03
Last query:
2011-04-03
Last reply:
2011-04-03

In addition to there not being a textbox for you to type in your password, is there also no list of usernames (this might be a one-item list)?

What happens when, before doing anything else after that screen comes up, you press the enter key once?

BabyGeek (babygeek) said : #2

Go to: "System" > "Administration" > "Users and Groups" and click "change" at the right of "password".

Phil harflett (philkatie) said : #3

Eliah: If I press enter key once, nothing at all happens?

BabyGeek: I have no way of going to system etc as there is no option to click on?

thanks for all help.

BabyGeek (babygeek) said : #4

Open the terminal (if you can't, press ALT + F2) then enter this: sudo users-admin

Phil harflett (philkatie) said : #5

BabyGeek: I did that but it says that my login is incorrect?

BabyGeek (babygeek) said : #6

Ah... i thought you can access your session but you wanted enable password.
Sorry i can't help you...

Best Sam_ (and-sam) said : #7

You sure didn't change the option to autologin without password?

There has been an update for gdm.
http://changelogs.ubuntu.com/changelogs/pool/main/g/gdm/gdm_2.30.5-0ubuntu4.1/changelog

> Shut Down options

Ok, then reboot please.
Right after boot switch to tty (virtual console, text mode only): ctrl+alt+f1
Type:
dpkg-reconfigure gdm
startx

Please let us know what happens, exact wording of error messages.

Other option.
Right after boot press [Shift] in case your settings don't allow to view boot menu.
Boot into Recovery Mode.
Choose option: repair broken packages
http://unixlab.blogspot.com/2009/08/exploring-ubuntu-recovery-mode.html

Phil harflett (philkatie) said : #8

Sam: excellent! now have the password box - yes!! Oh, slight problem, keyboard now not responsive so have password box but can't type password in - argh!!!!!!!
any thoughts are very welcome?!

Phil harflett (philkatie) said : #9

sorry being really thick!!! Works fine. many thanks for help :-)

Phil harflett (philkatie) said : #10

Thanks Sam_, that solved my question.