Upon boot always go to terminal mode

Asked by Gilbert Tan TS on 2011-04-02

I have installed Ubuntu 10.10 Desktop Edition and upon boot, it always go to terminal mode. What command must I use to get back on normal mode. I have already tried sudo apt-get upgrade to the latest packages but still get into terminal. Any help will b appreciated. I have tried reinstalling but it did not work.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdm Edit question
Assignee:
No assignee Edit question
Solved by:
Gilbert Tan TS
Solved:
2011-04-05
Last query:
2011-04-05
Last reply:
2011-04-03

This question was reopened

startx

will start the x server assuming all is well. If not then run:
less /var/log/Xorg.0.log

look for errors and warnings, use Q to exit less

Gilbert Tan TS (gilberttants) said : #2

When typing startx, I get ;
Fatal server error
no screens found.

When running the second command, I get;
No such file or directory

Please help.

Gilbert Tan TS (gilberttants) said : #3

I am now able to start normally but when I see the login screen, the password I used for setup is unable to log me in. Tried reinstalling but still get back the same problem. Change user and password for setup but still encounter the same problem, unable to login, please help.

madill (sciso) said : #4

Can you login via terminal or as Root?
If you can login ass root try the command
        passwd <yourusername>
and enter a new password when prompted.
Just a shot in the dark here but check your keyboard settings perhaps they have changed at some point and know what you are typing is different from what the computer thinks you are typing.

Gilbert Tan TS (gilberttants) said : #5

There is a bug in your sudo apt-get update script that forced the user to login even though u set it to login automatically and changes your password to something else. Please check if anyone else is facing the same issue when connecting to the Internet. By NOT connecting to the Internet and reinstalling, I manage to solve the problem but I am afraid if I update the software, the problem may come back. Can u check if it is safe to update?

Gilbert Tan TS (gilberttants) said : #6

When NOT connected to the Internet, the problem is the same, even after formating the harddisk, still gets into terminal mode, after running sudo apt-get update, it returns to normal mode but I am unable to login, must have tried more than 20 installations without success, it still brings me to login screen and I am unable to login, please help URGENTLY, if this continue I am not able to do any business.

Gilbert Tan TS (gilberttants) said : #7

I am going to try and download a new copy of Ubuntu Desktop 10.10 and try reinstalling if it will resolve the problem. Will feedback to you the outcome.

Gilbert Tan TS (gilberttants) said : #8

No use, even with the new copy of ubuntu, I still get into terminal mode, and when I sudo apt-get update, the same problem occurs, it will bring me to the login screen and I am still unable to login with my new user ID and password. Please help URGENTLY.

Gilbert Tan TS (gilberttants) said : #9

I am going to try reinstalling ubuntu and format the harddisk, create a new user ID and password, and when I get to terminal mode, will use the command startx instead. Will post to let u know the outcome.

Gilbert Tan TS (gilberttants) said : #10

When typing startx, I get ;
Fatal server error
no screens found.

When running the second command, I get;
No such file or directory

Please help.

Try updating Ubuntu, reboot, and see if that fixes the problem. You can update from the command-line by running:

sudo apt-get update; sudo apt-get upgrade

Also, I neglected to mention this, but the best way to reboot from the command-line is

sudo reboot

or, if you prefer:

sudo shutdown -P now

Gilbert Tan TS (gilberttants) said : #13

After rebooting it goes back 2 normal mode, with the login screen, and with the same problem again, can't login. Can't get back to command line, so unable to try your suggestion.

Can you get back to the command-line by pressing Ctrl+Alt+F1?

Gilbert Tan TS (gilberttants) said : #15

Tried your method n can get into command line. After keying sudo command and letting it run for more than 30mins, it reboot to the login screen, and the saame problem occurs again, unable to login. This is driving me crazy, please help me URGENTLY. It has been more than 12hours and I have tried reinstalling more than 50 times but cannot resolve the issue.

What was it doing when it was running for over 30 minutes? What kind of information did it give you? Did it appear to be stalled? Did you stop it after about 30 minutes, or did it just snap back to the graphical login screen by itself? If it just snapped back by itself (and you haven't rebooted the machine yet), can get you back to the command-line by pressing Ctrl+Alt+F1 again?

Gilbert Tan TS (gilberttants) said : #17

When it was running, it was updating all the packages and installing them without any errors until completion. When completed, I was at command prompt when I sudo reboot and go back to login screen. Same problem here, still cannot login. System does not appear to be hanged.

Gilbert Tan TS (gilberttants) said : #18

Tried Ctrl+Alt+F1 can get to command prompt. from there can login with any issue. At root, ran passwd <username> and change password without issue. Issue sudo reboot to return to normal mode login screen but still cannot login with CHANGED password. It appears to be a bug in the login module.

How much free space does it say you have on the volume that has "/" under "Mounted on", when you run the command:

df -h

?

Gilbert Tan TS (gilberttants) said : #20

I have installed Ubuntu Desktop 10.10 on a new compaq desktop and I face no issue, everything works fine. So I suppose it is my OEM Desktop with specs that are not compatible with ubuntu. The very most I dun use that desktop anymore. You can consider the case closed.