Boot up problem

Asked by donaldt on 2011-03-28

I had to re-configure my Ubuntu 10.10 and go back to the original factory configuration. When I did that, I was unable to get it to re-boot. Instead, I get a small terminal screen and cannot get past that. I believe I need to somehow get a password to the system but it is not asking for one. It just has the normal donald@donald $ with a cursor.

What do I need to do to continue the boot process?

Thanks for any assistance. Much appreciated, as always.

donaldt

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdm Edit question
Assignee:
No assignee Edit question
Solved by:
Ubfan
Solved:
2011-04-05
Last query:
2011-04-05
Last reply:
2011-04-04

This question was reopened

Ubfan (ubfan1) said : #1

Looks like you have booted into a "virtual terminal". Usually Alt-F1 through Alt-F6 are individual vitual terminals, with the X session running on F7. Try typing:
sudo startx
to see if you get into your desktop. (You must have selected automatic login if you are not at a login prompt on the first virtual terminal).
Once in a running X session Alt-F7 to get into X, it takes Ctrl-Alt-Fn to get back to the virtual terminals. You may shutdown the system cleanly by typing
sudo shutdown -h -t0 now
If X doesn't start, you may have to reinstall some X packages.
I have no idea what you mean when you "re-configured back to factory defaults".

donaldt (djt13) said : #2

Yes, you are correct. Auto Login also. sudo startx produced a fatal server error. I found a way through grub alternate boot to get back into the GUI. I have been afraid to shut it down. If I do "sudo shutdown -h -t0 now" will I be able to return to the x desktop window and find it as I left it? I've confirmed the start up does not ask for a password. Admin/users & groups/password "not asked on login" is set up.

what are my chances it will work?

Thanks very much for your help!

donaldt

Ubfan (ubfan1) said : #3

The shutdown will always be better than just powering down. If the alternate boot worked, it should work again. Looks like you have a video driver issue. You might try looking at system/Additional drivers and see what proprietary driver is offered, if any. The file /var/log/Xorg.0.log might have the errors which the X server had on startup. You might want to start another question if the issue is the video driver, or look at some of the other questions related to "blank screen" to see various solutions to video problems.

donaldt (djt13) said : #4

Ubfan,

Sincere thanks for your help. Unfortunately, I shut down using your
suggested sudo shutdown command and was once again on re-boot only able
to access the 2x3" white terminal window. Typing "sudo startx" in
terminal produced the same result. "x is already running on 0. Fatal
server error...etc."

I have been able to start an x system, but it is a new one and not my
desktop that comes up.

I believe my original desktop is running in the background. When I get
the fatal server error, it says X is running. Also, I always see the
Ubuntu boot screen whenever I shut down but am unable to find a way to
get it to boot up.

I tried system drivers and it said no proprietary drivers are used and
none are available. I don't understand how I get at the F1 through f7
keys to try anything. When I am in the terminal mode nothing happens.
I can't get the alternate repair mode to work with any of the choices
presented.

I'm sure this is something rather simple and trivial, but I can't find
what is causing the problem. Any other ideas?

donaldt

On 3/29/2011 10:08 AM, Ubfan wrote:
> Your question #150786 on gdm in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gdm/+question/150786
>
> Ubfan posted a new comment:
> The shutdown will always be better than just powering down. If the
> alternate boot worked, it should work again. Looks like you have a
> video driver issue. You might try looking at system/Additional drivers
> and see what proprietary driver is offered, if any. The file
> /var/log/Xorg.0.log might have the errors which the X server had on
> startup. You might want to start another question if the issue is the
> video driver, or look at some of the other questions related to "blank
> screen" to see various solutions to video problems.
>

donaldt (djt13) said : #5

I still have the same problem. I don't see how it can be a video issue, as everything works once I get into Ubuntu via "startx"

Latest episode: Ubuntu 10.10 launch from Grub 2 menu, current kernel in repair/alternate mode. Via several tries and "drop to command line w/---" finally reached a command line that did not require "sudo". Entered "startx" without sudo, listened to brief "Ubuntu theme music" and voila, my desktop appeared just as I left it 3 days prior. I will not shut it down again until I learn what is wrong.

How do I get the boot up to by-pass the terminal ghost window?

What is making the selection from the grub menu open a phantom terminal window in a white box? Why is it not asking for a password? From my perspective something in the boot up process is producing the terminal window that stops anything else from loading. It seems to me that is what needs to be fixed.

Any help will be much appreciated. I'm in my second year with Ubuntu and it is great when it works, but maddening under these circumstances.

Thanks!

donaldt

Ubfan (ubfan1) said : #6

The X session typically runs on terminal 7, so from any other terminal (1-6), you should be able to get to it my holding down the Alt key and typing the function key F7. Once you are in the X session, you may leave it and go back to virtual terminals 1-6 but you need to ALSO hold down the Ctrl key as well as the Alt key, and type F1 (or 2-6).
Don't know what that ghost terminal is. You're sure it is not a full screen gnome terminal which is getting restarted at bootup? can you close it (Ctrl d) -- what's under it?

donaldt (djt13) said : #7

Thank you for your continued help. I guess you assume I know what the x
session is. I don't. I guess it must be the GUI desktop that starts
when you invoke "startx".

OK, I learned something there. Now, what is terminal 7? Is it one of 7
or more terminals that run under Linux? Ubuntu? I know about the
terminal we use to open a command line. That's what I am trying to get
past or get rid of to start my gui desktop.

Why would I want to go to terminals 1 thru 6? What should I expect to
find there? What has all of this to do with my problem?

I don't know what the ghost terminal is either. It is pure white, about
1/4 the size of my laptop screen and opens with donald@donald-laptop:~$
     so I can type in "sudo startx". When I do that, it says "fatal
server error" ----- is already running" go to x.org for help.
exiting, etc. etc.

So then I shut down and re-boot into the latest kernel-generic
(recovery-mode). Now I have some menu options. I usually use drop to a
command prompt w/network (or without) and if I get to the right terminal
option I can type in "startx" (without sudo) and it boots up my normal
desktop with all the user configured options and I am a happy camper
once again.

I just don't know why I can't stop the terminal window from opening.
You say I can close out the terminal with ctrl-d. Now, that is useful
information. Maybe that will help me, but it doesn't solve the problem
of why it is there in the first place. Until I find a way to stop it
from interrupting the boot-up cycle, I still have not solved my problem.

donaldt

On 04/01/2011 05:26 PM, Ubfan wrote:
> Your question #150786 on gdm in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gdm/+question/150786
>
> Ubfan posted a new comment: The X session typically runs on terminal
> 7, so from any other terminal (1-6), you should be able to get to it
> my holding down the Alt key and typing the function key F7. Once you
> are in the X session, you may leave it and go back to virtual
> terminals 1-6 but you need to ALSO hold down the Ctrl key as well as
> the Alt key, and type F1 (or 2-6). Don't know what that ghost
> terminal is. You're sure it is not a full screen gnome terminal
> which is getting restarted at bootup? can you close it (Ctrl d) --
> what's under it?
>
> You received this question notification because you are a direct
> subscriber of the question.
>

Best Ubfan (ubfan1) said : #8

The prompt on the "ghost" terminal is what you see after login to any terminal, so you must have selected auto login when you set things up -- I never did that, so I'm just guessing. Normally Ubuntu boots up with a gui login, going to a gui (gnome/kde) desktop which is just an application running on X windows. All this gui stuff is running on a virtual terminal, the seventh of seven virtual terminals. The other six virtual terminals sit in the background, and you never see them unless you go looking for them. You may switch among the virtual terminals with the functions keys one through seven (F1 - F7). From any of the virtual terminals 1-6, you may switch to another virtual terminal by holding the Alt key and typing a function key. I just saw a dell laptop today which needed the fn key in addition to the Alt to make the switch work. My HP laptop does not need the fn key (beside the left ctrl key to be pressed. From the gui (on virtual terminal 7) You need to additional press the Ctrl key along with the Alt key, a function key, and maybe the fn key (That's at least three keys, and maybe four).
  If for some reason you boot up NOT on virtual terminal seven, try to go there (since the "startx" command claims there is an X server running). If that does nothing, then maybe you are already there, and the desktop is messed up in some way. Try to go to virtual terminal 2, with the F2 key and the others and see if you get a login prompt. If this happens, lets address fixing your desktop (deleting the .gconf and .gconfd hidden directories is a start, along with the .config/gnome-session directory.

donaldt (djt13) said : #9

Yes, I do have auto login. So, the terminal prompt is not looking for a
password.

As to desktop GUI's, I don't know if I have gnome or KDE. How do I find
out?

I have a function key on my laptop, but the remote keyboard (logitech) I
use at my desk has a windows key there. Is that interchangeable with a
function key?

I have successfully changed the desktop from my current gui (at terminal
7) using control alternate F6 and changing it back again with ctrl/alt
F7. Also able to go to F2 and back to F7 as you requested.

As you said, F7 is where my my normal gui desktop resides.

Ctrl/alt f3 produces the white screen without a password request, the
same as I get on boot-up, that i'm trying to by-pass. F2 thru F6 all
ask for a password, but I can bypass entering ID and password by doing
ctrl/alt F7 which so far has always returned me to my normal gui desktop.

Is this helpful? I'm learning a lot and that is all goodness.

Thanks once again!!

donaldt

On 04/03/2011 09:39 PM, Ubfan wrote:
> Your question #150786 on gdm in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/gdm/+question/150786
>
> Status: Open => Answered
>
> Ubfan proposed the following answer: The prompt on the "ghost"
> terminal is what you see after login to any terminal, so you must
> have selected auto login when you set things up -- I never did that,
> so I'm just guessing. Normally Ubuntu boots up with a gui login,
> going to a gui (gnome/kde) desktop which is just an application
> running on X windows. All this gui stuff is running on a virtual
> terminal, the seventh of seven virtual terminals. The other six
> virtual terminals sit in the background, and you never see them
> unless you go looking for them. You may switch among the virtual
> terminals with the functions keys one through seven (F1 - F7). From
> any of the virtual terminals 1-6, you may switch to another virtual
> terminal by holding the Alt key and typing a function key. I just
> saw a dell laptop today which needed the fn key in addition to the
> Alt to make the switch work. My HP laptop does not need the fn key
> (beside the left ctrl key to be pressed. From the gui (on virtual
> terminal 7) You need to additional press the Ctrl key along with the
> Alt key, a function key, and maybe the fn key (That's at least three
> keys, and maybe four). If for some reason you boot up NOT on virtual
> terminal seven, try to go there (since the "startx" command claims
> there is an X server running). If that does nothing, then maybe you
> are already there, and the desktop is messed up in some way. Try to
> go to virtual terminal 2, with the F2 key and the others and see if
> you get a login prompt. If this happens, lets address fixing your
> desktop (deleting the .gconf and .gconfd hidden directories is a
> start, along with the .config/gnome-session directory.
>

donaldt (djt13) said : #10

Thanks Ubfan, that solved my question.

Homer Blankenship (lorath14) said : #11

What ended up fixing this problem? I am having the exact same issue and cannot get it resolved. I have renamed .gconf, .gconfd and gnome-session but still get the 1/4 sized terminal window.

thanks...