Unable to configure gdk-pixbuf-2.22 even though all reqs are satisfied

Asked by Geoffrey on 2011-07-24

I'm hoping someone can help me with a problem.

I currently am running Ubuntu 11.04 and am trying to build GDK+-3.0 from source. I installed GLIB 2.28.8 and Pango 1.28 with no issue. When I try to compile Gdk-Pixbuf 2.22, I get the following message:

checking for GLIB - version >= 2.25.15...
*** 'pkg-config --modversion glib-2.0' returned 2.28.8, but GLIB (2.28.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.25.25 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gdk.org/pub/gtk/.

I don't understand how I am getting an error? All versions of GLIB on my machine are 2.25.25+. I have read several posts from various forums to try and solve this issue but to no avail. Nearly all the posts say the same thing and the two links below can relatively sum them up:

www.linuxquestions.org/questions/linux-software-2/conflicting-glib-versions-and-glib-config-206130
codelikezell.com/how-to-modify-the-gnu-linkers-default-search-path

I have used rpm to uninstall GLIB 2.0 and when I have subsequently ran it, I'm told that GLIB 2.0 is not installed. I then reinstalled the latest GLIB, yet I still get the same message. I then tried manually removing the glib-2.0 and libglib-2.0.so.0.2800.* directories and then reinstalling. Still no luck. I also used synaptic package manager to remove GLIB 2.28.6 from my system. I reinstalled GLIB and the error message still did not change. Most recently, I tried modifying '/etc/ld.so.conf.d/loc_lib.conf' and '/sbin/ldconfig'. Still no luck.

This brings me to where I am now. At this point I am taking pot shots in the dark and in the interest of not screwing up my system, I am asking if anyone may be able to figure out what might be going on?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdk-pixbuf Edit question
Assignee:
No assignee Edit question
Solved by:
Eliah Kagan
Solved:
2011-07-25
Last query:
2011-07-25
Last reply:
2011-07-24

If you installed GLIB and Pango from source, uninstall them (probably "sudo make uninstall" in each of the source directories). Also undo all the other changes you have made. (For example, if the Ubuntu packages for glib are still removed, reinstall them.) Then simply install two packages: libglib2.0-dev and libpango1.0-dev. That should be sufficient to fix your problem, unless you need the slightly later version of glib for some reason. Since glib 2.28.6 is more than sufficient for compiling gdk-pixbuf 2.22, I am not sure why that would be.

By the way, are you sure you need to build gdk-pixbuf from source at all? It is itself provided in Ubuntu packages (see https://launchpad.net/ubuntu/+source/gdk-pixbuf). You can install them in Synaptic, the Software Center, or with "sudo apt-get install ...". The version of gdk-pixbuf that is provided for Ubuntu 11.04 is actually newer than the version you've been trying to build from source.

Geoffrey (emneter) said : #2

Thank you Eliah. That worked. Also, I used Synaptic for the remaining packages.

I was trying to build from source in an effort to get more familiar with using the shell and understanding how my system works.

Geoffrey (emneter) said : #3

Thanks Eliah Kagan, that solved my question.