gdebi noninteractive dangerous

Asked by Varhegyi Balazs on 2015-04-14

Why gdebi non interactive dangerous?

Documentation doesn't mention to much about it, only:
" --n, --non-interactive
       Run non-interactive (dangerous!)."

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdebi Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2015-04-14
Last query:
2015-04-14
Last reply:
2015-04-14

Because the prompts to change config files on the system may remove functionality

E.g. Updating Samba suggests using the standard (blank) smb.conf file but you may already have an smb.conf file in place that works. The default config of gdebi may be to always use the developer file, removing your settings.

Thanks actionparsnip, that solved my question.