W: Ignoring Provides line with DepCompareOp for package gdb-minimal

Asked by Martin Kohn on 2019-03-13

I get the following message when running apt update:

W: Ignoring Provides line with DepCompareOp for package gdb-minimal

I have Ubuntu 14.04.6 on my system. The gdb-minimal package is not installed.
I have read online that this is just a warning and has no serious consequences.
It is due to the fact that 14..04 has apt version 1.0.1 installed but versioned provides were added in apt 1.0.7

However, gdb-minimal is the only package giving this warning. I wonder if the maintainers of this package can find a way to suppress the warning for apt 1.0.1 or alternatively, if Trusty can be upgraded to apt 1.0.7 ? I did search for a bug report on this issue but found none.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gdb Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-03-13
Last query:
2019-03-13
Last reply:
2019-03-13
Best Manfred Hampl (m-hampl) said : #1

I do not expect that any action is still being done for this issue.

1. As you wrote yourself: "It is just a warning", and
2. Support for Ubuntu 14.04 will end in a few weeks' time anyhow, see https://wiki.ubuntu.com/Releases

I recommend that you upgrade to a supported release of Ubuntu in due course.

Remarks:
There are higher versions of apt in PPAs.
There are bug reports with such issue, e.g. Bug #1428098 Bug #1662227 Bug #1511462

Martin Kohn (mtk001) said : #2

Thanks Manfred Hampl, that solved my question.