.ICEauthority and gconf-sanity-check-2 problem

Asked by Bailey Wray Wilkinson

I recently installed Ubuntu 11.04 Desktop and it was running well (with the exception of needing to uninstall Ubuntu One to allow Nautilus to work correctly), until last night. I put the system in hibernate for a few hours while I was away. I came back and it was running incredibly slowly. I decided to close out of everything and restart the computer. When I restarted it, it gave errors reading "Could not update ICEauthority file /home/bailey/.ICEauthority" and "There is a problem with the configuration server. (/usr/lib/libgconf2-4/gconf-sanity-check-2 exited with status 256)."

I clicked out of the error messages and instead of the Unity interface, I was presented with the older 10.10 version. I then tried to access the terminal and got this message when it popped up: "bash: /home/bailey/.bashrc : Permission denied." Many of the commands also wouldn't work, as if I didn't have access to any files or directories.

I tried to boot in recovery mode and run fsck to see if that would help and received this message after some time: "init: udev-fallback-graphics main process (803) terminated with status 1." I am able to boot normally into a recovery session and then get Unity and Nautilus running.

Here are the ownership details of the file.
bailey@bailey-desktop:~$ ls -la .ICEauthority
-rw------- 1 bailey bailey 4554 2011-08-19 15:14 .ICEauthority

I'm not really sure what else to do about .ICEauthority and I have no idea where to start with gconf-sanity-check-2. I have no idea what information I have provided is relevant, but I suppose that the more in depth I am, the better able someone might be to help.

By the way, I have not been using sudo with any graphical applications. The only command I have used lately that I'm not that familiar with is du. Thanks for any help. =]

EDIT: I also just check the permissions on gconf-sanity-check-2

bailey@bailey-desktop:/usr/lib/libgconf2-4$ ls -la gconf-sanity-check-2
-rwxr-xr-x 1 root root 14704 2011-04-11 07:24 gconf-sanity-check-2

Question information

English Edit question
Ubuntu gconf Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :


sudo mkdir -p /usr/local/etc/gconf/gconf.xml.default

Revision history for this message
Bailey Wray Wilkinson (sirbailey92) said :

That didn't seem to work. The directory didn't exist before, but now that it does, it is still empty and I still have to use the recovery console and the terminal to get Unity and Nautilus running. Once that is done, everything seems to run fine, it is just an annoying, and time consuming, process to have to go through every time I start my computer.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

sudo chown -rwx root:root /tmp; sudo chmod 1777 /tmp

May do it, there are some fixes here:

Can you help with this problem?

Provide an answer of your own, or ask Bailey Wray Wilkinson for more information if necessary.

To post a message you must log in.