how to delete key in ubuntu gnome gconf-editor

Asked by ladin

i'm new user ubuntu and now i use karmic koala codname.
now i want to delete key prog in gconf-editor that installed. but when i click right mouse or find in toolbar etc.. i didn't find any line to delete. please tell me people. thanks

Question information

English Edit question
Ubuntu gconf-editor Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best Sam_ (and-sam) said :

If you mean to unset a key of an app, lets say e.g. gedit, it can be achieved either via GUI or via CLI using gconftool:
gconftool --recursive-unset /apps/gedit-2

##see also manpage
man gconftool

config files of each app are as .xml in
##the dot in front means hidden folder, to unhide folders in Nautilus: ctrl+H

btw. we had once a discussion in bug section of lp about gconf-editor not deleting app entries.
The answer was gconf-editor isn't responsible if an app, after it was removed from the system, still remains in gconf-editor. Then it's a misconception of the app not of gconf-editor.

Revision history for this message
ladin (huunoivp-15071987) said :

thanks Sam for useful answer. i tried to do again and i successfully with program wp-tray. now it working normal. thanks

Revision history for this message
ladin (huunoivp-15071987) said :

but i need to know much gconf-editor and tricks to change ubuntu from this. any one can share to me?

Revision history for this message
Sam_ (and-sam) said :

Acutally there are no 'tricks', every highlighted key shows an explanation in a sub-frame.
Except of a short youtube video (keyword ubuntu tutorials), the (gnome) link already mentioned and gconftool, you may observe what users provide and learning by doing, presume you know what you're doing.

Small examples below can also be achieved via GUI.

Howto make Gedit showing more 'recently used' entries:
gconftool-2 --set --type=int /apps/gedit-2/preferences/ui/recents/max_recents 10

Howto check if Firefox is the prefered browser:
gconftool --get /desktop/gnome/url-handlers/http/command
if it isn't:
gconftool --set /desktop/gnome/url-handlers/http/command "firefox %s"

Revision history for this message
ladin (huunoivp-15071987) said :

Thanks Sam, that solved my question.