what is the value of initiate_edge

Asked by Mark Schultz on 2009-04-06

The following is what I get when I entger 'compiz --indirect' at the command line.
===============================================

nvidia@nvidia-desktop:~$ compiz --indirect
Checking for Xgl: not present.
Detected PCI ID for VGA: 03:00.0 0300: 10de:0a20 (rev a2) (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x1024) to maximum 3D texture size (8192): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz.real (core) - Warn: Unknown option '--indirect'

/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
GConf backend: There is an unsupported value at path /apps/compiz/plugins/scale/allscreens/options/initiate_edge. Settings from this path won't be read. Try to remove that value so that operation can continue properly.
GConf backend: There is an unsupported value at path /apps/compiz/plugins/scale/allscreens/options/initiate_edge. Settings from this path won't be read. Try to remove that value so that operation can continue properly.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gconf-editor Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2009-04-07
Last query:
2009-04-07
Last reply:
2009-04-06
Best Sam_ (and-sam) said : #1

Hi,
please check out in a terminal:
man compiz.real
it tells you why this option is unknown
Warn: Unknown option '--indirect'

>unsupported value at path /apps/compiz/plugins/scale/allscreens/options/initiate_edge

this is because of a default misconfiguration. Nothing to worry about, the key value just has to be empty and the message wont come back again.
Please open gconf-editor and navigate to mentioned path.
Unfortunately a simple reset with right click doesn't do the job.
So right click to edit key value, click on [] in the left section, then click on remove in the right section. Close.
Now, right click again and reset key value, this [] will disappear now. (Along with the same message in .xsession-errors)

Sam_ (and-sam) said : #2

Note:
If you create a profile in Compiz manager CCSM, it will ask if you want to keep default settings.
If yes, you'll have the same message again ....initiate_edge
No, problem.
You can open again gconf-editor
navigate to
/apps/compizconfig/profiles/Default/plugins/scale/allscreen/options
repeat the steps above, finished.

You may create bookmarks in gconf-editor to often used or long pathes.

To backup settings in gconf-editor from a terminal and pass it in a text document
example:
gconftool-2 -R /apps > gconf.backup.txt
gconftool-2 -R /apps/compiz > gconf.compiz.backup.txt

Mark Schultz (mschultz) said : #3

Thanks Sam, that solved my question.

Mark Schultz (mschultz) said : #4

I appreceate the time you took for the feedback. I actually just plugged a '0' in it yesterday in "initiate_edge", and it solved my problem. It also solved a problem that when I ran compiz from the command prompt, it would loose the window edge.

Thanks again,

Mark