how to know the key not listed in the gconf-editor

Asked by mohamodenuhafiza


in Ubuntu I can choose "System->Preference->Appearance" , in the pop-up window , choose "fonts" tab , then choose "Best shapes" in the "Rendering".

this operation will fix some application's non-English character problem.

My Question is if I want to do a configuration to all clients, I need to know the key in gconf-edirtor, like /desktop/gnome/background/picture_filename to set the backgourd file picture.

Could some guy tell me the key in this situation?

thanks in advance!

Question information

English Edit question
Ubuntu gconf-editor Edit question
No assignee Edit question
Solved by:
Marc Stewart
Last query:
Last reply:
Revision history for this message
Marc Stewart (marc.stewart) said :

The rendering options alter two keys that I know of:

If you open gconf-editor and look in /desktop/gnome/font_rendering then switch back and forth between the Font Rendering options in the Appearance Preferences window, you'll see these two keys changing.
Best shapes uses "grayscale" antialiasing and "medium" hinting.

Revision history for this message
mohamodenuhafiza (nofiza) said :

hey Marc

Thank you very much, That's it.

one more question, is there some documentation on these key? Then next time I can read that to find out the answer.

Revision history for this message
Best Marc Stewart (marc.stewart) said :

I don't know whether there's any online documentation, but GConf is supposed to be self-documenting, through the use of schemas. If you open gconf-editor, you should see that the lower-right section is labelled "Key Documentation". When you click on a key, this gives you a bit of information about it, including valid values—so long as there's a schema for it. (There's always supposed to be one, but GConf works without them, so sometimes there isn't.)

That self-documentation, coupled with the search function (Edit > Find...; or Ctrl-F) has often been all I've needed.

Revision history for this message
mohamodenuhafiza (nofiza) said :

Thanks Marc Stewart, that solved my question.