avr plus gcc synaptic downloads haven't arrived from requests?

Asked by John D Kephart on 2011-09-23

Dear Ubuntu and spt staff:

Have several questions:

In your repositories and linux in general there are numerous avr atmel series compliers, etc for linux os. Via sysnaptic manager had requested all I saw available around 6 items for download. Only rcvd 1 the USBProg what happened to all the rest of the avr downloads??

Also via synaptic manager requested the gcc and gcc ++ version 4.____ gnu compilers so when will I get those?

Finally I'm using the Ubuntu Lucid lynx os and on the version I had prior made some sort of error I think? That results in something referred to as the cannocal root in main menu programming area. Though that would disappear when I upgraded to the Lucid lynx but did not and still there.

Is it supposed to be thtiere or can it be deleted out of the programming menu tab???

Microcontrollers I understand but linux still somewhat beyond me yet.

Thanks for any help and your time.

Best regards John

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gcc-defaults Edit question
Assignee:
No assignee Edit question
Solved by:
John D Kephart
Solved:
2011-09-25
Last query:
2011-09-25
Last reply:
John D Kephart (techandsci) said : #1

On the avr types have no problem using the windows versions in linux as all will run under the wine app
just fine.

However linux has it's own avr atmel modules with some other options.

Those were listed by the synaptics manager in Ubuntu, out of 6 or more of those had
only recieved 1 so far. Called USBprog aka and one of the avr programmers.

Wondering where the others are or why does it takes so much time to receive those???

Same on the GCC C compiler and GCC ++ Version 4.04 compilers which hadn't showed up yet either???

There were a lot of dependencies that had to be included for those as well so added up to around
8 or 12 files total I think.

******
Do others have the same delay problems on these or do any know how long it takes, seems very
strange to me???

Thanks and

Best regards John

John D Kephart (techandsci) said : #2

Salutations:

If I've placed my indquires in the wrong area of Ubuntu here any should feel free to let me know and in what area I should post.

Only need the linux avr files which are in the repositories that Ubuntu lists.

In synaptic mgr when I applied it appeared to accept for downloading but had a msg that such would come at a later time??

*****
My basic question there is why do we have to wait for those?

Must be some reason, as most other things there usually download right away?

Has anyone else had same results when ask for the AVR downloads with the synaptic mgr???

Also:

Do all Lucid Lynx users have in their main menu's programming selection or tab that called Root
which connects to this Cannicol source root???

Ask because I got it placed there by accident on a former version, and it's stayed there on
this version.

I had thought all users on their machines with ubuntu os on them had their own separate
root directory not one tied into the Connical companies???

GCC Solved:

On the GCC stuff I can probably forgo that altogether as didn't realize till checked into it tonight that it uses the MinGW utils for all of that. So my error there.

I already have a full working MinGW C++ system running under wine so I can forgo that since GCC the same or based on that I guess anyway.

Best regards

John

John D Kephart (techandsci) said : #3

Ok think I see why no response.

Something I should have thought about was the very structure of linux itself.

Had been quite a long time and only remembered the basic files in the file system,
never that intimately though.

*****
Your marking alongside to the right of the question in answers lost prompted me to look
there.

To my surprise found pretty much all I was looking for there from gcc to avr series and
from that also found same was already in the linux files usr/lib area on my pc :)

******
Will be reading that answers on default gcc areas a lot as was a lot of good infos in the
answers of that section posted by those here which I'll need.

Installed geany and will add the debug option to it, very pleased and tickled that can
do the c++ directly on the gnu gcc itself had wanted to learn for sure, plus every
avr atmel file wanted in linux was already there too.

Best regards.